Jump to content
coords

Reboot instead of shutdown

Recommended Posts

Reboot instead of shutdown

Does anyone have any idea what I can do to prevent my machine from rebooting when I try to shut it down? Thank!!

Share this post


Link to post
Share on other sites

Can you shut down the machine through the terminal using this command:

sudo shutdown –h now

It may prompt you for confirmation after putting this command in, but it may work.

If you're wanting to put it into a script that you can run without having to remember the command:

echo "#!/bin/bash" > shutdown.sh
echo "shutdown -h now" >> shutdown.sh
chmod 777 shutdown.sh

To call that script:

sudo ./shutdown.sh

 

  • Like 1

Share this post


Link to post
Share on other sites

The script seemed to work, but sadly exactly the same result. The machine seems to shutdown but actually reboots. An extremely annoying bug since I manager this machine headless via my iOS devices.

Share this post


Link to post
Share on other sites
15 hours ago, coords said:

The script seemed to work, but sadly exactly the same result. The machine seems to shutdown but actually reboots. An extremely annoying bug since I manager this machine headless via my iOS devices.

Okay so I may have found the answer from insanelymac regarding the same issue with Yosemite (which seems to be an issue with Clover bootloader and the motherboard being used)

 

Quote

You can try this setings

<key>Fixes</key>
<dict>
        <key>FixShutdown_0004</key>
        <true/>
</dict>

or

<key>SlpSmiAtWake</key>
<true>

It adds SLP_SMI_EN=0 at every wake. It may help solve sleep and shutdown issues on UEFI boot.

Those settings have to be added to your /EFI/CLOVER/config.plist file if they're not already in there.

I haven't tested these since Yosemite doesn't seem to have shutdown issues, but some members on that thread were saying that adding one of those settings to their config.plist file helped with their power issue.

  • Like 1

Share this post


Link to post
Share on other sites

thanks for your reply!! Sadly my machine has a bios & this setting is not applicable as far as I know. Any other suggestions would be welcome!!

On 5/24/2017 at 2:25 PM, KimChoJapFan said:

Okay so I may have found the answer from insanelymac regarding the same issue with Yosemite (which seems to be an issue with Clover bootloader and the motherboard being used)

 

Those settings have to be added to your /EFI/CLOVER/config.plist file if they're not already in there.

I haven't tested these since Yosemite doesn't seem to have shutdown issues, but some members on that thread were saying that adding one of those settings to their config.plist file helped with their power issue.

 

Share this post


Link to post
Share on other sites

Greetings to you all! My hackintosh is running macOS High Sierra 10.13.2 and I was able to fix sleep and shutdown issues with a series of terminal commands. They must be entered in the order listed below. I hope it helps you guys too.

sudo defaults write /System/Library/LaunchDaemons/com.apple.securityd ExitTimeOut -int 5

sudo defaults write /System/Library/LaunchDaemons/com.apple.mDNSResponder ExitTimeOut -int 5

sudo defaults write /System/Library/LaunchDaemons/com.apple.diskarbitrationd ExitTimeOut -int 5

sudo defaults write /System/Library/LaunchDaemons/com.apple.coreservices.appleevents ExitTimeOut -int 5

sudo defaults write /System/Library/LaunchAgents/com.apple.coreservices.appleid.authentication ExitTimeOut -int 5

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...