Jump to content
  • 0
HackintoshMumbai

VMware Unlocker to Run Mac OS X Guests in Windows 7/8/8.1

Question

To be a Hackintosh user in desktop virtualization software VMware is must For making USB installer,Restoring images and so on then the “VMware unlocker” is a compulsory utility to run Mac OS X guests. This unlocker utility over right  few VMware program files to be able to install and run latest 10.7,10.8 and 10.9 Lion OS X guests. 

Here is the download links 

 

How to unlocker VMware workstation ?

I have updated the screenshots for latest 1.2.0 Unlocker I can confirm that latest 1.2.0 unlocker works well with VMware workstation 9 on Windows 10

Its very simple to Unlock/Patch. Close all VMware programs (if opened)

Extract the downloaded file. The latest Unlocker is having patch for Windows, Linux, Fusion 4.0 on Snow Leopard and Lion and VMware ESXi 5.

Before run the patch, its recommended to take a backup of VMware program folder, because this patch will replace the original files. Right click on install.cmd file and select run as administrator option as shown below. ( or you can start the command prompt as administrator in Windows 7/8/8.1 computer and execute install.cmd from command prompt)

 

The successful patch will return the following screen (and disappears automatically)

That’s it. You patched the VMware workstation 10, 9, in Windows 7/8/8.1 host to run Mac OS X 10.5 and higher guest. Restarting the host computer is not required here.

 

2.png

 

Following screenshot are just a example

 

Before Unlocking/Patching VMWARE WORKSTATION 

1.png

 

After applying patch with VMware unlocker – One more Guest OS type and versions.

 

3.png

 

Note:-By using this VMware patch you can install any MAC distro like iAtkos , Niresh12495 in VMware 

          workstation but source file should be in iso format else won't works 

 

Source 

http://hackintoshmumbai.blogspot.com/2014/01/vmware-unlocker-to-run-mac-os-x-guests.html

Edited by HackintoshMumbai

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
Guest InfamousSynergy

just to point out, I have no clue what it does but I did notice when installing, when you select your installation drive then hit customize, there is a kext for VMware support.

Share this post


Link to post
Share on other sites
  • 0
Guest InfamousSynergy

Also, have you tried finding a pre built machine online?

Share this post


Link to post
Share on other sites
  • 0

Specs;
Windows 7 64bit, VMware 10.0.1 build-1379776, OS X 10.9.0 & Unlocker 1.2 or 1.3
 
I had this working nicely for a while with no problems.. all VM's worked- Linux, OSx, etc..
 
Now when starting any VM inside VMWare I get pop up error;
 
----------------------------------------------------------------------
The following error occurred when starting VMware Workstation. 
 
W32AuthConnectionLaunch: WriteFile filed (code 6).
-----------------------------------------------------------------------
 
This is caused by Unlocker Ver 1.2 or ver 1.3
Specificly vmware-vmx.exe file that the unlocker modifies.
 
I have uninstalled and deleted all folders in Vmware and reinstalled. Everything works except OSX - Just get the spinning boot symbol
. Then run Unlocker (install script) as a Admin in safemode. Restart system and VMware or VMPlayer get the top error message again.
 
When replacing it with original vmware-vmx.exe (before) running unlocker, it works again.
 
 
Anyone else having problems?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $17.56 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • HI i have this card ATI Radeon HD 5770 Series and I have it working, but I got a problem with vram only have 7 mb I need help to solve this because i have problems with some glitches in the display. I haver clover . PD: My graphics card have 2gb      
    • Hi, I am trying to make bootable USB for Hackintosh , I tried TRANSMAC and Win32disk image from my Windows 10 PC, soon after completion USB not accessible. Please advise.   Thank you,  
    • That's happen every time that i am trying to install a hackintosh on my pc i can't find a solution. I tried a lot of different flags.  Pc specs:  GeForceGTX760 4GB Intel i7-4820K MSI Global X79A-GD65 (8D)   There is a video: https://streamable.com/us6nf  
    • nobody can help me
    • I have a GA-H81M-S mobo with G3240 Pentium (R) processor. I am not using the IGP but an Nvidia GT-710 1GB DDR3 dedicated Graphics card. I followed posts in other forums and managed to install once. After upgrade and reboot, I messed with clover configurator and now I can't get to the install screen. I get stuck on VoodooPS2Mouse: Version starting on OS X Darwin 16.4. If this forum is still alive, please help
  • Download Statistics

    • Files
      855
    • Comments
      2,150
    • Reviews
      2,619

    Latest File
    By Niresh

    230    2

×