Jump to content

AMD Radeon 7770 bug graphics

Recommended Posts

AMD Radeon 7770 bug graphics

Hello all, 

Hope you are well !



I have install Sierra on my AMD computer. My config : 


Mother Board ; M5A78L-M/USB3

Processor :  AMD FX(tm)-4170 Quad-Core Processor

Graphics Card : AMD Radeon HD 7700 Series  -   AMD Radeon Graphics Processor (0x683D)

RAM : 10 GB



The install was successful and I boot on Mac with the bootloader Enoch R2848 and boot flag:

-v npci=0x2000 

Sound, internet work great but the graphics don't work well, I have no acceleration graphics and bug (see capture):


Can you please help me to add kexts or other?

Thanks a lot in advance,


Have a nice day,




Share this post

Link to post
Share on other sites



Please I try different thinks but doesn't work... Any idea ? I muss change boot loader like clover or impossible ?





Share this post

Link to post
Share on other sites

I may have found a possible solution to your problem Léonardhttp://www.macbreaker.com/2013/03/radeon-7000-hackintosh.html

Essentially this will be the process for your machine:

  1. Set your BIOS to default to your integrated graphics (IGPU)
  2. Plug your monitor into the Radeon HD 7770
  3. Use the following bootflags: 
-v GraphicsEnabler=No npci=0x2000


Then you might have functioning QE/CI, otherwise you'll either want to pick up a known functioning Nvidia GPU for OS X Sierra or resort to downgrading the version of OS X to a known functioning version. (I think 10.8.3 is the minimum supported version for the HD 7770 (Mountain Lion) see this post for specific variants of the Radeon HD 7000 series cards that are known to work: https://www.tonymacx86.com/threads/list-of-confirmed-radeon-hd-7xxx-series-10-8-3.92952/ )

Share this post

Link to post
Share on other sites



ok I have been struggling with this for the past 2 weeks. I have installed and uninstalled Sierra more times than I can count and its been driving me potty .... have only cracked it today.  what you need to do is download create a vanilla usb stick with Sierra.  in order to do this I downloaded Yosemite.zone from the distroes  and created a usb stick.  the installed Yosemite once I was in Yosemite  ( the gfx work in this disto) I downloaded a copy of Sierra from the store..  you will have to search the net for the direct link.. I then created a bootable Sierra usb stick using unit beast, I selected legacy boot loader with no gfx injected. I then installed Sierra from this. once Sierra is installed boot from the usb and select your installed Sierra. iff all goes well you should have a working Sierra install with the gfx acceleration working.  I think the problem is with the type of Mac that Sierra thinks it is with everything working my system info is showing a iMac 27" 14.2 .  I have tried installing a boot loader on the main drive with no success so as a workaround you will have to use your usb stick.

pics below of my system info 

I hope this helped. 


I also just noticed whilst I was trying to get thing working I copied a modified andradeonx4000.kext into the root drive of the Sierra stick. I don't know if this has had any effect on the install might be worth doing the same thing


Share this post

Link to post
Share on other sites

Hi have been looking into this a bit more,  it turns out it is the boot loader that is at fault.  what you need to do is copy verde.kext to your clover efi partition Clover/Kexts/10.12 then copy EMUVariableUefi-64.efi to drivers64UEFI Folder in the Clover refi partition then copy Lilu.kext and WhateverGreen.kext to Clover Kexts Other then reboot.  Have produced a how to here  With the Kexts Here https://1drv.ms/f/s!AsV7QRaRFGYgiJM_PMa-vhuv9vJ7_Q


Hope this helps.  if anyone who knows /Hackintoshing in more depth could streamline this as I don't think all the kexts are needed but by doing the above got me into a working Sierra install 

Hope this helps




Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.

    $17.56 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • HI i have this card ATI Radeon HD 5770 Series and I have it working, but I got a problem with vram only have 7 mb I need help to solve this because i have problems with some glitches in the display. I haver clover . PD: My graphics card have 2gb      
    • Hi, I am trying to make bootable USB for Hackintosh , I tried TRANSMAC and Win32disk image from my Windows 10 PC, soon after completion USB not accessible. Please advise.   Thank you,  
    • That's happen every time that i am trying to install a hackintosh on my pc i can't find a solution. I tried a lot of different flags.  Pc specs:  GeForceGTX760 4GB Intel i7-4820K MSI Global X79A-GD65 (8D)   There is a video: https://streamable.com/us6nf  
    • nobody can help me
    • I have a GA-H81M-S mobo with G3240 Pentium (R) processor. I am not using the IGP but an Nvidia GT-710 1GB DDR3 dedicated Graphics card. I followed posts in other forums and managed to install once. After upgrade and reboot, I messed with clover configurator and now I can't get to the install screen. I get stuck on VoodooPS2Mouse: Version starting on OS X Darwin 16.4. If this forum is still alive, please help
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By Niresh

    230    2