Jump to content
Sign in to follow this  
Uros Jovanovic

Graphic Artifacts

Recommended Posts

Hello, yesterday i successfully installed and booted OS X 10.8.2 on my AMD machine but there is a problem with graphics.

 

It's not about the drivers, OS X is recognizing my card (Saphire 6870). But there are strange graphic glitches, screen tearing etc. Safari is unusable, the text is all messed up. Also sometimes folders wont show files until i move the window and it glitches out.

 

I tried booting with GE=no, the artifacts occur a little bit less but in Kext wizard i see that AMD6000Controller is still loaded.

 

Is there a way to fix this? I read that it's AMD kernel problem and that it cannot be solved... :(

 

using following bootflags on Clover bootloader:

 

-v darkwake=0 npci=0x2000

Share this post


Link to post
Share on other sites

why dont u try the latest 10.8.5

Share this post


Link to post
Share on other sites

I guess i was too late to the party xD You think it would help me with the problem? Is AMD kernel changed there?

Share this post


Link to post
Share on other sites

Old amd kernel still have glitchs like u saidThere are two option to resolve first Replace the amd kernel with latest one and second as niresh said try niresh latest iso

Share this post


Link to post
Share on other sites

SOLVED:

 

Downloaded latest AMD kernel for 10.8.x from here: http://www.osx86.net/file/3694-amd-108x-kernel/?st=10#commentsStart

 

Swapped the kernel via Terminal using instructions from here: http://rubayathasan.com/tutorial/osx86-changing-default-kernel/

 

Rebooted and there are no glitches anymore. Also, the system boots a lot quicker now. I'm happy :)

 

Tnx everyone for help and I hope that this thread will help someone else.

 

Cheers and happy hacking!

Share this post


Link to post
Share on other sites

use this flag  -v amd pci=acpi busratio=19

Share this post


Link to post
Share on other sites

SOLVED:

 

Downloaded latest AMD kernel for 10.8.x from here: http://www.osx86.net/file/3694-amd-108x-kernel/?st=10#commentsStart

 

Swapped the kernel via Terminal using instructions from here: http://rubayathasan.com/tutorial/osx86-changing-default-kernel/

 

Rebooted and there are no glitches anymore. Also, the system boots a lot quicker now. I'm happy :)

 

Tnx everyone for help and I hope that this thread will help someone else.

 

Cheers and happy hacking!

Thanks woky and niresh!

I used this kernel: http://www.osx86.net/file/3716-1085-amd-kernel/

This worked for 10.8.5 too and now I have a fully (95%) working  OSX.

 

Things what is not working for me but I don't need that:

- iCloud

- can't wake up from Sleep 

 

I can play opengl games like Team Fortress 2 with full speed!

 

My specs:

Motherboard: Asrock Extreme 3

CPU: AMD FX-8120

RAM: 8GB

GPU: ATi Radeon 5670 1GB

HDD: Samsung 320GB Sata2

 

Posted Image

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.30 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

  • Download Statistics

    • Files
      855
    • Comments
      2,148
    • Reviews
      2,612

    Latest File
    By Niresh

    188    2

×