Jump to content
Sign in to follow this  
mdg1618

no bless setting for a primary boot program was found

Recommended Posts

mdg1618

no bless setting for a primary boot program was found


Hello:

I had Yosemite 10.10.5 installed on my PC (PC specifications are noted below) via "Niresh's Yosemite with AMD & Intel ISO & USB" and everything ran well.

Recently, I tried to upgrade to Sierra OS via "Hackintosh Sierra Zone", but ran into some problems. I rechecked my BIOS settings and everything was OK and I also checked (verified) my SSD, which was also OK.

During the booting of my system, I use the flags:
cpus=1 npci=0x3000 nv_disable=1
which allows me to get to the install screen, where I am able to access Disk Utility to erase my SSD.

Afterwards, I use the "Customize" button within the macos installer to install needed drivers and kexts (I have tried to install Sierra OS without changing any of the settings as well).

At last, I press the "Continue" button within the macos installer and after a couple of seconds, I get a message:
"no bless setting for a primary boot program was found"

I searched the forum and found a similar problem and deleted "OsxAptioFix2Drv-64.efi" from: HZ/EFI/CLOVER/drivers64UEFI using Windows 10, because I did not know how to do it in the terminal.

Even after the deletion of "OsxAptioFix2Drv-64.efi" I still receive the message "no bless setting for a primary boot program was found". I also tried to install Sierra OS onto my system by utilizing different USB ports on my PC.

I have searched for common boot flags to alleviate this problem and I have searched the Web as well with no solution found until now.

 

Thank you in advance for your assistance towards this matter.

 

PC Specifications:
MoBo: Asus Rampage IV Black Edition (BIOS:0602 x64)
CPU: Intel i7-4930K
GPU: PNY Geforce GTX 780 Ti 3072MB OC
Memory: 4 x 4GB Corsair Dominator Platnium 16GB (4 x 4GB) DDR3 DRAM 2133MHz C8
PSU: Super Flower 1000W
CPU Cooler: Cooler Master Nepton 280l
System Drive: Samsung 840 Pro - 128 GB SSD
Storage Drive: 2 x Seagate Barracuda 7200.14 ST3000DM001 3TB - 7200 RPM 64MB Cache

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...