Jump to content
Sign in to follow this  
Ala'a Taha

[Solved] Can't find /mach_kernel

Recommended Posts

Can't find /mach_kernel

I got "Can't find /mach_kernel" when trying to boot from HDD. Using Chameleon bootloader, it was working fine yesterday, but today it didn't and even after I do a new clean installation of Sierra zone. 

My device specs are:

  • HP pavilion dv6-6c01ej
  • intel i3-2350M
  • 8 GB rams
  • AMD Radeon HD 7470M

Edited because of typo, user used mach_kernal instead of mach_kernel

Share this post


Link to post
Share on other sites

Are you having this issue after installation or before?

try this Kernel flag with Chameleon, Keep me updated

Kernel=kernel

  • Like 1

Share this post


Link to post
Share on other sites

It shows after installation. 

After set Kernel flag = kernel

same error appears with message "can't find /kernel"

Share this post


Link to post
Share on other sites

Kernel flag isn't Kernel flag = kernel, you have to type the following fully

Kernel=kernel

or you can try the full path

Kernel=/System/Library/Kernels/kernel

 

  • Like 1

Share this post


Link to post
Share on other sites

I know that, I do using Chameleon wizard under Boot Flags tab. 

The second one 

Kernel = /System/Library/Kernels/kernel

made the boot process crash and restart

  • Like 1

Share this post


Link to post
Share on other sites

Can you post a pictures of the crash in verbose mode?

Share this post


Link to post
Share on other sites

Unfortunately it didn't. 

And the blog doesn't allow Dropbox or google drive links, can I send you the picture on email 

Share this post


Link to post
Share on other sites

@Ala'a Taha You can post drop box links or Imgurl links are you facing any issues while pasting links?

Cl.ly is a better alternative

Share this post


Link to post
Share on other sites

Thanks in advance, I know that I realy annoying you with this.

https://drive.google.com/open?id=0B4qKvozZb2czZUo2Vlc3ZVZLY3c

Sorry I tried to use "Insert other media" option :evilgrin:

  • Like 1

Share this post


Link to post
Share on other sites

Do you have a chameleon theme installed? 

i think yes....

Share this post


Link to post
Share on other sites

yes

Share this post


Link to post
Share on other sites

Remove the theme folder, usually i prefer the legacy CMD mode for Chameleon, it works better

Remove the folder and then post the result

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Are you booting from the HD, or the USB? 

Did you upgrade the Chameleon Bootloader?

What happens if you don't add the -v ?

Remove all the files in /Extra folder, except org.chameleon.Boot.plist then try booting, post results

  • Like 1

Share this post


Link to post
Share on other sites

I'm trying to boot from HD, the USB work fine. 

Thanks for your time, I do a clean installation without messing with the bootloader, the stock bootloader (Clover) is working now. 

Thanks again 😊

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $21.95 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

  • Download Statistics

    • Files
      855
    • Comments
      2,150
    • Reviews
      2,619

    Latest File
    By Niresh

    236    2

×