Jump to content
monda7

HDMI audio not working

Recommended Posts

HDMI audio not working

i have just installed yosemite, and everything is fine but the audio does no work on my tv, i use cdmi connection, and the video works fine but no audio; any help?

Share this post


Link to post
Share on other sites

I'm assuming you are using voodooHDA. From within the sound preference pane, check if the HDMI output is selected.

If you're not using voodooHDA, then please provide more details. e.g. system specifications. Do you have sound through your speakers  (intern or extern using the green audio jack on your motherboard)?

Share this post


Link to post
Share on other sites

yes i'm using voodoo.
 from hdmi no sound at all, and from the jack i can hear an annoying continuous buzz but the sound works

mb: lenovo sharkbay
intel core i5-4460
ram : 4gb 
gtx 745

 

Screen Shot 2017-02-28 at 18.49.33.png

Screen Shot 2017-02-28 at 18.49.41.png

Share this post


Link to post
Share on other sites

Can you go to System Preferences -> VoodooHDA? Are you able to change the HDMI settings there? Also, which version of VoodooHDA are you using?

You can check by going to terminal and write "kextstat | grep VoodooHDA"

Share this post


Link to post
Share on other sites

i've eliminated the buzz when i'm using the audio jack, but still not working with HDMI
 

Screen Shot 2017-02-28 at 19.00.39.png

Screen Shot 2017-02-28 at 19.03.45.png

Share this post


Link to post
Share on other sites

Try updating to VoodooHDA 2.8.9. Also, my PCM and iMix are both at 100%. 2.8.9 fixes the buzz.
Schermafbeelding 2017-02-28 om 19.11.35.png


 

Share this post


Link to post
Share on other sites

sorry i'm not so practical, how can i update voodoo?

Share this post


Link to post
Share on other sites

1. Download both files from the link provided.
2. If you do not have Kext Utility already, you can download it from here.
3. Open Kext Utility, enter your password and drag "VoodooHDA.kext" in it.
4. Open System Preferences. Right click on VoodooHDA and delete it.
5. Drag your newly downloaded VoodooHDA.prefpane into your System Preferences screen.

Restart your computer.
 

Share this post


Link to post
Share on other sites

I'm having the same problem and I've tried this and still nothing. Can someone please help me out with this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $21.95 of $100.00 goal reached.
    Donate Now
×