Jump to content
Sign in to follow this  
neostyles

How to disable Airplay on Yosemite 10.10.1

Recommended Posts

How to disable Airplay on Yosemite 10.10.1

Hey all, 
I have a Yosemite 10.10.1 and I was wondering if there was a way to disable airplay so I don't keep seeing my neighbors devices as audio outputs.   Thanks in advance! Any ideas would be appreciated!

Share this post


Link to post
Share on other sites

To disable AirPlay
Open terminal and write
sudo chmod 000 /System/Library/CoreServices/AirPlayUIAgent.app/Contents/MacOS/AirPlayUIAgent

To enable AirPlay again
Open terminal and write
sudo chmod 755 /System/Library/CoreServices/AirPlayUIAgent.app/Contents/MacOS/AirPlayUIAgent

On a special side note: if you are ever planning on updating to El Capitan or Sierra (or anyone who has the same question and is on El Capitan or Sierra), the above commands only work when you disable SIP.

SIP should be disabled within your bootloader. If it's not the case you can do it by booting into Single User Mode (bootflag -s).

While in Single User Mode:

To disable SIP
Write "csrutil disable"
Reboot

To enable SIP again
Write "csrutil enable"
Reboot

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...