Jump to content

Mountain Lion 10.8.5 on VirtualBox

Recommended Posts

Mountain Lion 10.8.5 on VirtualBox

Hello folks

I'm new to Hackintosh, and maybe someone could help me.

I'm trying to install Mountain Lion 10.8.5 (Niresh's release) as a virtual machine on Oracle VirtualBox (version: VirtualBox-5.0.20-106931-Win). The OS on my host machine is WIndows 8.1 x64.

The specs of my machine (I made two screenshots, as my machine is a laptop with dual graphics, in one you can seel the Intel HD graphics card, in the other one the AMD Radeon):


The specs of the virtual machine are as follows:


No matter what I do, it doesn't even finish booting, it always hangs at the following message:


I googled as much as possible, as far as I found out, FakeSMC is responsible for tricking MacOSX into believing it is being installed on a MAC, right? How can that even be that it finds a physical SMC when my computer is definitely not an Apple and on top of that I don't even bott into my physical PC but into a virtual machine?

What I've tried so far:

- disabling my AMD graphics card in device manager (shouldn't be an issue anyway since VirtualBox fakes another graphics card anyway, but who knows...)

- tried booting in safe mode as per your site "Debugging your Hackintosh"

- tried both ncpi=0x3000 / ncpi=0x2000 boot flags

- tried GraphicsEnabler=Yes / No  (both options)

- tried PCIRootUID=1/ PCIRootUID=0

What else could I try?

Treid googling of course, but didn't found a solution to my specific problem, neither on the net in general nor on your page specifically.

Any help is greatly appreciated, and I thank everyone who takes the time to read my post.




Share this post

Link to post
Share on other sites

Okay, I figured the first step out myself, it's so easy it's almost embarrassing, but I'll leave it here anyway so others who have the same problem can google a solution:

It seems that Oracle tried to program some sort of FakeSMC into VirtualBox themselves, and that their way of doing it somehow is recognized as a physical SMCDevice by FakeSMC.

I just had to change one setting:

Instead of OSX as the guest operating system I just used the generic "Other/Unknown(64bit)" setting VirtualBox offers, and voila, now I can boot into the installer.

Just installing now, let's see how this goes. :)



Share this post

Link to post
Share on other sites

And here's another point:

I don't really know why, but VirtualBox only needs to be set to "Other/Unkown" for botting from the ISO file. After MacOSX is installed on a virtual hard drive, I even had to change the setting back to "Mountain Lion", or it would hang at boot. But now I got it up and running, only small issues (like keyboard layout) need to be fixed.

Share this post

Link to post
Share on other sites


Two more things I got fixed:

Mountain Lion didn't recognize the standard Intel network card which is "meulated" by VirtualBox, and I couldn't get it to work, no matter what I tried.


Use the Paravirtualized Network (virtio-net) option in VirtualBox for your guest, and, on the guest, install the following driver:


Also, I didn't get any sound initially, the solution is found here:


Just follow from step 6 on, I didn't need the rest of the steps, as installation of Niresh's ISO worked mostly out of the box (apart from the tiny setting I had to adjust as according to my second and third post).

Things I still couldn't figure out:

Weirdly enough, the resolution is fixed at 1152x864.

I did everything I found on the internet, including putting my desired setting into the com.apple.Boot.plist:



Also, I put my desired settings into the org.chameleon.bootlist.pl:



<key>Kernel Flags</key>

<string>npci=0x3000 darkwake=0 "Graphics Mode"="1680x955x32"</string>

And of course into the VirtualBox settings file:


Does anyone know what I could still try to get my desired screen resolution?

Also, a final problem:

The guest doesn't shut down properly. The VirtualBox Window doesn't close automatically, and VirtualBox keeps on producing a high processor load on the host's processor even half an hour after I have shut the guest down. The guest remains stuck at the following screen:


At least, it doesn't cause any issues, on teh next bootup, MacOSX doesn't "complain" it hasn't been shut down properly.

Still, I'm a perfectionist, any advice on that one?



Share this post

Link to post
Share on other sites

bm, thanks for the clue about selecting unknown/64 .  I was dieing during the install boot as the same point.

Its still installing. I'll post an update as to how it goes.




Share this post

Link to post
Share on other sites

Hi scottyd

I'm glad my post was somewhat helpful.

I think I partly figured out why it is the way it is. Apparently, when you choose some "MacOSX" in VirtualBox, some sort of SMC is already emulated, and this doesn't work with the fake SMC included in Niresh's installer.




Share this post

Link to post
Share on other sites

It installed and boots up fine.  Since there is no GuestEdition for mac guest, andmy network is down, how did you copy the nio network driver from your host to the guest?



Share this post

Link to post
Share on other sites

I burned a dvd with the network driver and mounted that in the mac guest.  installed it and the net work is up!




Now to get the screen resolution up to a usable setting?


thanks, scott

Share this post

Link to post
Share on other sites

Hi Scott

I didn't even go to the trouble of physically burning a CD/DVD, I used CDBurnerXP, which can create an ISO file without the need of a physical DVD. Then you can just mount that ISO file straight into your virtual machine. (https://cdburnerxp.se/de/home)

I tried fiddling around with the screen settings a lot, but it seems in order to change the resolution, you have to use EFI, which in turn doesn't seem to work properly with that Mountain Lion release.

What I did was an upgrade to the latest OSX, El Capitan, following the instructions to be found here:


Getting the ISO I created in Mountain Lion to my host machine was easy, as networking worked, so I just used an SMB share on my physical machine to copy it over.

This is even better, now I got the most up-to-date OS, which actually was my plan right from the beginning.

What made me choose Mountain Lion in the first place was that I didn't want to steal from Apple, but I couldn't find a place to purchase an El Capitan license, but I could purchase a license for Mountain Lion for 19,99 (Euro). And I guess since El Capitan is a free upgrade, that license I got includes the upgrade.

The good thing about El Capitan was that many things worked out-of-the box (Audio driver, networking). With networking, you have to make sure that in VirtualBox you choose the "Intel Pro/1000MT Server" option, as El Capitan doesn't work with the Intel Pro/1000MT Desktop network card.

Setting the screen resolution worked flawlessly as described in that El Capitan installation guide.

I hope I could be of help. :)



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.

    $22.30 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • did you know the RX580 sapphire works out of the box to get it to work just let the pc go to sleep and thin wake it up make sure all monitors are hooked  up before you boot up the system. let me know how it works for you. here is the specs of my machine    HP Z800 2 x 3.07 GHz 6-Core Intel Xeon 16 GB 1333 MHz DDR3 Radeon RX 580 8192 MB 2 monitors and a 60 inch samsung uhd tv   thank you all for reading my post I have ben working in apple products for years and hackintosh from the beginning .
    • (MAC & PC) macOS Multi Boot USB Project [KEAL-kealOS’es] – Kemal ALKIN – RAW Image   Support – Apple Macintosh | PC (CLOVER Bootloader/Önyükleyicisi UEFI & Legacy BIOS) – Destekler. SSD NVME & SSD TRIM Desteği / Support : CLOVER | Apple Macintosh (SSD Trim Terminal.app Command: “sudo trimforce enable“) (Kernel & Prelinkedkernel) AMD / Ryzen CPU (İşlemci) | Intel CPU (İşlemci) Native/Doğal Destekler – Support macOS versions/sürümleri: (MBR: Master Boot Record – GPT: Guid Partition Table) Mavericks 10.9.5 – MBR & GPT (AMD/Ryzen + Intel Native) Yosemite 10.10.5 – MBR & GPT (AMD/Ryzen + Intel Native) EL Capitan 10.11.6 – MBR & GPT (AMD/Ryzen + Intel Native) Sierra 10.12.6 – MBR & GPT (AMD/Ryzen + Intel Native) High Sierra 10.3.3 – GPT (Stable AMD/Ryzen + Intel Native) High Sierra 10.13.6 – GPT (AMD/Ryzen Test + Intel Native) Mojave 10.14.1 – GPT (Intel Native)   Needs/Gerekenler: 64GB/64GB+ USB | 7-Zip/WinRAR | Win32DiskImager/Transmac   Download / İndir : GoogleDrive  
    • @Niresh - any chance you can help?
    • salve a tutti  non riesco ad aprire jpg con anteprima di macOS MOJAVE
    • i tired i cant install graphics hp probook 450 g5
      i have Intel® HD Graphics 620
      and NVIDIA® GeForce® 930MX
      i cant install any one
      used most app
      allawys get error from mulibest "no logo"
      and web NVIDIA dont enable 
      i boot from flash so used win10 and mac
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By Niresh

    156    2