Jump to content
Sign in to follow this  
EdHardwood

EXC_BAD_ACCESS (SIGSEGV) with iTunes and Safari, also Graphical errors in pictures

Recommended Posts

Hi there, 

I'm fairly new to the OS X scene, and brand new to the hackintosh scene, having managed to install Niresh's 10.10.1 Distro for the first time on Sunday, and have been playing about with it since. I've got a few problems that I've encountered, and have tried many different ways of fixing them, but I am still struggling, and I'd appreciate any assistance, or pointers in the right direction!

Specs:

AMD Phenon II X4 945

MSI 785G-E53

Nvidia GTX 460

2x 4GB 1333 DDR3 ram.

 

The first problem I encountered was iTunes crashing after I updated it to the latest version. Thinking it may have been a bug with that version (it worked on fresh install), I tried the previous two versions as well, yet I received the exact same error.

Error Log Paste Bin

  1. Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
  2. Exception Codes:       EXC_I386_GPFLT

Which is the common error I receive for most app crashes, including Safari sometimes, but it's running stable now (no idea why), so I cannot produce an error log for that. I could easily re-produce a safari crash by highlighting text, and extending over the "border", and it'd crash 100% of the time.

EDIT: Managed to get Safari to crash
Link to Error Log

Another problem I've got is strange graphical artefacts on some images, and only when using default OS X apps, so an image that'd have a problem in preview/Skype, would work in VLC.

Phone photos of screen as screenshots were not working.

I also have strange text errors in Chrome, where the fonts do not display correctly, and most web pages crash.

LINK

Sadly, I could not get a better pic than that as all the web pages I tried to load would crash.

 

Steps I have tried to fix the problem:

  • Reinstall OS X with /amd /amd1 /amd2 /amd64 boot flags, where I get the least issues when I used the /amd bootflag.
  • Install Nvidia Web Drivers, multiple versions
  • Arny Cutez's forum "guide" on patching OS X after install (P.S. That was before I found out about the /amd1 and /amd2 bootflags, but I have gotten the best result out of the /amd bootflag with his guide)
  • Swapping RAM in and out, trying different combos of chained and unchained etc.
  • Trying a different HDD (was not a step in my trouble shooting, but I feel it should be mentioned that it's been done)
  • Fiddled around in BIOS a bit, but had no luck
  • + a few other minor things that I can't think of off of the top of my head

 

Thanks so much for reading my wall-o-text, and I hope it's a simple solution where my google-fu has failed me!

 

 

Share this post


Link to post
Share on other sites

Just as I gave up on fixing it myself, I managed it!

I replaced the Kernel with a different one,

Credit it to Bronya on the insanely mac forum.

 

If anyone else has the same issue, I fixed it by using Arny Cutez's forum "guide" on patching OS X after install, but replacing the kernel he linked with Bronya's kernel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.66 of $100.00 goal reached.
    Donate Now
×