Jump to content
Sign in to follow this  
flgd

Computer can only boot in safe mode Yosemite 10.10.1

Recommended Posts

Hi all,

I have installed Yosemite Niresh on my computer but I can only boot in safe mode (see my config at the bottom).

I managed to complete the Install with the following boot flags:

  • /amd64 PCRootUID=1 npci=0X2000 GraphicsEnabler=No USBBusFix=Yes -v -x

 

I managed to sucessfully reboot a few times without any flags, however the resolution was 1024x768.

 

I installed the graphics kexts Ati Radeon HD 5750 (0x68BE1002) from the download section using kext wizard + repair permissions and cache reduild, then rebooted

  • on the system report graphics/displays shows that the graphics card is not recognized, no kexts are loaded, the monitor is not recognized either, the resolution is 1400x1050 at that stage

 

Out of desperation I installed SwitchResX, filled in the monitor info and the graphics resolution, then rebooted

  • Without any flags: stuck on grey screen prior to login with spinning beach ball on the left corner
  • With -x flag: boot all the way through and logged in successfully in full resolution  (system report shows all the correct info display and graphics)

 

Tried to tweak the boot.plist with chameleon wizard (-F, -S, PCIRoot=0, GraphicsEnabler=Yes...) one change at the time + reboot, still no luck, can't narrow down to anything in particular, I cannot boot my computer other than in safe mode.

 

I have installed Yosemite 3 times now, trying to do things in a different order but the result is always the same. SwitchResX definitely helps to get the GC and monitor recognized but I believe it is also responsible for preventing me to boot normally. Can anyone help?

Thanks in advance.

 

Asus M5 A97 R2.0 (no Integrated Graphics Card) / AMD Phenom II X4 955 / 8 GB RAM / Asus Radeon HD5750 / 500GB HD / Samsung SyncMaster 2494HM (1920x1080)

Share this post


Link to post
Share on other sites

Little update, I can now boot normally since I have removed AMDRadeonX3000.kext. I have full grahics resolution but no acceleration. I suppose it's better than a kick in the teeth....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...