Jump to content

Black Screen (After Apple Logo on Boot)

Recommended Posts

I was able to install 10.9 without having to use bootflags, but when I tried to start MacOS I get a black screen after the Apple Logo.

It seems that MacOS is actually running but without any image/video output.


I tried several common bootflags like +x npci=0x3000/0x2000 IGPEnabler=Yes/No GraphicsEnabler=Yes/No

I'm using Chameleon as bootloader.

I have read about parameter injection, but I have no idea how to do that without a working MacOS.


I googled for solutions but none of those worked out.


I have an ASUS Laptop X551CA with following Specs:


Intel® Celeron® 1007U Processor / HD 2500 (also tested a configuration with Intel® Core™ i3 3217U Processor / HD 4000 and had same results)






Please help me out with possible fixes.


PS: I have found these websites and they seem to have to do something with this issue, but I dont speak chinese. Maybe someone can translate them.





  • Like 1

Share this post

Link to post
Share on other sites

Update 1: I'm able to boot MacOS in safe mode when I boot from the starting menu of the Niresh CD/USB. (Not the Chimera Bootloader) -> Trackpad does not work anymore! (Worked during installation)


Update 2: Managed to boot into MacOS after removing the Intel kexts, but now im missing the HD 2500 Graphic Drivers.... does anyone have workings files? -> Trackpad does not work anymore! (Worked during installation)


A way to delete/move the Video-driver is btw: Boot -s and when you see the prompt "root:", then:




mount -uw /

cd /System/Library/Extensions

mkdir intel_back

mv AppleIntelHD* AppleIntelF* intel_back/

touch ../Extensions



Update 3: The HD 2500 seems to be recognized by the system, but its not activated. I have no idea how to get any further now. Trackpad is working as mouse, but no gestures. No sound and no WLAN (even after installing some drivers via Multibeast)

Share this post

Link to post
Share on other sites


I intent to buy an Acer Netbook with the same CPU and GPU as yours, can you please tell me if graphic aceleration is fully working or not, cause I can't understand from your posts.


I intent to buy a Acer Aspire AO756 with a Celeron 1007U Ivy Bridge CPU and for the last three days and nights I am searching info about the Intel HD Graphics to find if it or it is not fully compatible with OS X, but with no results.


Some says that it runs a Intel HD 2500, which from what I read on other forums is compatible with ML, some says that it runs a Intel HD (just like that) and is not going to work with QE/CI.


So is QE CI working or not, cause if it's not, I'm going to look for another Netbook?


Thank you!


LE: I am going to start a new thread about this, so if moderators consider that my post should be deleted, please do it, cause I didn't find out how to do it.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...