Jump to content
Razor1898

No HPET's available

Recommended Posts

Hi. I installed the distro and on the first boot, I got a grey screen. Then I used the flags cpus=1 ForceHPET=Yes and it booted into setup. However after a while it started hanging. Then I booted in verbose mode and it hung again, but the specified kernel panic was "No HPET's available." HPET mode is turned on in the bios.

 

Specs:

AMD FX-6100

Nvidia Geforce GTX 650 Ti

Asus M5A97 R2.0

Share this post


Link to post
Share on other sites

Have you tried booting without any flags? Have you tried making sure "HPET" is on in the BIOS? Have you tried making sure it's 64 bits ( If you have the option ). Is your mother board / cpu 64 bit?

Share this post


Link to post
Share on other sites

I booted without flags the first time. HPET is on. And I couldnt find an option in the BIOS for 64 bit.

Share this post


Link to post
Share on other sites

@

Share this post


Link to post
Share on other sites

@

Have you tried using kernel flags like "PCIRootUID=0" etc

Share this post


Link to post
Share on other sites

@ I tried PCIRootUID=1 but lemme try this one

Share this post


Link to post
Share on other sites

Nope no luck @ 

Share this post


Link to post
Share on other sites

Hi. I installed the distro and on the first boot, I got a grey screen. Then I used the flags cpus=1 ForceHPET=Yes and it booted into setup. However after a while it started hanging. Then I booted in verbose mode and it hung again, but the specified kernel panic was "No HPET's available." HPET mode is turned on in the bios.

 

Specs:

AMD FX-6100

Nvidia Geforce GTX 650 Ti

Asus M5A97 R2.0

post a image ???

Share this post


Link to post
Share on other sites

1389747632_IMG_20140113_175033.jpg

Thanks again for your help

Share this post


Link to post
Share on other sites

I remember this error!! try booting into safe mode (-x) that always helped me. Hope it helps you

Share this post


Link to post
Share on other sites

1389747632_IMG_20140113_175033.jpg

Thanks again for your help

You need to delete aicpm.kext use following command 

Step 1:  Boot in Single User mode by interrupting the Chameleon bootstrap and enter -s boot flag, having highlighted the targeted OS X partition to boot from.Step 2: Shortly afterwards, you will be given the possibility to enter your own commands. You need write access to the partition, so we start with these commands:fsck -fymount -uw /Step 3: Go to the directory where you installed the kext.cd /System/Library/Extensions/orcd /Extra/ExtensionsStep 4: Remove the kext you just installed.rm -rf example.kextStep 5: Remove caches.rm -rf /System/Library/Caches/com.apple.kext.cachesStep 6: Clear nvram.nvram -d boot-args Step 7: You can now run myFix by typing this command:rebootThe system will automatically reboot upon myFix completion and it should normally work again!

Share this post


Link to post
Share on other sites

@Deepak What is myfix?

Share this post


Link to post
Share on other sites

@Deepak What is myfix?

use this command to delete AICPM.kext which giving you kernel panic

Share this post


Link to post
Share on other sites

It says myfix: command not found

Share this post


Link to post
Share on other sites

It says myfix: command not found

forgot about myfix  type reboot

Share this post


Link to post
Share on other sites

When I reboot I get a blank screen. The computer is on but the monitor isn't

Share this post


Link to post
Share on other sites

have you installed NULLCPUPowerManagement.Kexts

Share this post


Link to post
Share on other sites

I don't think so...I don't know what I installed in the setup I just went for the default

Share this post


Link to post
Share on other sites

do a fresh install check about ncpm.kext is ticked 

Share this post


Link to post
Share on other sites

Should I install it or not?

Share this post


Link to post
Share on other sites

do you have installation media  osx along with you ,then i'll tell you some steps  which may be won't let you to install again 

Share this post


Link to post
Share on other sites

I am at the customize page lol

Share this post


Link to post
Share on other sites

I am at the customize page lol

install it ,

Share this post


Link to post
Share on other sites

It's already checked. So I'm pretty sure I installed it last time. Should I install disabler.kext instead?

Share this post


Link to post
Share on other sites

It's already checked. So I'm pretty sure I installed it last time. Should I install disabler.kext instead?

yes then you don't need to delete aicpm.kext 

  • Like 1

Share this post


Link to post
Share on other sites

Now I get a blank white screen on first boot

Share this post


Link to post
Share on other sites

I can't access the second page of the topic

Share this post


Link to post
Share on other sites

@Deepak any ideas?

Share this post


Link to post
Share on other sites

also gets the same problem

Share this post


Link to post
Share on other sites

@aldhistinct what's your setup?

Share this post


Link to post
Share on other sites

 

You need to delete aicpm.kext use following command 

Step 1:  Boot in Single User mode by interrupting the Chameleon bootstrap and enter -s boot flag, having highlighted the targeted OS X partition to boot from.Step 2: Shortly afterwards, you will be given the possibility to enter your own commands. You need write access to the partition, so we start with these commands:fsck -fymount -uw /Step 3: Go to the directory where you installed the kext.cd /System/Library/Extensions/orcd /Extra/ExtensionsStep 4: Remove the kext you just installed.rm -rf example.kextStep 5: Remove caches.rm -rf /System/Library/Caches/com.apple.kext.cachesStep 6: Clear nvram.nvram -d boot-args Step 7: You can now run myFix by typing this command:rebootThe system will automatically reboot upon myFix completion and it should normally work again!

Hello

same problem..

 

boot

-s

fsck -fymount -uw

says : illegal option --m 

Share this post


Link to post
Share on other sites

I solved the problem with the boot flags: PCIRootUID=1 -x

 

 

 

Edited by Niresh: This Article May help you

  • Like 2

Share this post


Link to post
Share on other sites

Thanks

 

I'm gonna do it continuous?

Share this post


Link to post
Share on other sites

yes

Share this post


Link to post
Share on other sites

okii thnkx

can not be added to boot?

Share this post


Link to post
Share on other sites

You can add as many kernel flags as you want to the chameleon plist file.with chameleon wizard

  • Like 2

Share this post


Link to post
Share on other sites

@InQeNe what kind of error you are getting ???

Share this post


Link to post
Share on other sites

@ sorry that time second tab is not working i'm not able to read your post ,now it's done,,you can tell me your problems ??

Share this post


Link to post
Share on other sites

@Deepak I got it working thanks

  • Like 1

Share this post


Link to post
Share on other sites

@ your sgreeting_welcome_sign_general_100-107.gif?w=545

Share this post


Link to post
Share on other sites

Hello Bro i am using Dell inspiron N5010 And i am getting No HPET's is there But when i boot with PCIRootUID=1 -x

But now it got hang tell me for next step

Share this post


Link to post
Share on other sites

make sure you have Nullcpu powermanage.kext installed or Backup all Graphics extensions 

Share this post


Link to post
Share on other sites

Same problem on my end on Gateway p7905u FX.  When I try PCIRootUID=1 -x, I simply get a blank screen (nothing displaying at all).  When I first tried this, I got a loading bar of some kind, followed by the blank screen.

 

In my BIOS, there is no option available to set HPETs to 64-bit or any HPET options at all

 

In my case, I just installed default niresh to test it.  My machine will boot fine using the USB bootloader, but after about 2 minutes I get the HPET error.

 

In addition, I am unable to boot to safe mode using the -s flag.  I am able to, of course, run Terminal from the installer, so I'll try removing the power management kext from that.

 

Any assistance would be appreciated.

Share this post


Link to post
Share on other sites

Tried removing the null cpu power management.  Still the same kernel panic after 2 minutes.

 

Suggestions, anyone?

Share this post


Link to post
Share on other sites

Most likely in the installer you used AppleHPET.kext was removed from /System/Library/Extensions since it can potentially cause a kernel panic on some systems. 

If you used the Niresh ISO/DMG then you'll find the removed kext in /Backup/Kexts.

Copy it back to /System/Library/Extensions/AppleHPET.kext and rebuild the caches:

touch /System/Library/Extensions
kextcache -system-prelinked-kernel
kextcache -system-caches

or use Kext Wizard to install the kext.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $40.22 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

  • Download Statistics

    • Files
      856
    • Comments
      2,150
    • Reviews
      2,618

    Latest File
    By Niresh

    113

×