Jump to content
Sign in to follow this  

Problems running in virtualbox on AMD

Recommended Posts

I have lots of questions - as is clear below.  

I am trying to run Yosemite (from the niresh yosemite 10.10.1 iso file) in a virtualbox VM - but it is running REALLY slow, the image rendering is awful, cannot get to the app store, and a slew of other problems.  Also - I am logged in using root and niresh, per the screen that came up after loading up the VM - and when i create a new admin user and try to log in as that user, the VM gets stuck and fails to boot up.

My main question is this - from what i have read here I am guessing that I need to fix a bunch of the kext files and change some of the boot settings - but i have no idea how to do those things. Are there any instructions or tutorials out there for unsophisticated people like me?

Background - and i've put some questions in here if anyone has the patience to answer...

I am a fairly new programmer, and want to learn to use xcode, and program with objective-c and swift for iOS.  I also rcan't afford to buy a Mac right now - and a Hackintiosh seems like a great solution.

But I am having trouble, and really need help (in addition to some very helpful answers I've gotten here in the past, which brought me to where i am).

I am trying to run Yosemite in a Virtualbox VM (could not get my computer to recognize the .dmg file - and I like the idea of running inside a VM).

My PC is a HP desktop with:
- AMD Athlon II X4 630 Processor - 2.80 GHz. with 6GB RAM.
- NVIDIA GeForce 9100 Display Adapter
- Windows 7 Ultimate, 64-bit.

The VM is set up with 4GB RAM, a 40GB virtual drive, and 2 processors.  (I've tried 1, 2 and 4 processors, and that setting doesn't seem to affect performance - if anyone has an idea regarding how i should set this, please let me know).

The bootflags that worked for the install were "/amd1 npci=0x2000"

After formatting the hard drive with the Disk Utitlity, and installing to the hard drive, the installation gets to "about 2 minutes remaining" and then stalls.  But when i restart the VM I can boot from the new hard drive.  (Is there a way to get it to go all the way and not get stuck at "about 2 minutes remaining"?)

So when I boot from that hard drive I don't know what bootflags to use - PLEASE ADVISE.  I have tried with npci=0x2000 and npci=0x3000 - but would appreciate advice on this point.

After booting from the HD the system is really slow, the graphics are awful the screen is small.  

Also - the system asks me if i was to fix the App Store app - if i say yes then the system bogs down and gets stuck.

FYI - I did all of this with the Mavericks ISO file, which got me further, but found that the newest xcode requires Yosemite or later.

Also - I log in initially as root/niresh (per the screen that came up during the install).  But when I create a new admin user and try to log in as the new admin user the bootup stalls (I've let it run overnight, and it stays stalled).

Lots of things make the VM stall - like trying to connect to or create an iCloud account.

Can anyone out there please help me get past all of this?

Suggestions for what to do next?


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...