Help with HP Laptop, pretty complex issue (for me at least) - OS X Yosemite 10.10 - Hackintosh Zone
Jump to content
  • 0
fresh

Help with HP Laptop, pretty complex issue (for me at least)

Question

cause I know there is bunch of info on the net; Still I suck at this so hard and also my case is pretty specific:

The computer is HP ProBook 450 Laptop with Intel 4000 HD Graphics; Having an UEFI support
or whatever that even means :P
Just to assure you: yes, I tried booting directly from UEFI, the motherboard won't recognize it;
Also, can't set the partition active; And for now, I think the EFI partition is gone somehow;

Disk 0
Partitions:
------------------
System Reserved 101MB NTFS       // Windows & BCD Handler
Untitled 350 GB  NTFS                 // this is C: of Windows
DATA     ~350 GB  NTFS              // NTFS (windows partition)
Linux Swap    200  MB                // From the last linux I had, might triple boot so I don't delete it yet
Hackintosh     105GB  HFS+        // Hackintosh containing EFI stuff

Disk 1
Sometimes appear, I think this was my disk on key but after dealing with so many variables IDK   LOL

I have a Primary Windows 8 partition;
I resized it and installed on the new partition OS X Yosemite;
Now, (to my surprise) it worked and kept both working so I just installed easyBCD like I used to do
in other computers but this one is getting tough on me.
I think it's important to note that I want my Windows 8 as it is; I don't wanna touch it; Otherwise stuff would've been probably much easier, but if it isn't neccessery and it isn't cause I already logged into the OS X using external discs and No graphics kexts enabled.
Now, apperantely I can't make the OS X partition main cause it's logical (even though when I created it it said Primary and even now when I'm in the virtual disk manager it says so...);
So I reckoned using MBR wouldn't work pretty well, and as expected it didn't work at all;
When I tried to use EasyBCD to boot to it somehow it just threw "Chain booting error";
So I tried using NeoGrub; It worked for a while but as soon as I needed to install drivers it all went to shit. So I had to reinstall Yosemite (I'm using the niresh distro but the problem is with the bootloaders rather than the distro itself, since I installed them after the installation ,seperately); 
Please, when offering some solution consider that every reinstall is very slow cause for some reason the My CD/DVD ROM is pretty damn slow; It takes over an hour to install; And about ten minutes for first boot, might be more if some kexts don't work and I have to disable some injections;
So, at last what I have now is that only the EFI works; I just make easyBCD boot using the menu called by the IntelCDClover Bootloader which is an alternative iso I found cause the default was immidiately rebooting; Then from there I boot from file;
Now I don't know what to do cause the bootloader won't update and I can't get the graphics to work;
Tried installing Chimera but I think it installed MBR; Can't get to Chameleon;
Clover is the only bootloader working, I can find on the harddisk; When trying to use NeoGrub it says: "Can't mount the selected partition"
Like all the shitiest things and problems on one computer T_T
Thanks for reading, I'd be pleased to hear from you some suggestions I'm pretty tired at this point wacko.png 

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hackintosh Zone Donations

    Hackintosh Zone is a free website with most useful Hackintosh Resources, We try to keep it that way, Your donations and disabling Adblock makes this site going on.



    $8.78 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • It's basically a problem with your graphics card, so try doing this.   In the boot options go to graphics injector and make a tick on intel graphics injector.   Also make sure you go to your bios and disable your discrete graphics Card.   After doing these to things, it solved the issue for me!! Hope it helps!
    • I installed Yosemite with the use of iGPU but when I installed the eGPU as mentioned on the title the loading screen stuck on caution. I also tried the bootflags such us  nv_disable=1 and nvda_drv=1 also I tried GraphicsEnabler=Yes/No but still no luck. What might be the possible problem? Image link
    • Information BrandHP Model450 G1 (F6B14PA) Dimensions(WxHxD)375 x 256 x 22.0  mm Weight2.4 Kg ColorsSilver Operating SystemWindows 8 Professional Operating System Type64-bit Display Details Display Size15.6 Inches (39.62 cm) Display Resolution1366 x 768 Pixels Display TypeTFT Display FeaturesTFT Colour Display Display Touchscreen  No Performance ProcessorIntel Core i5-4200M (4th Gen) Clock-speed2.5 Ghz ChipsetIntel HM87 Express Graphic ProcessorAMD Radeon HD 8750M Graphics Memory2 GB Memory Capacity4 GB RAM typeDDR3 RAM speed1600 Mhz Memory Slots2 DIMM Expandable Memory16 GB Memory Layout1 x 4 Gigabyte Storage HDD Capacity750 GB HDD Speed(RPM)5400 RPM HDD typeSATA Battery Battery Cell6 Cell Battery typeLi-Ion Power Supply90 W AC Adapter W Battery Life8.5 Hrs Networking Wireless LAN802.11 b/g/n Bluetooth Bluetooth Version4.0 Ports USB 3.0 slots2 USB 2.0 slots2 SD Card Reader Headphone Jack Microphone Jack VGA Port Multimedia Web-cam Video Recording720p HD Secondary cam(Rear-facing)  No Audio SolutionHD Audio Solution SpeakersStereo Speakers Sound TechnologiesDTS Sound+ In-built Microphone Microphone TypeDigital Microphone Peripherals Optical DriveDVD+/-RW SuperMulti DL Drive TypeDVD Writer Pointing DeviceTouchpad with Multi-touch Gesture Support KeyboardFull-sized, spill-resistant keyboard with numeric keypad  
    • Does anyone have some advice on this issue? I'm stuck in the same spot and searching the forums for answers. thanks
  • Download Statistics

    • Files
      852
    • Comments
      2,146
    • Reviews
      2,604

×