Jump to content

Hackintosh on Virtualbox (Linux host)

Recommended Posts

I'm trying to install on VirtualBox using the Yosemite iso from this site. I followed this howto: http://www.macbreaker.com/2015/01/virtualbox-yosemite-zone.html. The VM crashes as soon as the grey splash screen comes up. Here's the virtualbox log: https://bpaste.net/show/353728833a6a. I also tried the mavericks iso and I get the same error. I tried on VMware and I get an error about the CPU being disabled by the guest. On QEMU I don't get any errors but it hangs right after the splash is shown. I also downloaded a Mountain Lion vmware image from somewhere else and it gives me the same result. I tried different VM settings and boot options and at one point it seemed to boot but it never loaded a GUI, just a terminal that showed syslogd messages.


My virtualbox version is 4.3.26.

QEMU: Tried 2.2.0 and 2.3.0

VMware Workstation version

Linux kernel version: 4.0.1 on Gentoo

CPU: AMD A4-1250 APU with Radeon HD Graphics

Video: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8210]

RAM: 4GB (2 for the VM)

Network: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter

Share this post

Link to post
Share on other sites


I have inform at some threads about success with VirtualBox Yosemite.

I am using VirtualBox Yosemite up to 10.10.2.  For installation I follow: http://www.macbreaker.com/2014/05/os-x-mavericks-in-virtualbox-with-niresh.html

Some details is impotent from:https://www.hackintoshzone.com/topic/5064-virtualbox-yosemite-install-stuck-at-2-minutes-left/page-12

For me only stuck at shotdown is a problem.

Good luck

Share this post

Link to post
Share on other sites

Thanks for the reply. That's pretty much the same as the howto I was following, it has more stuff but I never got that far.


I saw another post where somebody mentioned problems with virtualbox 4.3.x so I decided to try 4.2.x but I had to downgrade my kernel to 3.18.13 in order to compile the virtualbox 4.2.x modules. After booting the new kernel I decided to try once more with virtualbox 4.3.26 and to my surprise it booted without problem.


I suspect it's not related to the new kernel but since I remember seeing a bluetooth message just before it crashed a few times it may be that I misconfigured the new kernel and the bluetooth driver is not working. I'm supposed to compile the bluetooth driver as a kernel module but I compiled it built-in and since I don't have the firmware for it on my initrd the driver fails to load. It's installing right now. After it's done I will rebuild my kernel with bluetooth support to confirm if that was the problem. Thanks.

Share this post

Link to post
Share on other sites


Only inform that I updated my VirtualBox Hackintosh to 10.10.4 without any problem.

Best regards to all

Share this post

Link to post
Share on other sites


Only inform that I updated my VirtualBox Hackintosh to 10.10.5 without any problem.

Best regards to all

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.

    $17.56 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • HI i have this card ATI Radeon HD 5770 Series and I have it working, but I got a problem with vram only have 7 mb I need help to solve this because i have problems with some glitches in the display. I haver clover . PD: My graphics card have 2gb      
    • Hi, I am trying to make bootable USB for Hackintosh , I tried TRANSMAC and Win32disk image from my Windows 10 PC, soon after completion USB not accessible. Please advise.   Thank you,  
    • That's happen every time that i am trying to install a hackintosh on my pc i can't find a solution. I tried a lot of different flags.  Pc specs:  GeForceGTX760 4GB Intel i7-4820K MSI Global X79A-GD65 (8D)   There is a video: https://streamable.com/us6nf  
    • nobody can help me
    • I have a GA-H81M-S mobo with G3240 Pentium (R) processor. I am not using the IGP but an Nvidia GT-710 1GB DDR3 dedicated Graphics card. I followed posts in other forums and managed to install once. After upgrade and reboot, I messed with clover configurator and now I can't get to the install screen. I get stuck on VoodooPS2Mouse: Version starting on OS X Darwin 16.4. If this forum is still alive, please help
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By Niresh

    230    2