"npcio=0x20000" yes that is an extra zero!!!!!! - Hackintosh Mavericks - Hackintosh Zone
Jump to content
Earl R Carol III

"npcio=0x20000" yes that is an extra zero!!!!!!

Recommended Posts

When I first saw this thread i laughed and said yeah that has to be a typo. Then to my amazement it solved an issue i have been struggling with for 6-8 months. I have a HP Pavilion dv6-3050us AMD laptop with the ATI Mobility Radeon HD 5650 that i could never get to boot into the installer. I tried Unibeast,myhack pandora, Niresh ect. I decided for the hell of it to try npci=0x20000 as a bootflag since i always get stuck on pci configuration begin. I went ahead put it in and BOOM SHAMA LAMA DING DONG!!!! :). IT WORKED!!!!! If there3 is any Genius's out there that care to explain this i would be happy to know more about this flag. Also Now that i have 10.9 installed i must use npci=0x20000 to get it booted no matter what also i must use USBBusFix=Yes EHCIreset=Yes UHCIacquire=Yes USBLegacyOff=Yes UseKernelCache=No npci=0x20000 in that order then i will get stuck at IOAPIC then i must play around with my mouse usb transmitter and 1-2 flash drives on the left side i have to put them in then pull them out or switch the usb transmitter with the usb flash drive When doing this I will get FAKESMC failed to initialize then what i do is use a flash drive on the front right usb port and all of a sudden it says smc initialized and and it will continue booting. This is quite a process and its super RATCHET!! LOL I am willing to provide anymore info if there is anyone out there willing to help me iron out these issues. So long story short "npci=0x20000" did help me finally get this machine to work and once i do get it booted it runs very smooth..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hackintosh Zone Donations

    Hackintosh Zone is a free website with most useful Hackintosh Resources, We try to keep it that way, Your donations and disabling Adblock makes this site going on.



    $8.78 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • Hi guys I've installed Yosemite Zone 10.10.1 on my PC who has the following specs: CPU: FX-8850 GPU: R7 260X MOBO: 990FXAUD3 REV 4.0

      I installed yosemite zone 10.10.1 without any problem and successfully installed the ethernet drivers with the PKG i found in the downloads section of hackintosh zone, I wanted to update to 10.10.5 to install the R7 260X drivers which i can download from the site but now when i enter my bootflags: npci=0x2000 and PCIRootUID=1 and I choose my ssd from chameleon bootloader it boots up and I can see it starts to load stuff when i put -v  but then the screen goes black and the system just reboots. Pls tell me how to fix thanks in advance.
    • Hi DAFFY,   Yes. High Sierra is actually installed on a Z270-F from Asus ROG. Everything's good with it.
    • Dear Community,   First of all I would like to apologise for my horrible English knowledge.   Well, I have one main problem with my hackintosh.   The first and most annoying problem is gIOScreenLockState 3. I've just tried some kexts but still this problem. Now, if I start without -v I just get black screen.   Thanks for reading,   TheXeno      
    • Can anyone specify the best or minimum NVidia GPU for Yosemite OS? Can someone list it? including the best GPU that can be supported with the nvidia web drivers. Does GT730 is supported? I only have DDR3 slot for my motherboard.
    • Thank you for your immediate response :)
  • Download Statistics

    • Files
      852
    • Comments
      2,146
    • Reviews
      2,603

×