Jump to content
techiechick120

Can't get RTL8111b ethernet working

Recommended Posts

Got Niresh Mavericks (updated to 10.9.5) running on a Gigabyte GA-P31-DS3L with 4gb ram,core 2 duo 2.3ghz cpu and a Asus Nivdia 8400gs 512mb video card,

Graphics and sound work perfectly but not wired internet.

I've tried Lnx2mac  and installing kexts with kext wizard and kext utility but can not get the RTL 8111b wired ethernet to work.

Nothing shows up in network preferences.

I do not have a great understanding of the terminal and plists etc. so would need DETAILED instructions that I can understand.

Share this post


Link to post
Share on other sites

Do a search for Hackintosh Vietnam Tool and down load it. Unzip and you have a .pkg file which you run with installer.

 

Opens up an installer window with choices. click on all the accept buttons which will take you to a window listing Chameleon: Clover: Kexts: and so on. Click on Kexts, then on Network, then on Ethernet. there is a choice box for NullEthernetInjector, which you can check or not. I haven't found where it does anything, but  the explaination at the bottom box says it is supposed to help with AppStore.

 

next choose Realtek, and then check RealtekRTL8111, which is the kext for your Ethernet. I have the same one.

click install and it should get your wired ethernet going.

 

While you are in this thing, Wander around in it and choose whatever else you need for getting your install of Mavericks going. It is supposed to work on Yosemite also, but I have not been successful in getting Yosemite to install yet, so can not report on that.

Share this post


Link to post
Share on other sites

hiya,I used the the tool you mentioned,even tried the ethernet injector thing which made my hackintosh boot in safe mode so then the graphics driver wasn't loaded so all I got was a black screen.

I reinstalled everything and tried the realtek kext again,but still nothing,no wired internet.

Share this post


Link to post
Share on other sites

hiya,I used the the tool you mentioned,even tried the ethernet injector thing which made my hackintosh boot in safe mode so then the graphics driver wasn't loaded so all I got was a black screen.

I reinstalled everything and tried the realtek kext again,but still nothing,no wired internet.

might give this one a try, then:  https://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...