Disable ADBlock Extension If you have.
Jump to content

OS X 10.10.3 on Haswell PC

Recommended Posts


I installed niresh OS X 10.10.1 without any problem on my haswell pc using /haswell flag. But I updated to OS X 10.10.3 and I can not start my Mac since I've got an I7-4770K. I tried to copy your haswell patch to my kernels folder using the installer's terminal, but I couldn't because I didn't find the "cp -f" code to copy it from my USB Installer to the Kernels folder. I hope someone will help me.






-OS X Installed on a Samsung 120GB SSD.


Share this post

Link to post
Share on other sites

Please, help me I need a solution!!

Thx in advanced!

Share this post

Link to post
Share on other sites

@ctabuyo02 you have to patch the haswell kernel after the upgrade

Share this post

Link to post
Share on other sites

Thanks for answering. How can I do that??



Share this post

Link to post
Share on other sites

I am trying to update it with "OS X 10.10.3 updater" but I can´t because once it downloads the file, at the middle of the installation it gives me an error and it breaks my OS X Installation, because if I reboot it gives me instant reboot, and if I don´t the Mac crashes. Please help me I need OS X 10.10.3!!

Share this post

Link to post
Share on other sites

1. Download this kernel. It's a patched haswell kernel for 10.10.3. (I'm not on haswell, so can't promise that it'll work).
2. Place the kernel in your root directory of your OS X volume
3. Download the 10.10.3 combo update (or if you used Niresh' updater there's a backup install on your desktop. Open it).
4. Install the update. Boot with '/kernel'. 
5. If your system boots, open terminal and write  defaults write com.apple.finder AppleShowAllFiles YES

6. Go to /System/Library/Kernels/ and rename kernel to kernel.backup
7. Move the kernel out of your root directory to /System/Library/Kernels/
8. Make the kernel hidden (e.g. with invisibliX)

9. open terminal and write  defaults write com.apple.finder AppleShowAllFiles NO

10. Repair permissions

Edit: just realized that you updated to 10.10.3 already.

mv  /System/Library/Kernels/kernel  /System/Library/Kernels/kernel.backup
cp   /path/to/your/kernel/kernel   /System/Library/Kernels/

Share this post

Link to post
Share on other sites

Unable to install Yosemite Zone.dmg in Acer Aspire E5 571 33YS notebook

I tried to install Yosemite Zone.dmg (10.10.1) in intel i3 haswell PC with a USB (disk image restored with transmac) using boot flag  /haswell –no-zp –x  and formatted the whole 1 TB hard drive with Mac OS extended (journaled). 

Thereafter I made 5 partitions. First partition is ‘Yosemite HD’ (190 GB, format Mac OS extended (journaled), Second partition is ‘Cinema’ (250 GB) , format -ExFAT  Third is ‘Windows 8.1’ (160 GB), format MS-Dos (FAT). Fourth is ‘Songs Videos’ (260 GB), format ExFAT. Fifth is Documents (120 GB), ExFAT.

After that, selected Master Boot Record and clicked ‘Partition’ tab only to get the error “Could not mount disk2s6 with name Documents after erase”.  After partitioning, I selected “Yosemite HD” to install Yosemite 10.10.1 and when I completed installing the distro in “Yosemite HD” I got the installation error saying “OS X  could not be installed on your computer. The Operation could not be completed.  Undefined error 0. Quit the installerto restart your  computer and try again.” When I restarted my computer I got “boot0ss: error_”

 I did the installation again,   but here before restarting the computer  I went to ‘Terminal’ and typed the following commands.

cp  –f  /Volumes/“Image Volume”/haswell  /Volumes/ Yosemite”/System/Library/Kernels/kernel

rm  –rf  /Volumes/ “Yosemite”/System/Library/Catches

kextcache –u  /Volumes/ “Yosemite”

But I got the error “Read-only file system” in every Image Volume and

“rm :  /Volumes//Image Volume: Resource busy”

When I restarted and booted through USB to “Yosemite HD” I got kernel panic.  

I also used boot flag  /haswell  –V  –X PCIRootUID=1 or  /haswell  –V  –X  ncpi=0x2000 but got the error “disk1s2 : device is write locked” when using the above terminal command.

I also have attached the error Log of the installation.

The specification of the above note book is as under:


Product type


Form factor


Processor model


Processor family

Intel Core i3-4th Generation (HASWELL)

Processor frequency

1.80 GHz

Processor cores


Processor threads


System bus rate

5 GT/s

Processor cache

3 MB

Processor cache level


Processor socket


Internal memory

4 GB

Internal memory type


Memory slots


Storage media


Hard drive capacity

1000 GB

Hard drive interface

Serial ATA

Memory card suppoted

Secure Digital SD card

Display resolution

1366 x 768 pixels

On-board graphics adapter model

Intel HD Graphics 4400

Discrete graphics adapter model


Optical drive type

DVD Super Multi

Built-in microphone


Wi-Fi standards

802.11b, 802.11g, 802.11n

Ethernet LAN


Ethernet LAN data rates

10, 100, 1000 Mbit/s

VGA (D-Sub) ports quantity


HDMI ports quantity


DVI port


Ethernet LAN (RJ-45) ports


Microphone in


S/PDIF out port *


Docking connector *


DC-in jack *


ExpressCard slot *


CardBus PCMCIA slot type *


SmartCard slot *


Pointing device


Operating system installed *

Linux Linpus

Intel Wireless Display (WiDi) Technology


Intel Smart Connect Technology


Intel Anti-Theft Technology


Enhanced Intel SpeedStep Technology



Intel Virtualization Technology


VT-d, VT-x


Intel HD Audio Technology


Intel Matrix Storage Technology


Intel Turbo Boost Technology


Intel Hyper-Threading Technology


Intel visual technologies

Intel Clear Video HD, Intel Insider, Intel InTru 3D, Intel Quick Sync Video

Intel vPro Technology


AC adapter power

40 W

Cables included



Share this post

Link to post
Share on other sites

Do someone got patched kernel of OS X 10.10.4??


Thx in advance

Share this post

Link to post
Share on other sites

Do someone got patched kernel of OS X 10.10.4??


Thx in advance

Look here: http://forum.osxlatitude.com/index.php?app=core&module=attach&section=attach&attach_id=7645


Jast a moment I have successfully update my MSI GS60 Hackintosh to 10.10.4 using this patched kernel.

I have only to remove IOBluetoothHostControllerUSBTransport.kext, with which I had problem with previous version as well -

it is my MSI GS60 local problem

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.

    $18.27 of $100.00 goal reached.
    Donate Now