Jump to content

Still waiting for root device (different problem than most)

Recommended Posts

Okay, I have seriously been trying to fix this for about 2 days now and I just can't get it to work. I'd really appreciate some help.


Basically, I can get it to boot to my usb and install perfectly fine but once the installer finishes and resets my pc and I try booting into my yosemite drive it always stops and gives the still waiting for root device error.


The bootflags I've tried already are -f, -x, USBBusFix=Yes, USBLegacyOff, and a couple others. My BIOS is set to use AHCI also. It's weird to me because most people run into this issue when trying to boot to the usb and that's not the case for me. I have a picture to show where it stops.


I've also successfully ran mavericks before on this motherboard in the past.




Share this post

Link to post
Share on other sites

ahcidisk=1 debug=8 works for me. I had a screen with a circle and a slash in the middle while Still waiting for root device. I saw that chameleon on the Yosemite Zone installer had these flags by default. fixed that issue for me

Share this post

Link to post
Share on other sites

That doesn't seem to work for me either :/

Share this post

Link to post
Share on other sites

So I was trying to boot it up again and while I was sitting there at still waiting for root device I was looking for solutions. After a while some things happened on my screen.

It seemed to find the root device and then start searching for it again. I got it to end up booting up but it takes a really long time.


Here's some pictures to show what happened




If anyone has any ideas on how I can make it not take so damn long I'd greatly appreciate it.

Share this post

Link to post
Share on other sites

Good news and bad news. Good news is I got it to boot up a bit faster and I installed graphics drivers for my gtx 970 and it is all working beautifully so far! Internet works no problem and so does the sound! (Which I was surprised about)


Bad news is I still get waiting for root device. Difference is that now when it does find the root device it doesn't try finding it again. I've tried setting rd=disk1s2 (that is the name of my disk) and it still takes a bit to find it. If anyone has any ideas I'd appreciate it.

Share this post

Link to post
Share on other sites

Super good news. I brought my computer into work today (I'm a computer tech) and it seems to boot up here without the stilling waiting for root device error. So it must have something to do with whatever is plugged into the back of my computer. I will figure it out when I get home. But my problems solved.

Share this post

Link to post
Share on other sites

Found out it's my mechanical rgb80 keyboard made by rosewill that was causing the still waiting for root device. If anyone has any ideas of how I can work around it I'd appreciate it

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.

    $17.56 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • HI i have this card ATI Radeon HD 5770 Series and I have it working, but I got a problem with vram only have 7 mb I need help to solve this because i have problems with some glitches in the display. I haver clover . PD: My graphics card have 2gb      
    • Hi, I am trying to make bootable USB for Hackintosh , I tried TRANSMAC and Win32disk image from my Windows 10 PC, soon after completion USB not accessible. Please advise.   Thank you,  
    • That's happen every time that i am trying to install a hackintosh on my pc i can't find a solution. I tried a lot of different flags.  Pc specs:  GeForceGTX760 4GB Intel i7-4820K MSI Global X79A-GD65 (8D)   There is a video: https://streamable.com/us6nf  
    • nobody can help me
    • I have a GA-H81M-S mobo with G3240 Pentium (R) processor. I am not using the IGP but an Nvidia GT-710 1GB DDR3 dedicated Graphics card. I followed posts in other forums and managed to install once. After upgrade and reboot, I messed with clover configurator and now I can't get to the install screen. I get stuck on VoodooPS2Mouse: Version starting on OS X Darwin 16.4. If this forum is still alive, please help
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By Niresh

    230    2