Jump to content
Sign in to follow this  

Unable to boot into Yosemite after successful install

Recommended Posts


Hi all,


So near to a breakthrough but I need some help...


AMD FX 6300

AMD Radeon R7 260x

Gigabyte GA-970-UD3P

Existing Windows 7 on local HD


Using Yosemite 10.10.1 distro via a USB key, it seemed to install successfully to a seperate HDD but after restarting it just boots into Windows, and I can see in the UEFI/BIOS that boot priority has been altered so that my Yosemite HD is at the top.


I have booted into the USB and tried to select the Yosemite HD, and this looks right but when I enter the same bootflags as before:


amd64 -v npci=0x3000


...it says can't find systemlibrarykernelsamd64  and using HFSExplorer, I can see it's there! amd64 is there! If I can find it, why can't it?!


I did have the same error when trying to install, BUT I moved the 'amd64' file from the root of the USB and into systemlibrarykernels because that's where it was looking for it. Is that normal? I haven't found anyone else who had to do that but it worked for the install, annoying now it doesn't work to boot.


Can anyone please help?



Many thanks!



Share this post

Link to post
Share on other sites

Hi Tom;


My name is Tom as well. What are the chances? lol.


If you used /amd to boot the installer, then you do not need the kernel boot flag to boot Yosemite when finished. I have amd fx 8350. my boot flags for the installer were:


/amd GraphicsEnabler=No npci=0x3000 cpus=1 -f -v


Once installed my boot flags for Yosemite installation (and I use clover)


ahcidisk=1 debug=8 dmar=0 -force64 GraphicsInjector=No npci=0x3000 -v


I have 2 EVGA GTX 660s thus the GraphicsInjector=No, which is the same as GraphicsEnabler=No in chameleon. You may or may not need it depending on your graphics card. And you probably won't need the -force64. I have it for fun.


I had Windows 8.1 installed first, made hfs partition and installed yosemite on that. Used Bootdiskutility to install clover to usb. (Edit: I have both Windows 8.1 and Yosemite on same HDD)

And then copy the clover files and folders from that to the EFI partition on my Windows drive. Gives me the option to select Windows or Yosemite. Works well for me.


Note: When you use the flag amd64 OS X defaults to looking for the kernel in /System/Library/Kernels/


When you add a slash in front (/amd64) it will look for it in the root of the installer/installation

  • Like 1

Share this post

Link to post
Share on other sites

Thank's for this post!

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...