Jump to content

My installation experience with Mavericks and Yosemite on an older system

Recommended Posts

So, finally it worked. I decided to share my installation experience.

I have a costum made system, but an old one, with Gigabyte 945pl s3p as motherboard and Nvidia Geforce 6200 as video card, with an Intel dual core cpu. This configuration could have been the one for a home made Mackintosh back in 2007, altought this combination was not mode for this.

First step, I tried Mountain Lion. I managed to install it with Chameleon, surpasing a kernel panic with back up the Nvidia Graphics. But, after installation, it froze often, reset being the only way to exit this state. So, I tried Mavericks. After finding the way how to boot from USB (this type of motherboard is very picky on booting USB devices, the boot menu is really weird and automatic boot is not possible, only through the boot menu from pressing f12), installed Mavericks with Chameleon. It worked, the freezing from Mountain Lion was gone. App Store, iTunes Store etc did now work, so I googled and discovered a way. So, the next step was to try Yosemite. The image made by Niresh refused to boot on itself. I have tried to boot it using the Chameleon boot menu at the basis of the Mavericks installation, it failed, giving the Can,t find mach_kernel error. I realised that I can not use Chameleon, because the old Chameleon will not see the Darwin 14 kernel, because of it,s location and name that have changed. So, I reinstalled Mavericks with Clover. It worked, even the Apple stores went fine, I did not need that tweak anymore. Using the base installed Clover, I could boot the Yosemite installer. I knew that Mavericks and Yosemite share the same basic hardware requirements, so I had to work one way or the other, and this confirmed. I have installed Yosemite on Clover, but it either have me an error at the end of the installation, or, if not, the PCI Configuration begin error. On the guide, Niresh said he removed the boot argument npci=0x2000, because it caused him issues. I have burned Clover on an iso, to use it as a boot loader, so I will not depend on an installed Mavericks that I should reinstall every time I tried to install  Yosemite. I so that it had npci=0x2000, so I booted the Yosemite installation media with it, adding this boot argument. I succeeded in this, and, to avoid issued, after repartitioning on GPT, I have installed without a bootloader. This installation was reported as a success, and booted through the Clover from the cd-rw I put it into, with npci=0x2000 added at every boot. I could log in, the downloaded Clover and installed it on the main partition. I could now remove the cd, to boot from the hard drive. The only drawback is that I have e to manually add npci=0x2000 on every boot. I have installed all the updates from the App Store. I found that it freezes on log in screen, so I reinstalled the OS and deactivated the log in screen. I figured out that the need to manually add the boot argument in Clover time could serve as log in password, anyway. So, I guess that this method could be used by others in similar situations like mine.

What issues I still have: some apps freeze in full screen maximised mode, like Chess, and sometimes it is even impossible to return to the desktop from them. If I could restore the old maximise function, it would be something. iTunes complex visualisations refuse to work due to the video card, they say, I mean iTunes Visualizer (Magnetosphere) and iTunes Classic Visualizer (GeForce). I would really like to make them work.

Now, a lot is still ahead, I mean to learn about maintenance. On Windows, the need to clean up disk,  delete internet cache etc is needed at least weekly, I assume in here is the same thing, I know that defragmenting has to occur rarely, once every six months, perhaps even rarely, I found out, not minimum weekly, like on Windows.

Finally, I would like to thank Niresh and the rest of you for making this possible. Keep on going, in the name of freedom.

Share this post

Link to post
Share on other sites

Hello, I have a dell inspiron 3541 AMD A4 processor, has 4GB of RAM and 500 GB hard drive, using the CPU-Z tells me these instructions the processor MM (X) SSE, SSE2 SSSE3, SSE4.1, SSE4. 2 SSE4A, x86-64, AMD-V, AES, AVX. will run the Yosemiti 10.10.1 ?, which kermel finger to use for the processor?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...