Jump to content

Triple Boot OSX Yosemite, Windows and Linux help with Grub

Recommended Posts

I recently successfully installed Hackintosh.Zone yosemite on my asus i97i-plus system. But now I want to be able to boot Linux (ElementaryOS (Ubuntu), Windows and Yosemite OSX, from one bootloader.


I tried chameleon. Chameleon does see Windows 8.1, but does not start windows successfully. Chameleon does not see Linux (even with Grub in de bootsector of the partition sda6).


So, Grub2 seems to me a better way to go.

Grub does see Windows and boot it successful and of course boot Linux (with different kernels).

Grub (update-grub) does not see my Yosemite Chameleon install. I did try to modify /etc/grub.d/40_custom in different ways, but none of them did work.


Can anyone help me with Grub and OsX?


My partition layout is: (lsblk)



sda 8:0 0 223,6G 0 disk

├─sda1 8:1 0 300M 0 part NTFS rescue

├─sda2 8:2 0 100M 0 part /boot/efi EFI

├─sda3 8:3 0 128M 0 part Unknown msftres

├─sda4 8:4 0 143,9G 0 part Windows 8.1

└─sda6 8:6 0 79,2G 0 part / EXT4 ElementaryOS (Ubuntu)


sdb 8:16 0 1,4T 0 disk

├─sdb1 8:17 0 200M 0 part HFS+ EFI

├─sdb2 8:18 0 232,6G 0 part HFS+ OSX-Root

├─sdb3 8:19 0 619,9M 0 part HFS+ Recovery OSX

└─sdb4 8:20 0 1,1T 0 part HFS+ OSX Data


sdc 8:32 0 1,8T 0 disk

├─sdc1 8:33 0 15,3G 0 part [sWAP]

└─sdc2 8:34 0 1,8T 0 part /home EXT4 Linux home


Grub is installed on /dev/sda and /dev/sda6. The pc boots from SDA.

Share this post

Link to post
Share on other sites

I think elementaryOS is not linux but an ubuntu based distribution.


Any how, you should install the grub bootloader on sda6 alone.


I had done it before, see below. I only have 500GB and partitioned it.




I had tried Luna(grub bootloader) on it, following this guide and successfully made it worked.


Im now experimenting Quad booting on my Fujitsu, currently Chameleon can see and boot on Fedora.

Wndows81, Yosemite, Fedora and Arch Linux using Chameleon as the main bootloader.


Which partition is your default 1st boot?

Share this post

Link to post
Share on other sites

:D Believe me, Elementary OS (a Ubuntu derivative) is a full Linux distro! Just Like Ubuntu itself is full Linux.


Do you mean I have to remove grub from sda?


My UEFU computers boots Grub from /dev/sda and the default os to boot is Elementary. But When I boot the OSX harddisk (UEFI F8 selection) then that is the default.




Share this post

Link to post
Share on other sites

yeah I think so, we'll wait for the final release of Freya. :D


I finally manage to make a quad boot just now.


Try to remove the grub on sda


is there a Disable Secure boot on your bios settings?


Can you check the chameleon version your using?

Share this post

Link to post
Share on other sites

Darwin/x86 boot v5.0.0.132 - Chameleon v2.2svn r2286 Build date: 2013-12-27 22:41:01


Secure is disabled in Uefi

I'l have to find ut how to remove grub on bootsector sda.


What bootmanager do you use on your quad boot system?

Share this post

Link to post
Share on other sites

You might want to purge or remove it from sda.



Here's the demo


I install windows first, then Yosemite (installed Chameleon bootloader), then Fedora (install grub on its partition), then Arch (install grub on its partition). No extra editing on grub cfg files.


Basically Chameleon handles all those partition. If you will follow rehab's link, you will gain knowledge on multiple booting.

Share this post

Link to post
Share on other sites

I did not get it working with chameleon. So I did a reinstall selecting the Clover uefi bootloader. No clover startsup en lets mee chosse between Windows 8, Linux Ubuntu and OSX. Eventhing worked perfect till today. I'll open a new thread.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...