Jump to content

Problem after installing Yosemite, gray screen (pantalla gris)

Recommended Posts

Hello everyone,


My problem starts to reboot after installing ("Niresh Yosemite 10.10") after installation, when you reboot and should enter the settings for the first time, shows a gray screen, and not continuous from there. I've tried many flags (-v, -f -x -F, cpus=1, GraphicsEnabler=No, UHCIreset, etc...) but the result is the same, a gray screen, I can't think of anything else, had already installed "Niresh Mavericks" but had not had problems (at least with the installation), and installing Yosemite, I leave with customization options by default, I do not move anything, and yet the result is the same, at the beginning of the installation but using the flag for my AMD processor ("/amd64") I went out error ("still waiting for root device"), but it solves the flag (USBLegacyOff=Yes), and then if starting the installation.


Here the specs of my PC, is an old machine, but still could install Mavericks:


CPU: AMD Athlon 64 x2 Dual-Core

GPU: Nvidia Geforce GT 8400gs 512 MB

HDD: Hitachi 320 GB SATA

RAM: Kingston 4 GB

Motherboard: MSI Nvidia chipset (MCP61P)

Ports USB: only 2.0




PDT: Sorry for my por English.





En Español:




Mi problema es que después de reiniciar luego de haber instalado "Niresh Yosemite", cuando debería entrar a la configuración del Mac por primera vez, me aparece una pantalla gris, nada mas, solo una pantalla gris y se queda ahí congelado, he probado con todos los flags que encontré (-v -f -x cpus=1 GraphicsEnabler=No etc...)  pero el resultado sigue siendo el mismo, la misma pantalla gris, no se que hacer mas, pues creo que lo he intentado casi todo, antes tenia instalado "Niresh Mavericks" y la instalación no genero muchos conflictos, y de ahí uno que otro problema pero ya, andaba, incluso en la instalación de Yosemite en la parte de personalizar la instalación lo dejaba por defecto y el resultado después de reiniciar es el mismo, a pesar de que mi procesador es AMD, usaba el flag "amd64" y me generaba el error "still waiting for root device" y lo arreglaba con el flag "USBLegacyOff=Yes" y la instalación continuaba normalmente.


Estas son las especificaciones de mi PC, es vieja pero aun así pude instalar Mavericks:



CPU: AMD Atlhon 64 X2 Dual-Core

GPU: Nvidia Geforce GT 8400gs 512 MB

HDD: Hitachi 320 GB SATA

RAM: Kingston 4GB

Placa: MSI chipset Nvidia (MCP61P)

solo con puertos USB 2.0



Share this post

Link to post
Share on other sites

Because nobody answered or helped me and left me alone with my problem, I had to keep trying with other flags and other solutions until they solved it. To start when installing keep in mind the following points:

1. If you have AMD, and are installing Yosemite but your BIOS does not support AHCI or changed but you still get the error: "Still waiting for root device" in addition to the flags for amd and -v -f, also used: USBLegacyOff=Yes or USBBusFix=Yes. and the installation in the section "customize" select "totally fix still waiting."
At least to me it worked me.

2. The solution to my problem (gray screen after the first reboot after installing.) If you are installing before you start, go to "customize" and select npci=0x2000, but if you already installed and're stuck in the reboot that takes you to the gray screen, then enter the same bootflag at the beginning: -v,  -f and npci=0x2000 and ready, but you could also try npci=0x3000, then add the boot .plist.
Of course this also I worked.

At least with this as I have an almost functional Yosemite, then at least let you in and Login, then remains fixed, app store, safari, but that's another thing.

I hope I could help with the same problem, at least I try.

PDT: Sorry for my poor English

Share this post

Link to post
Share on other sites

@kamilo_zamar updating your kernel to the latest version will fix your safari glitches there is an appstore fix available in downloads section

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...