AMD FX8350 and HD7850 1GB - starting only in safe mode - Hackintosh Yosemite - Hackintosh Zone
Jump to content

AMD FX8350 and HD7850 1GB - starting only in safe mode

Recommended Posts

Hi, I have a problem.
I installed yosemite 10.10.1 build, everything went good with npci=0x2000 (for the first time, I always had a problems even with install).
It booted after install but the only thing which I seen was white/gray screen with rainbow-circle cursor. -> GraphicsEnabler=No (without this it even can't pass bootloader screen -> memory allocation problem)
Next I tried -x flag to start in safe mode. OK it started. I created user account, and logged in. 
In safe mode everything is super laggy (but it is normal I think?).  However i dedected my GPU and screen has native resolution (1080p):
I have no sound too… it is problem for later, priority is get to work my GPU without safe mode
My complete setup:
MOBO: Asus M5A97R2 LE
GPU: Club King Radeon HD7850 1GB Royal King
CPU: AMD FX 8350
Soundcard: Creative X-FI Audio PCI


Thanks in advance for any help!

Share this post

Link to post
Share on other sites

I Was having the exact problem on my specs:

MSI 970A-G46 AMD970A s.AM3.

AMD FX 6300

4 GB RAM 1600 MHZ Kingston

Samsung Spinpoint F3 500 GB (i think)

Sapphire Radeon 6670 2 GB


I didn't know what to do, so i've installed Mavericks 10.9, but i didn't upgraded it yet BUT, now everything is working just like it supposed to. Maybe Your card just like mine is not supported, or we need to change something in order to work.

For example you need to add kernel flag AtiConfig = Zonalis... Check this site:


It has compatibility table for every os x system, maybe you can found your answer here.


Check this out, maybe this will work:


Go down to Update - 03.28.2014


Maybe this: will help you as well

Share this post

Link to post
Share on other sites

install kernel and kexts worked for im on amd 8320 and nvidia gt 620

Share this post

Link to post
Share on other sites

Had the exact same problem as you, i got it working (FX-8320 HD 7770)

Share this post

Link to post
Share on other sites

It is working. Thanks!

I installed :



Now only Audio is not working.
I will search for some kexts for my Creative sound card (SB1040)
, but if someone already has working one, please share it.


Thanks again!
Sound is working. I have first fully working OS X on full AMD platform ever o/
first link :

Share this post

Link to post
Share on other sites

ok i promise you this will solve your problem i have seen this many times and been through it myself 


mine and many others would also only start in safe mode this will solve your problem

Share this post

Link to post
Share on other sites

OK, everything is working fine as I said (almost), but...


Audio ... everyting is OK till restart

I created combined Audio via SPDiF without this (I don't know why).

Generally I'm using digital out for media center (Audio via multiple device -> this can't be done on windows without external app, but even with app the latency is too high)


But after reboot I need go to settings -> sound, select this combined Audio device and then analog -> after this I have sound in kodi (digital) and pc (analog).



I was thinking about this Audio problem, and I got a idea, how to fix it :D


Automator->App->shell script > save
SwitchAudioSource -s 'Urzadzenie' 
afplay /Users/pawel/click_one.mp3
SwitchAudioSource -s 'Line-out (Green Rear)'
1st line -> change default sound adapter for my SPDiF, of course this is my device name, you should write yours
2nd line -> play click sound (actually it is very important, only when sound is playing the SPDiF is activating)
3rd line -> go back to default Audio out
Next -> add this app to autostart
And ... It is working ! :)
The only problem now is internet. Sometimes it working all day, and sometimes it is stopping after few minutes...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hackintosh Zone Donations

    Hackintosh Zone is a free website with most useful Hackintosh Resources, We try to keep it that way, Your donations and disabling Adblock makes this site going on.

    $8.78 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • It's basically a problem with your graphics card, so try doing this.   In the boot options go to graphics injector and make a tick on intel graphics injector.   Also make sure you go to your bios and disable your discrete graphics Card.   After doing these to things, it solved the issue for me!! Hope it helps!
    • I installed Yosemite with the use of iGPU but when I installed the eGPU as mentioned on the title the loading screen stuck on caution. I also tried the bootflags such us  nv_disable=1 and nvda_drv=1 also I tried GraphicsEnabler=Yes/No but still no luck. What might be the possible problem? Image link
    • Information BrandHP Model450 G1 (F6B14PA) Dimensions(WxHxD)375 x 256 x 22.0  mm Weight2.4 Kg ColorsSilver Operating SystemWindows 8 Professional Operating System Type64-bit Display Details Display Size15.6 Inches (39.62 cm) Display Resolution1366 x 768 Pixels Display TypeTFT Display FeaturesTFT Colour Display Display Touchscreen  No Performance ProcessorIntel Core i5-4200M (4th Gen) Clock-speed2.5 Ghz ChipsetIntel HM87 Express Graphic ProcessorAMD Radeon HD 8750M Graphics Memory2 GB Memory Capacity4 GB RAM typeDDR3 RAM speed1600 Mhz Memory Slots2 DIMM Expandable Memory16 GB Memory Layout1 x 4 Gigabyte Storage HDD Capacity750 GB HDD Speed(RPM)5400 RPM HDD typeSATA Battery Battery Cell6 Cell Battery typeLi-Ion Power Supply90 W AC Adapter W Battery Life8.5 Hrs Networking Wireless LAN802.11 b/g/n Bluetooth Bluetooth Version4.0 Ports USB 3.0 slots2 USB 2.0 slots2 SD Card Reader Headphone Jack Microphone Jack VGA Port Multimedia Web-cam Video Recording720p HD Secondary cam(Rear-facing)  No Audio SolutionHD Audio Solution SpeakersStereo Speakers Sound TechnologiesDTS Sound+ In-built Microphone Microphone TypeDigital Microphone Peripherals Optical DriveDVD+/-RW SuperMulti DL Drive TypeDVD Writer Pointing DeviceTouchpad with Multi-touch Gesture Support KeyboardFull-sized, spill-resistant keyboard with numeric keypad  
    • Does anyone have some advice on this issue? I'm stuck in the same spot and searching the forums for answers. thanks
  • Download Statistics

    • Files
    • Comments
    • Reviews