Jump to content

App store login problem on OS X 10.8.5 VirtualBox

Recommended Posts

I wonder if anyone can help me, I am having weird issue with app store login on OS X 10.8.5 running on VirtualBox - I cannot enter my password when trying to download an app or view my account information. There is no error nothing, simply nothing happens when I enter password. I can get signed in to the app store, by associating apple ID with computer account, so app store shows me as signed in. But when I try to download anything I need to re-enter apple ID/password again and now in the app store, and the above problem happens then. Also, I can login to iTunes and do anything from within iTunes, like enter password, check account, without any problems. 


I installed iAtkos or Olarila distors of OS X 10.8.5, I have the same issue in both distros.


I tried all the fixes on the internet. I added EFI string to org.chameleon.boot using EFI Studio. I removed and re-added network interface and made sure it is BuiltIn, Active, and en0. I changed serial number, make, year in smbios.plist using Chameleon Wizard. Nothing worked. Actually I am not sure these fixes and the problem I have are related.


I run hackintosh on VirtualBox with simulated Ethernet card, but the host box connects to local network via wifi, and the local network itself is in a university, so it is on a local IP block, behind firewall and all that. I don't know if any of these may contribute to the login failures. Also I am physically located in Turkey. I tried using apple ID's created with US or Turkey address, with and without credit card, and tried to access both US and Turkey app store. Obviously none of these helped either. 


Please help, what can I do to resolve or troubleshoot the login problems, or what alternatives I can use to mac app store, or can I circumvent the second login during purchases in mac app store somehow?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.

    $22.30 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • I get this message no matter what I do, I've tried changing my SMBIOS to a newer model to no avail. Anyone no how to get the second install boot to work?
    • This is my first time doing Hackintosh. I've several other machines running Mac using UniBeast and Multi beast. I wanted to try Hackintosh Vanilla. So far, no luck. I followed the Guide and MacPwn Mojave Guide. 
    • Hello! I wanted to install MacOS High Sierra, but the SSD does not appear in Disk Manager. I have a Samsung Pro 840 250GB. Is there a Driver for Intel Gigabit 82579LM Network LAN for MacOS High Sierra?
    • This is my very first post and have looked around the forums to my question but I wasn't able to find the exact specifics that I need. This is my very first windows/mac dual boot project. I chose to attempt high sierra and I hope I am posting in the correct area. High Sierra seemed to be the newest that is possibly more stable than Mojave so I chose that. I'm reaching out to the more advanced builders and experienced people. I'm currently running Win 10 as of now and bought a separate SSD to install a macOS on. Before I invest time and energy into this. I'm wanting to get the best recommendations on what OS I should choose , if my hardware will be up for the task and my best plan of attack. I'll be honest I'm not ready to bang my head on the keyboard for hours. I've been there and done that.  My hardware was some of the best at its time in 2011 and I'm not 100% confident it will work with a more up to date macOS I'm also concerned about drivers for my GPU.  All input is welcomed   Here are my current specs:   CPU
          Intel Core i7 2600 @ 3.40GHz    28 °C
          Sandy Bridge 32nm Technology
          8.00GB Dual-Channel DDR3 @ 668MHz (9-9-9-24)
          ASUSTeK Computer INC. CG8350 (LGA1155)    26 °C
          NS-24E730A12 (1842x1036@60Hz)
          1023MB NVIDIA GeForce GTX 560 Ti (NVIDIA)    31 °C
          3726GB Western Digital WDC WD40EFRX-68N32N0 ATA Device (SATA )    25 °C
          111GB PNY CS900 120GB SSD ATA Device (SATA (SSD))    33 °C
          931GB Seagate ST31000528AS ATA Device (SATA )    30 °C
          3726GB Western Digital WDC WD40EFRX-68N32N0 ATA Device (SATA )    27 °C
      Optical Drives
          HL-DT-ST BD-RE BH12LS35 ATA Device
          NVIDIA High Definition Audio 
    • Hi! Everything seems to install ok, but after reboot, it just says Disk Booth Failure Insert system disk and press enter.. Don't have a clue about what can I do!   Francisco
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By Niresh

    184    2