Jump to content

Help With Elitebook 8760w - i7 /AtiGFX-m5950

Recommended Posts

Hello all,
  Hoping someone who knows how to deal with this stuff will climb aboard with me and walk me through this.  
 I’ve got Yosemite-Zone 10.10 Up and running on an HP Elitebook 8760w With an i7 2860qm and Ati m5950 (HD6770) HP Branded romless video.  

Set it up, it boots consistently, I’ve added a user and can reboot through clover (installed on the EFI partition that Mac creates in the GUID Mac Partition.)  Right now I can not boot to the Clover Hard drive unless the USB Install media is present at boot time.  Had no luck using the Chameleon end of the install even though this is like an exact opposite of what had been happening.

As It Stands I Have a basically Virgin install that stays running, and shuts down/restarts without issues.  Graphics have  not been messed with except to specify 1920x1080 in the initial set up.

  My 500 Gb HD is in two HFS+ Partitions, This install is on the first partition, second was formatted in Disk Utility during install and untouched.  I’d really like to know how to proceed from here with out screwing this up.  
I’ve tried multibeast and have never had any success.  I’d really like to join the PBI bandwagon,, but I’ve had absolutely no success with that route yet.  Whether it be cloning this install and using it as a test bed, using my other resources to install development environments or whatever, if you are willing to lead me in the right direction and offer some guidance sign up below!!

My first priority for me is to get this backed up so If I screw it up I can get back again.  Next would be a pretty huge one,  I had created a HFS+ Partition on my windows drive at some point for some storage away fro my install drive.  Well now if I have that drive in the computer during boot the boot fails when it mounts that partition, just freezes.  Happens that the name of the partition is “USB” because it started as a clone of a good install media.   …Anyway.  

 I’ve got a handful of resources thatI’ve collected which include both HP’s last bios for this machine and the most recent update which was a security fix for the UEFI system,   A copy of the rom for the romless video card in the machine.  If Everything goes right, access to both a Mac environment and a Windows 7 environment, Familiarity with the linux command shell and bash stuff in general, willingness to set up anything else needed to help on this end.  

Don’t even care if I ever get that far,  just want to be able to boot both Windows 7 and this version at least of OS X ( Hopefully with at least a little VA) Consistently and safely for the machine.

Please provide links for anything that you can right off hand, otherwise I’ll gladly do the legwork.

Thanks for any help, and I’ll gladly provide any info to help any other user along, at your own risk of course.

Share this post

Link to post
Share on other sites

@dtrud0h you have stated that you have a EFI Partition so

boot the Installer run this command

dd if=/usr/standalone/i386/boot1h2 of=/dev/disk0s1

i assume that you only have 1 Hard disk and You stated it is GUID

Share this post

Link to post
Share on other sites

Yes, I got Clover installed on EFI partition. Works now on that.problem. Next I am trying to get DSDT to compile. Can get through most errors, but down near the end of the list I end up with "Brackets don't match " error and had got to a point where only 1 error left that said " unexpected end of file expected $end" or something like that and I couldn't figure out how to get rid of that one. I appreciate your reply and the work you are doing.

Why boot2h instead.of boot1h? I put 1h in there and it works, what's the difference between the two files?

Share this post

Link to post
Share on other sites

Just a follow up post here.  I ended up using the PBI method, everything works perfectly with files dated closest to the date of this post.  Yosemite 10.10.1 


Not going to mention where I got the files / **tmX86**/ but the method, although hard to follow worked perfectly once I followed the directions to a "T". 


Thanks for your help Niresh, I wish I could have gotten your files to work for me.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...