[Request] AMD R9 280x Kext for Yosemite - Graphics Kexts - Hackintosh Zone [Request] AMD R9 280x Kext for Yosemite Jump to content
rainmaker3

[Request] AMD R9 280x Kext for Yosemite

Recommended Posts

OK, I have a 280x Sapphire video card. This card worked on Mavericks perfectly with Chameleon and the vanilla kexts and it was recognized as a 7xxx card. In my research I have found that the 280x has the same framebuffer and characteristics as the HD 7970 so the kext recognizes it as a 7xxx series. 

 

After updating to Yosemite, the vanilla kext doesnt load and I get stuck before the login screen. It boots up in safe mode and recognizes the card as 7xxx series. I have tried different SMBIOSes but none work. I have tried reverting the ones from Mavericks and I got KP.

 

I have never done a request so I don't know what else is needed. If I can help somehow, please tell me. Thanks in advance.

Share this post


Link to post
Share on other sites

OK, I have a 280x Sapphire video card. This card worked on Mavericks perfectly with Chameleon and the vanilla kexts and it was recognized as a 7xxx card. In my research I have found that the 280x has the same framebuffer and characteristics as the HD 7970 so the kext recognizes it as a 7xxx series. 

 

After updating to Yosemite, the vanilla kext doesnt load and I get stuck before the login screen. It boots up in safe mode and recognizes the card as 7xxx series. I have tried different SMBIOSes but none work. I have tried reverting the ones from Mavericks and I got KP.

 

I have never done a request so I don't know what else is needed. If I can help somehow, please tell me. Thanks in advance.

Hello dear, will you please tell me how you get your r9 280x card work on maverick? I have the same card and I am new to hackintosh. I have managed to make everything work but graphics card is not working. and I have tried to move the bootloader to EFI partition following the instruction given here: http://www.tonymacx86.com/401-install-bootloader-extra-efi-partition/ but for some reason, I got an error after I use this commad "fdisk -f boot0 -u -y /dev/rdisk0". I installed maverick using niresh maverick, I did not use unibeast to install maverick. maybe that is why it failed when I followed that tutorial. Now I am very very desperate. I do not know how to get it work. Please please tell me how I can make my graphics card work.
My System specs:

core i5 4590
MB : Asus H81M-E

SSD: transcend 370s 256 GB
Graphics: Sapphire Vapor-x R9 280X
RAM: Corsair Vengeance 8GB  
Please help me. thanks a lot.

Share this post


Link to post
Share on other sites

Sry, I just saw this post. I installed the latest chameleon (enoch) bootloader and I booted using these flags : "AtiConfig=kFutomaki AtiPorts=4 GraphicsEnabler=Yes". Try it with GraphicsEnabler=No initially and if it works OK then turn it on and see if it runs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting July 2018

    Please donate to support the community.
    We appreciate all donations!

    Thanks



    $22.30 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • Hi,   I have purchased  Core i3 7100 Processor 16GB Memory 240GB SSD Nvidia GTX730 2GB DDR5 Graphics Cards Asus H110m-cs Motherboard LG 25" HDMI Monitor TPLink 781ND V2 Wifi PCI   Deployed High Sierra  10.13.6 using unibeast and multibeast option, changed bios settings as well and the problems now facing are   1. Display showing as Nvidia Graphics 5MB 2. TPLink unable to install 3. Vodooo install for Audio, but HDMI audio not working, whereas via Audio jack working fine.    Please help me to resolve this issue which is running for more than 1.5 months   Thanks
    • HELLO EVERYONE I HAVE REACH A WALL, IM TRYING TO INSATLL YOSEMITE ON MY PC. I DID EVERYTHING BY THE VIDEO BUT CANT GET PASS THE APPLE LOGO WITH PROGRESS BAR THAT IS NOT MAKING PROGRESS. CAN SOME ONE PLEASE HELP. HERE'S MY SPECS HP DESKTOP PROCESSOR: AMD A4-5000 APU WITH RADEON (TM) HD GRAPHICS: 1.50 Ghz INSTALLED MEMORY: 8:00 GB X64 BASED PROCESSOR
    • I have an old lenovo s10-3 notebook that i want to take to holiday but i simply cannot install it it gets stuck at hfs mounted os x base system on device root than some bluetooth error comes up and no more its been a good 3 days to come this far.   i belive its the gpu kexts becouse it has a Intel GMA 3150 gpu i found the kext for it but i dont know how to run them with the usb installer.   i am trying to install: Niresh Maverick Usb   cpu : intel atom n450 1.66ghz ram : 1gb hdd : 255gb   sata mode is achi boot args are these : atom cpus=1 npci=0x2000 nv_disable=1 dart=0 -f -v -s GraphicsEnabler=No the needed ones are : atom cpus=1  dart=0 -f -v  GraphicsEnabler=No please help i need this notebook working in 3 days  
    • Hey friends, i need the DSDT  for mac OS X MAVERICKS 10.9.5  of my laptop (SAMSUNG R430), i can't find it anywhere. thanks!
    • @svpsl08 Your images don't work and post your specs as text don't share images, Have you tried installing High Sierra?
  • Download Statistics

    • Files
      850
    • Comments
      2,144
    • Reviews
      2,586

    Latest File
    By Niresh

    1060    0

×