Jump to content

Bootloader help please... must use USB stick boot loader to boot.

Recommended Posts

I've got an old Dell Inspiron 1525 laptop. I installed Yosemite 10.10 via Yosemite Zone onto an AMD Gigabyte GA-MA785GM-US2H Rev.1.3 w/Phenom X4 CPU. This install was problematic, I didn't get much working yet, no WIFI (have Netgear WN3111B 802.11n Broadcom WIFI), no sound, no boot from HD boot loader, only USB Yosemite Zone boot loader. This was updated to 10.10.1, but it's a difficult situation.


I cloned this problematic AMD desktop installation onto a laptop internal HD and changed the kernel, DSDT.aml, SMBIOS.plist, and a few other minor things, and attempted to boot this installed Yosemite System on the old Dell Inspiron 1525 laptop w/Intel x3100 graphics. To my great surprise, it booted fine. I found a download for some 64-bit kexts for the old Intel x3100 graphics, which I assumed would never work or give acceleration, and during the verbose startup dialog, I always see the x3100 driver panic, but somehow it later seems to reload, and is shown loaded by kextstat, and better yet, every test I've done seems to indicate I have full graphics acceleration on an old x3100 under 10.10.1 which seems unbelievable and incredible to me. Before these 64-bit kexts the x3100 only recognized as 4mb, and there was no acceleration. Now it's perfect recognized at 144mb, with full acceleration seemingly.


AFAIK everything seems to work on this Inspiron 1525 with the exception of iMessage. The trackpad is slightly fidgety, but works. Sound is a little low volume, but not too quiet. Everything just works, probably the best of any version of OS X I've installed on this laptop, including 10.6.8, 10.7.5, and 10.8.5. I assumed 10.8.5 was "the end" because I used MLPostFactor for the 32-bit compatible x3100 acceleration, and assumed I'd NEVER see a working 64-bit driver for the x3100 under either Mavericks 10.9 or Yosemite 10.10. I am amazed.


PROBLEM: can't get a HD-installed boot loader to work. I've tried several combinations. Right now I've got one HD formatted MBR w/ Chameleon from Yosemite Zone 10.10 USB installer. This will load the Chameleon boot loader graphically, but the boot never completes, it stalls hard after the verbose leaves but before the desktop screen appears. If I use the Chameleon textual on the Yosemite Zone USB installer, which always shows as a textual rather than graphical, it will always boot fine without any problems or errors. The same Chameleon version from the HD stalls every time.


I've also got an identically cloned GUID HD with Clover installed. Almost same problem, only Clover never even loads, the HD is completely invisible to the laptop unless booted from the Yosemite Zone 10.10 USB stick w/Chameleon textual. Only then the HD is recognized, and will boot normally. Perhaps I need MBR w/Clover?


So the problem is: I can clone this WORKING System onto ANY HD, and I can format the drive any way (MBR or GUID), and I can install any boot loader (Chameleon Standard, Chameleon EFI, Clover Standard, Clover EFI), but I NEED to be able to boot without using the boot loader from the USB stick. What format should I use for the HD (MBR or GUID)? What boot loader, I'm leaning toward Clover because I want to fix the iMessages, and supposedly there's a Clover based fix for the iMessages login validation issue (yes, my board & serial match w/ real Mac serial). I've never used Clover, only Chameleon, but I need some working boot loader ASAP. Help would be appreciated...

Share this post

Link to post
Share on other sites

Please give me your X3100 drivers that support hardware acceleration. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.

    $17.56 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • HI i have this card ATI Radeon HD 5770 Series and I have it working, but I got a problem with vram only have 7 mb I need help to solve this because i have problems with some glitches in the display. I haver clover . PD: My graphics card have 2gb      
    • Hi, I am trying to make bootable USB for Hackintosh , I tried TRANSMAC and Win32disk image from my Windows 10 PC, soon after completion USB not accessible. Please advise.   Thank you,  
    • That's happen every time that i am trying to install a hackintosh on my pc i can't find a solution. I tried a lot of different flags.  Pc specs:  GeForceGTX760 4GB Intel i7-4820K MSI Global X79A-GD65 (8D)   There is a video: https://streamable.com/us6nf  
    • nobody can help me
    • I have a GA-H81M-S mobo with G3240 Pentium (R) processor. I am not using the IGP but an Nvidia GT-710 1GB DDR3 dedicated Graphics card. I followed posts in other forums and managed to install once. After upgrade and reboot, I messed with clover configurator and now I can't get to the install screen. I get stuck on VoodooPS2Mouse: Version starting on OS X Darwin 16.4. If this forum is still alive, please help
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By Niresh

    230    2