Jump to content
Sign in to follow this  
Alvaro Ursua

Stuck at grey screen with loading cursor (only boots in safe mode)

Recommended Posts

Alvaro Ursua

After installing Yosemite I have tried to boot back in, but I am only sucessfull with safemode (which does not allow me to acess any drives or internet)

Without safemode I am waiting at a greyscreen with a "loading" cursor.

I tracked the error down and the error is:

"Warning : Could not block sleep during cache update

Warning: Proceeding w/o DiskArb"

I guess its just not scanning the drive that has the actual operating system and its going to a blank grey screen. Anyone know what to do? Ive tried using UseKernalCache=No and theres no luck.

My build:

CPU: AMD FX-8320, 3.5ghz

Graphics: Sapphire Radeon HD 7770 1GB

MoBo: ASRock 990FX Extreme3 AM3+

Audio: Realtek ALC892

Share this post

Link to post
Share on other sites

I get the exact same thing on my build.


CPU = AMD-FX 8320

GPU = Sapphire 280x Tri-X 3GB

Mobo = Asus M5A97 R2.0


I had a Mavericks installation prior to that, and a time machine backup. I booted Yosemite in safe mode and tried to transfer the files and it got stuck so I rebooted. It gave me a b-tree node size error and I lost all my backups. I also had the Yosemite Zone install USB on and the same thing happened to it as well. So now I'm stuck with this.


In a previous update that I did (10.9.5) the same thing happened. I managed to get over it by replacing some kexts with the ones from version 10.9.0 . They were these :


AppleACPIPlatform, IOACPIPlatform, IOPCIFamily, IOUSBFamily.


Now, Niresh's Yosemite install only worked in safe mode and after replacing these with the Mavericks ones I got a GenericUSBXHCI error (outdated) and it got stuck at "Still waiting for root device". If you could replace these AND the GenericUSBXHCI from the Mavericks Niresh install USB it might work. But MAKE SURE YOU HAVE A TIME MACHINE BACKUP FIRST!!!


Niresh please see this.

Share this post

Link to post
Share on other sites
Daniel Conte

Guys, I have a similar configuration, and I have the same problem

(Sorry for english)


I have 

CPU : FX 8350

MOTHERBOARD: Asrock 990fx extreme 3

GPU: Sapphire R9 270x Dual x 4gb OC


I have mavericks perfectly work on my pc.

But now i want upgrade to Yosemite (For Final cut upgrade, and other thing)


With 10.10 when I started with -v npci=0x2000 and GraphicsEnabler=Yes the monitor going off.

With 10.10.1 when I start with -v npci=0x2000 and GraphicsEnabler=Yes/No the monitor keep on grey screen with cursor.


If i start with -x the GPU is viewed (Readon HD 7xxx 4096, but is not important this.) and I can also change resolution in 1080p . But this in only safe mode.


I think it is not a graphic problem, because in safe mode the gpu is viewed. 


Can you help we?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...