Jump to content
Sign in to follow this  
Arunim Choudhary

Graphics issues on Yosemite

Recommended Posts

Arunim Choudhary

I am on gtx 650 and amd fx 8350. I did a clean install and i can't boot without nv_disable=1 . I installed the nvidia web driver but no help :( . I think its an nvda(openGL):exception error

Please help

Share this post


Link to post
Share on other sites
Naganex

I am on gtx 650 and amd fx 8350. I did a clean install and i can't boot without nv_disable=1 . I installed the nvidia web driver but no help :( . I think its an nvda(openGL):exception error

Please help

what is your bootflags? i think the simple way is like this:

for first boot (you install outside Chameleon screen)

 

        /amdfx GraphicsEnabler=Yes PCIRootUID=0 -v npci=0x3000

 

after reboot you login to boot inside Chameleon screen (if you using Gigabyte mobo you must use PCIRootUID=1)

 

        -amdfx GraphicsEnabler=Yes PCIRootUID=0 -v npci=0x3000

 

remember to download Chameleon Wizard  and install it with latest update after installing Yosemite

run Chameleon Wizard and klik org.Chameleon.Boot

and check an option like boot-flags you use before and Save

Now you can start your Yosemite only with hit Enter... ^_^

Share this post


Link to post
Share on other sites
Arunim Choudhary

what is your bootflags? i think the simple way is like this:

for first boot (you install outside Chameleon screen)

 

        /amdfx GraphicsEnabler=Yes or No PCIRootUID=1 -v npci=0x2000

 

after reboot you login to boot inside Chameleon screen

 

        -amdfx GraphicsEnabler=Yes or No PCIRootUID=1 -v npci=0x2000

 

remember to download Chameleon Wizard  and install it with latest update after installing Yosemite

run Chameleon Wizard and klik org.Chameleon.Boot

and check an option like boot-flags you use before and Save

Now you can start your Yosemite only with hit Enter... ^_^

Share this post


Link to post
Share on other sites
Arunim Choudhary

Already tried it, nothing :( nv_disable=1 makes my.computer very laggy but it only works that way, i think i need a driver that works perfectly with my gpu gtx 650

Share this post


Link to post
Share on other sites
Naganex

Already tried it, nothing :( nv_disable=1 makes my.computer very laggy but it only works that way, i think i need a driver that works perfectly with my gpu gtx 650

What is you motherboard? If you use Gigabyte i think this boot-flags will work :

 

   -amdfx GraphicsEnabler=Yes PCIRootUID=1 -v npci=0x3000

 

If your not using Gigabyte, it should be like this

 

   -amdfx GraphicsEnabler=Yes PCIRootUID=0 -v npci=0x3000

Share this post


Link to post
Share on other sites
Arunim Choudhary

What is you motherboard? If you use Gigabyte i think this boot-flags will work :

 

   -amdfx GraphicsEnabler=Yes PCIRootUID=1 -v npci=0x3000

 

If your not using Gigabyte, it should be like this

 

   -amdfx GraphicsEnabler=Yes PCIRootUID=0 -v npci=0x3000

Asus m5a97 Le r2.0

Will try that later

Share this post


Link to post
Share on other sites
Arunim Choudhary

Asus m5a97 Le r2.0

Will try that later

Didn't work

Share this post


Link to post
Share on other sites
Naganex

Well, I think the problem is with your BIOS setting.

Use this to set up your BIOS

  • To access BIOS/UEFI Setup, press and hold Delete on a USB Keyboard while the system is booting up
  • Load Optimized Defaults
  • If your CPU supports VT-d, disable it
  • If your system has CFG-Lock, disable it
  • If your system has Secure Boot Mode, disable it
  • Set OS Type to Other OS
  • Save and exit.

Hope it will help.

Share this post


Link to post
Share on other sites
Arunim Choudhary

Well, I think the problem is with your BIOS setting.

Use this to set up your BIOS

  • To access BIOS/UEFI Setup, press and hold Delete on a USB Keyboard while the system is booting up
  • Load Optimized Defaults
  • If your CPU supports VT-d, disable it
  • If your system has CFG-Lock, disable it
  • If your system has Secure Boot Mode, disable it
  • Set OS Type to Other OS
  • Save and exit.

Hope it will help.

does not work

Share this post


Link to post
Share on other sites
Naganex

Already tried it, nothing :( nv_disable=1 makes my.computer very laggy but it only works that way, i think i need a driver that works perfectly with my gpu gtx 650

if it work but your computer is laggy, i agree you must try to install the kext for gtx 650. try this link: https://www.insanelymac.com/forum/topic/290941-nvidia-geforce-gtx-650ti-on-1084-hackintosh/

Share this post


Link to post
Share on other sites
Hackintosh

@Arunim Choudhary just add nv_disable=1 to chameleon boot config flag

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...