Jump to content
Michael Fletcher

My Installation Experience, Tips Wanted

Recommended Posts

Hi there,

I'm looking to get some help with installing Yosemite on my computer. I am kinda new to installing Hackintoshes. I have made several attempts in the past, some with luck and other times not so much. My last attempt was with Mavericks with this same computer, and it would install and boot up the first time, but after that I was never able to boot into it again after the first restart. I honestly couldn't tell you the various Boot-Flags I had to use to get it to work right, but now after reading about "Yosemite Zone" it has sparked my passion again to try and get this hackintosh installation working, but this time I figured I would ask for help rather than just googling each problem. I wanted to actually put Yosemite on it's own hard drive bringing me up to 3 hard drives inside my computer (One being windows and the other a data master drive where I house all my information, programs, media etc), but if this is not an easier route I am fine with partitioning a current hard drive. I planned on getting started late tomorrow, as to give me time to read any responses I get back from this community and complete prior engagements, I have a family of 2 soon to be 3 so I can get pretty busy, so I apologize now if I take a while to response or read your replies. Below I have listed my computer hardware specs, I really look forward to hear your responses and hopefully have a stable, working hackintosh.

Thank you in advance!

CPU: Intel Core i5-3570K 3.4GHz Quad-Core

Motherboard: ASRock Z77 Pro4 ATX LGA1155

Memory: Kingston 8GB (1 x 8GB) DDR3-1600

Storage: 2x Seagate Barracuda 2TB 3.5" 7200RPM

Video Card: MSI GeForce GTX 670 2GB

Ethernet: Realtek RTL8111E

Audio: Realtek ALC892

Edit 1: So far I can see that my graphics card and my motherboard are the only things that might/should have issues due to the following posts:

Graphics Card: http://www.tonymacx86.com/mountain-lion-desktop-support/109311-msi-gtx-670-not-working.html

GTX 6xx Series not booting (possibly setting memory allocation to "auto" may fix this issue)

Motherboard: http://www.tonymacx86.com/mountain-lion-desktop-support/90485-asrock-z77-pro4-will-work.html

Power Management Issue it seems, I can't find a link to a modified bios as they all lead to no where. Maybe I'll have better luck finding a patched appleintelcpupowermanagement.kext.

Edit 2: I have some extra freetime tonight, Maybe about 2 -3 hours so I am getting started ahead of time using the Yosemite Zone DMG and guide. The link is located at the bottom of this edit. I'm downloading the DMG as I type this, ETA to finish 15 - 20 minutes. Wish me Luck!

https://www.hackintoshzone.com/hackintosh/articles/yosemite-hackintosh-installation-instructions-guide-and-videos-for-amd-amdfx-intel-haswell-hp-laptops-common-pc/

Edit 3: Download has finished, Restoring the DMG with TransMac. After this is done, I will be updating from my iPhone after this, so I can get started with configuring my BIOS and installing Yosemite. I am using an extra 2TB hard drive for Mac. I do understand that Mac will not work with over 1TB, I will partition the hard drive into two 1TB partitions. Perhaps using the other 1TB for extra storage but we will see if it is stable first before I decide. I have my graphics card connected through DVI to prevent errors with HDMI.

Edit 4: Yosemite is installing right now, having a few graphical glitches (I'm hoping they will be resolved post-installation) other than that no issues so far. Installation will be complete in ~14 minutes. Sorry for the change in formatting, updated to fix.

Edit 5: Well after the initial reboot I ran into the Monitor Turn Off Issue, I will have to reinstall. Taking a quote out of the guide: "Monitor Turn Off Issue to resolve it ReInstall Yosemite with all the Backup Graphics Extensions package selected". I feel this will be better than the other solution listed in the guide. I'm going to re-install with all Backup Graphics Extensions package selected. After that I'm going to be headed off to bed, starting fresh tomorrow. I will update this post tomorrow with the results. Good Night everyone!

Edit 6: Good Afternoon! After a bit of trial and error and a few re-installs last night, I haven't made much progress towards a stable build. I am now re-installing with "GraphicsEnabler=No" and all Backup Graphics Extensions. I am able to boot into Mac and Windows with no issues now. The bugs I'm encountering are: Graphical Errors Lack of Ethernet support (I don't have a WiFi card/dongle) so no internet General lag everywhere (which I do believe is from the graphical issues)

I haven't checked on anything performance wise like if my CPU is constantly running at max or anything. I have gotten a tip thank to HackinDoge: "For the motherboard, enable AsusAICPUPM in Clover". Unfortunately I cannot not get Clover to boot without the use of the thumb drive . If I use clover I get the error "boot0ss: error". I'm going to let this re-install finish with Chameleon as my boot loader. Afterwards I will multi-beast as I do worry the graphical error will wear down my graphics card quick. I'm going to take a break for a while, hang out with the family for a while Will update later tonight

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.30 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • @riddlemeright You have not posted any pictures regarding ACPI Error, without pictures I can not debug Also you need to post your full hardware specs
    • @Douglas Dreer use ATH9KFixup.kext with Lilu.kext also you need to add -ath9485 as boot-flag in clover config
    • @tdtech959 Without any pictures of kernel panic it is really hard to debug, but anyhow have you installed whatevergreen.kext with lilu.kext   i had a weird kernel panic when my onboard graphics was turned on, I was able to select external graphics card via BIOS settings as default. are you sure if the USB is the actual problem.
    • Has anyone managed to run the atheros 9485 run on Mojave? I even managed to make it recognize, but it can not find any network.
    • Hello everyone  I have installed High Sierra and updated to 10.13.6 before installing nVidea web drivers. After everything was installed (Kexts and the driver) everything booted fine. Graphics worked perfectly. My onboard USB did not work but I have some generic NEC USB 2.0 card that works fine. After a reboot later in the day, I had a weird kernel panic. It spit out strings no longer than 30 charters and then proceeded to reboot. I have not seen this type of panic . This happened when using the onboard USB 3.0 controller but was fixed by removing the device. But now I'm not sure what caused this. I have reinstalled about 15 times already. Here are my specs: ASUS B150 Plus D3 Intel Pentium G4400 ZOTAC GeForce GTX 1050 2GB WD Blue 500GB HDD 8GB Ram Some generic wireless card (That works) Thanks -T
  • Download Statistics

    • Files
      855
    • Comments
      2,148
    • Reviews
      2,611

    Latest File
    By Niresh

    166    2

×