Jump to content
Carlos Trindade

Guide for Hackintosh Yosemite 10.10 installation using Unibeast and Clover (a hard way!)

Recommended Posts

Table of Contents

Computer hardware
Tools used
Preparation and UEFI settings
Mounting and configuring installer package
Installation of OS X Yosemite in the PC machine

The Boot0: GPT problem

Manual installation of Clover boot loader

The /Extra folder dilemma

Audio problems

HDMI AMD Radeon HD7770 enabling

Audio with Realtek ALC892 onboard Audio

Yosemite 10.10.01 update


1417540478__hackintosk01.jpeg    1417540505__hackintosk03.jpeg    1417540566__hackintosk02.jpeg




This guide was written only with the purpose to help those who, like me, want strictly to do a trial over the possibility of running OS X Yosemite on a PC hardware configuration. The combination of specific hardware and software installation is merely temporary and exclusively for testing purposes. Moreover, this test is just part of a personal private research project. The procedure required a genuine Machintosh machine.



This hasn’t been easy at all and I quitted temporarily the project at least two times. I believe I have tried almost every installation method available to build my hackintosh based first in OS X Mavericks, followed by OS X Yosemite. I had some bad luck because, when I began my project there wasn’t yet a stable version of Yosemite. So, I gave a try installing Mavericks 10.9 using Niresh distro. So far, so good! It is an easy installation, at least in my machine, but my AMD video card wasn’t working properly. I haven’t tried it with the integrated motherboard video card. I decided, almost immediately, to update Niresh installation to Mavericks 10.9.5 version. Everything went fine, except I lost my Audio. This was, of course expected, but I don’t bother to fix it because, meanwhile, Yosemite 10.10 was out. I tried to update Mavericks 10.9.5 to Yosemite with no success at all, in spite I have used Multibeast before booting. I got kernel panic and was unable to fix it. So, I forgot Niresh installation and tried to move on. I tried Clover installation method, as my system is UEFI, but couldn’t ever reach the OS X installer with any combination of boot arguments. I only was able to reach OS X installer when I got Unibeast 5.0.2 and mount my USB pen in my Mackintosh machine. Although, things were just getting to warm up! I think most problems I faced had something to do with my hardware configuration. I confess I wasn’t enough careful when choosing the hardware components for the hackintosh project. In the end, after annoying and countless hours, days and weeks of hard work, I got it just right. Finally OS X Yosemite is running quick, smooth and perfectly stable in my PC machine.


Computer hardware

Case: Aerocool Cube Ds White

Motherboard: Gigabyte GA-Z97M-DH3 Intel Z97 SK1150

Processor: Intel Haswell i5 4690 3,5GHz

Memory: 2 x 4GB Kingston Hyper X Fury DDR3 1600MHz

Graphics Card: Sapphire AMD Radeon HD7770

Ethernet: Realtek RTL8111

Audio: Realtek ALC892

Disks: Seagate SSHD 2,5” 500GB + Maxtor HD 1TB


Tools used

  • Unibeast 5.0.2 - credit: Tonymacx86.com
  • Multibeast 7.0.2 - credit: Tonymacx86.com
  • Clover_v2k_r2999 (or else latest version) - credit: apianti, asava, bluesseau, dmazar, slice2009, Sourceforge.com users, BSD licence.
  • Clover Configurator – credit: mackie100, hackintoshosx.com
  • Kext Utility – credit © cVad 2008-2014, cvad-mac.narod.ru
  • ShowHiddenFiles – credit: Gotoes.org
  • iMac 21.5-inch, 3.1GHz Quad-core Intel Core i7, OS X Yosemite updated; © 2014 Apple Inc. All rights reserved
  • USB 8GB pen with a Unibeast Yosemite install;
  • Clonezilla Live (disk and partition imaging and cloning software) – credit: Colonezilla.org, licence GPL software

Preparation and UEFI settings

Main goal was to install OS X Yosemite on Seagate SSHD 2.5” 500GB disk. I didn’t disconnect anything from my system. Not even the Maxtor HD 1TB disk.

To build the USB installer pen, I used an iMac computer updated to OS X Yosemite.

Since my motherboard has UEFI, I just had to be careful with UEFI initial settings. For this I followed this Macbreaker guide for Gigabyte motherboards: How to set up the UEFI of your Hackintosh's Gigabyte motherboard.

Although, since I have a dedicated AMD Radeon graphic card and would like to use it with OS X Yosemite, had to be special care with graphics configuration in UEFI.

My experience told me that, to avoid boot errors, it would be better to leave the onboard graphics enabled in UEFI. Rules of thumb in this case are as follows:

  1. Enable onboard graphics;
  2. Leave memory graphic size with the value of 64MB;
  3. Set as the first graphic card to look for, the PCI-E card, which is the dedicated graphics card connected to the PCI-E slot of the motherboard (in my case AMD Radeon HD7770).

Mounting and configuring installer package

In the first place, it was supposed to install OS X Yosemite directly from a Clover installation prepared USB pen to be able to settle an EFI clean installation in my UEFI system. Unfortunately, I was completely unable to do that, since I always end with a freezing screen with a white apple in the middle or with a black screen. Of course I tried several boot arguments combinations with no success at all. Maybe I had miss something, but I spent countless hours trying to boot from the Clover USB installer. Then, completely frustrated, I decided to move to Unibeast installation method.

For this procedure I just used "UniBeast: Install OS X Yosemite on Any Supported Intel-based PC" from Tonymax86. At the end, I copied Multibeast to the USB pen root, to be used later.


Installation of OS X Yosemite in the PC machine

Installation from the previously prepared USB pen was almost straightforward. I just had to use boot flag,




to be able to reach the OS X install wizard.


After Yosemite OS X installation I run Multibeast 7.0.2, which is a Yosemite release, and settle the following configuration,



https://raw.githubusercontent.com/Niresh12495/Imgs_move/master/hackintosh/1417540589__screen_shot_2014-11-26_at_121547.png  https://raw.githubusercontent.com/Niresh12495/Imgs_move/master/hackintosh/1417540599__screen_shot_2014-11-26_at_121620.png  https://raw.githubusercontent.com/Niresh12495/Imgs_move/master/hackintosh/1417540611__screen_shot_2014-11-26_at_121631.png  https://raw.githubusercontent.com/Niresh12495/Imgs_move/master/hackintosh/1417540620__screen_shot_2014-11-26_at_121646.png  https://raw.githubusercontent.com/Niresh12495/Imgs_move/master/hackintosh/1417540630__screen_shot_2014-11-26_at_121657.png  https://raw.githubusercontent.com/Niresh12495/Imgs_move/master/hackintosh/1417540636__screen_shot_2014-11-26_at_121710.png  https://raw.githubusercontent.com/Niresh12495/Imgs_move/master/hackintosh/1417540657__screen_shot_2014-11-26_at_121717.png  https://raw.githubusercontent.com/Niresh12495/Imgs_move/master/hackintosh/1417540676__screen_shot_2014-11-26_at_121727.png  https://raw.githubusercontent.com/Niresh12495/Imgs_move/master/hackintosh/1417540689__screen_shot_2014-11-26_at_121735.png  https://raw.githubusercontent.com/Niresh12495/Imgs_move/master/hackintosh/1417540698__screen_shot_2014-11-26_at_121744.png



Still, on the second booting I got kernel panic and had to use again boot flag PCIRootUID=1. Despite I was able to boot this time, I reached Yosemite desktop without mouse or keyboard.

Strangely, on the third booting, using boot flag PCIRootUID=0, I got everything working fine.

At last, Yosemite was booting normally from USB installation pen, but I was unable to boot it from the internal disk.


The Boot0: GPT problem

I kept getting this error over and over again if I tried to boot from the Yosemite internal disk,


boot0: GPT
boot0: test
boot0: test

boot0: GPT

boot0: test
boot0: test
boot0: error


As explained on "Tonymacx86 official boot0 Error", this is a very common error with an easy solution. Maybe in this guide, the solution is best explained for those who want to try.

After countless trials I reached to the following conclusions:


  • This is not an specific Mac OS X error; this is simply an error generated by the system where it can’t find a boot loader; can happen with OS X or with any other operating system;
  • In my case, I have the Chimera boot loader in place so, what could be wrong?
  • As OS X was installed with GUID partition scheme, there is an EFI FAT16 partition in the installation disk;
  • That partition should have a EFI folder with an .efi boot file inside;
  • As long as there is an EFI partition on the disk where the system is trying to boot from, it always look for the .efi file inside an EFI folder;
  • With Chimera boot loader there isn’t such a configuration in the EFI partition, because Chimera was made as a MBR boot loader only;
  • I could try to start fresh, formatting the OS X installation disk as MBR but, with my Gigabyte UEFI motherboard, OS X Yosemite refuses to install using a MBR formatting scheme;
  • With that said and proved, I would need an UEFI capable boot loader; Clover, of course, but as I reported before, I couldn’t even reach the OS X installer using USB Clover installation pen.

At this point I have an advantage, because I am able to boot from the installation pen.


Manual installation of Clover boot loader

Further solution I adopted was to try to install manually Clover EFI boot loader on the EFI partition of my installation Yosemite disk. I realized only later that I could have run Clover EFI bootloader APP to install the EFI files on the EFI partition so, unfortunately or perhaps not, I didn’t try that but ended learning a lot about Clover. However, I can upgrade Clover EFI bootloader installation later, simply running the Clover EFI bootloader APP.

First, I rushed to do a good cloning copy of my Yosemite installation disk using Clonezilla Live.

Second, I followed the guide [How to] Clover on EFI partition/Add to Bios in order to manually install clover on EFI partition. My motherboard UEFI, adds automatically an entry for the new boot loader when detected. So, I wouldn’t bother with the second part of this guide.

Next, a few manual configuration steps must be done to assure you wouldn’t get a kernel panic when booting,


1.   I created a folder named “10.10” in EFI/Clover/kexts (EFI/clover/kexts/10.10); note: other folders presented in kexts folder could be removed;


2.   I copied (not moved!) from /System/Lybrary/Extensions, in OS X Yosemite system disk, the following kexts,


i.   FakeSMC.kext

ii.  AppleACPIPlatform.kext

iii. AppleIntelCPUPowerManagement.kext

iv. AppleIntelCPUPowerManagementClient.kext


and dropped them in EFI/Clover/kexts/10.10 folder;

I got some help for this action from the Skyline OS X guide for Yosemite installation.


3.   I also read the "Tonymacx86 guide for Yosemite installation with Clover" from which I downloaded the config.plist file for ATI graphic boards; I renamed the config.plist in EFI/Clover to config.plist.old and copied the config.plist file, downloaded from Tonymacx86 guide, to the same location;


4.   As stated in Syline OS X guide for Clover configuration with Yosemite you must modify config.plist file adding the flag,




However, as stated in thread #2 of of "Tonymacx86 guide for Yosemite installation with Clover", this flag also can be added to config.plist using Clover Configurator;

Here is where you should include that argument.




















You can also include dart=0 flag in the same string as kext-dev-mode; I read somewhere that dart=0 is a workaround for disabling VT-d (CPU virtualization technology) in the BIOS or UEFI; since I had disabled it directly I didn’t need to use this flag;


5.   I followed the same Skyline OS X guide for Clover configuration to edit my config.plist file and add a few configuration Clover extras; I needed to do that since my system wouldn’t boot in the new EFI mode getting the kernel panic “Unable to find a driver for this Platform: ACPI ”… etc;

At this point, I have to remember I kept the alternative to boot from Unibeast USB installer pen, which has a MBR boot formatting; thanks to that extra booting alternative, I was able to boot again into OS X Yosemite and run the Clover Configurator software; here are the extra flags I added,


https://raw.githubusercontent.com/Niresh12495/Imgs_move/master/hackintosh/1417540707__screen_shot_2014-11-27_at_173807.png  https://raw.githubusercontent.com/Niresh12495/Imgs_move/master/hackintosh/1417540715__screen_shot_2014-11-27_at_173948.png  https://raw.githubusercontent.com/Niresh12495/Imgs_move/master/hackintosh/1417540722__screen_shot_2014-11-27_at_174312.png




6.   First step has precisely to do with boot issues;


7.   Second, on the graphics section of the Clover Configurator, I only applied Inject Intel and Inject ATI, since my motherboard has integrated Intel graphics card and I am using an AMD Radeon graphics card;


8.   Third, I applied a few Kernel Patches, to avoid some sort of kernel panic;


9.   I didn’t touch anything in the Rt Variables section or SMBIOS section.


Finally, I could boot OS X Yosemite without errors.


The /Extra folder dilemma

Chimera configuration with Unibeast puts a folder /Extra in OS X system root, which is absolutely necessary for this particular configuration; when changing to Clover I don't think this Extra folder have any use but, just in case, there is no need of deleting it or moving it to another place, specially because I kept the possibility of booting from Unibeast USB pen which has the Chimera boot loader; keeping Extra folder in its original place allows to boot from the USB pen and don't have any known implications when booting from Clover EFI partition.


Audio problems


HDMI AMD Radeon HD7770 enabling

  1. Just downloaded HDMI Audio from Tonymacx86; package located at http://patrovic.com/HDMIAudio-1.0.dmg;
  2. Mounted dmg image file and installed the kext HDMIAudio-1.0.dmg dragging the file to the window of Kext Utility (Kext Utility here);
  3. Restarted.

Note: this HDMI driver as its own kext (HDMIAudio.kext), located at /System/Library/Extensions but needs AppleHDA.kext to work properly.


Audio with Realtek ALC892 onboard Audio


Discussion - problems coming from Clover configuration


I patched AppleHDA.kext with Multibeast, which works nice with Chimera, but turns unstable when changing to Clover EFI booting configuration


As long as Audio was enabled with Multibeast and booting OS X from Chimera, the flag,









will enable Audio configured in patched kext AppleHDA.kext.


Although, it seems that when booting from Clover EFI partition, org.chameleon.Boot.plist Audio was sometimes enabled and other times disabled).


Problem was solved simply keeping Multibeast patched AppleHDA.kext and adding HDAEnabler1.kext in /System/Library/Extensions. Maybe it wasn't necessary, but I installed first this last kext using Kext Utility App, before restarting the machine.


For instance, in http://www.skylineosx.com/post-installation/Audio working as well.


Disabling or deleting Audio flag in org.chameleon.Boot.plist seems to be logical, but I didn't detect any problems keeping things as it was, even booting from Unibeast USB pen. So, I choose to keep everything that way, avoiding further messing ups with the system.



  1. Used Multibeast for Yosemite to patch AppleHDA.kext with Realtek ALC892 Audio
  2. Installed HDAEnabler1.kext (can be found here) copying the file to /System/Library/Extensions;
  3. Opened Kext Utility (found here) and dragged the file HDAEnabler1.kext over the APP window – this assures the kext file is installed correctly;
  4. Restarted.

Yosemite 10.10.01 update

After all this wasn’t a big issue, at least with the method I used.




As Clover bootloader is in the EFI partition, it would be better to backup that partition to an image, just in case. For this I used Clonezilla once again.

If the OS X update modifies that partition, preventing OS X Yosemite from booting, EFI partition could be restored from backup as it was.

Extra folder in OS X Yosemite root shouldn’t be touched, but it would be better to make also a copy of it, as well as of the contents of EFI partition. Don’t forget to enable Show Hidden Files using ShowHiddenFiles APPs (it can be downloaded at Gotoes.org), so you can copy the hidden folders and files. Of course, Extra folder is not necessary with Clover, but in my particular case, I still want to be able to boot from the Unibeast USB pen, because it’s always a possibility if something goes wrong with Clover.

Anyway Audio.

After Yosemite update, I found only the AppleHDA.kext was replaced with the original version. HDMIAudio.kext and HDAEnabler1.kext weren’t touched. Also, Clover EFI partition wasn’t affected, so I only had to restore Audio Realtek ALC892.

To be able to get a quick fix of AppleHDA.kext, I backed it up, before the OS X update. For this I used Kext Utility. Just dragged AppleHDA.kext (patched version) over Kext Utility. This produces a functional backed up copy of the kext. After OS X update application, you just need to delete AppleHDA original kext and rename the previous backup of the patched version again to AppleHDA.kext.


Caution preparation procedure

  1. Did a backup image of EFI partition using Clonezilla Live;
  2. Copied EFI partition contents and Extra folder contents to an external disk;
  3. Backed up AppleHDA.kext patched, using Kext Utility; left the backup in /System/Library/Extensions, but also copied it to an external disk (this backup is in the form of a folder named AppleHDA.kext.bak).

Update install and post-install procedure

  1. Proceeded with update Yosemite 10.10.01;
  2. Restarted and waited for installation completion; [No Kernel Panic!]
  3. Booted successfully into Yosemite with 10.10.01 update without ALC892 sound but with HDMI sound working (in my case, HDMI sound wouldn’t work only if proper kext isn’t installed, or if AppleHDA.kext isn’t present or not working);
  4. Deleted AppleHDA.kext in /System/Library/Extensions;
  5. Restored Audio patched file from AppleHDA.kext.bak, previously made and present in /System/Library/Extensions, renaming it back to AppleHDA.kext;
  6. Restarted.

Final note: I noticed that Yosemite 10.10.01 update added extended support for AMD Radeon and NVIDIA Geforce video cards. This can be verified looking for the new kexts installed in /System/Library/Extensions. However, I didn’t run the necessary tests to confirm if this support also adds HDMI sound output for these cards.

For those who want to adventure in hackintosh building my advice, for the moment, is to use the integrated graphic card on the motherboard or to get a Geforce or Quadro NVIDIA card, since NVIDIA launched a dedicated alternate driver for these cards on Yosemite 10.10. Look here.



  • First of all, thanks a lot to Tonymacx86 web site; without all the resources there, this project wouldn’t have been possible;
  • Thanks very much to all users who posted their experience in the useful forum of Tonymacx86; it was thinking about future adventurer users I decided to share my own experience;
  • Also many thanks to Mackbreaker.com, Skylineosx.com, HackintoshZone.com and all the people in insanelymac forums.


Other posts: you may also be interested in [GUIDE] Dual Boot Clover configuration - Yosemite & Windows 8.1 on two hard drives (Gigabyte GA-Z97M-DH3 & Intel i5 4690 3,5GHz)

Share this post

Link to post
Share on other sites


intel 4200M i5 hd 4600(haswell)

an instant reboot caused in both mavericks and yosemite ,but i managed to boot into mavericks using xpcm-free 

instead of that what i could  use in yosemite

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...