Jump to content
pablowerty100

[HOW] Install Yosemite 10.1.3 on AMD

Recommended Posts

Pre-Installation

 

 

Download:

UTorrent

Yosemite 10.10.1 HackintoshZone.com

Transmac (only if you want to make it in windows)

Restore DMG (If you are in mac)

WINDOWS:

 

MAC OS:

 

Installation

 

 

Reboot PC in BIOS and put disk in AHCI  ( search google for your motherboard)

Reboot and in my case is F8 to select boot device--- Select USB and instantly press 2 untill you see something

Then type this: /amd -v -x -f npci=0x2000 dart=0

Let it boot up  until you see a graphical enviorment, format disk and  install it.

If it gives to you Undefined Error:0 go to disk utility verify permisions and after repair

Open terminal and do this:

cp -f /Volumes/"Image Volume"/haswell /Volumes/"Mac OS"/System/Library/Kernels/kernel

rm -rf /Volumes/"Mac OS"/System/Library/Caches

Reboot

                  Post-Installation

 

 

Try to boot normaly and if you get stuck in PCI try npci=0x2000 , if you get black screen or white screen type -s and

make what is promted in screen and then: grafix backup all and then exit ... for my it reboots and then boot well

Configure your pc and if it stuck in creating account just wait 10minutes and power off...

After you finally boot into destock just live there settings the computer when it finnished

If you have no grub or boting windows use rescatux for reparing it....

 

Update to 10.1.3

Now you need to update from appstore to 10.1.3 let it install like a Mac OS normal

When it finish reboot on windows....

Download this archives:

Kernel: http://www.mediafire.com/download/lndn2jyvi8yqrq1/1010-kernel-REV-8N.zip

Kext: http://www.mediafire.com/download/46riv6nfspg6bgt/10102-UPD-Patch-pthread.kext.zip

Open TransMac go to tools settings read and write disk

Open OSX disk go to System/Library/Kernels and remplace with the old one

and them go to System/Library/Extensions remove pthread.kext and add the new one

Reboot to Mac osx with -f flag let it boot...

Repair permissions and rebuild cache with Kext Wizard it is inside the apps

Reboot and just you have it

300dvcz.jpg

 

If after reboot you have some graphics problems and NVDIA card

If it new up to series 700  nv_disable=1 and try if not GraphicsEnabler=No

If you got older one follow this: https://www.insanelymac.com/forum/topic/302979-how-i-got-my-gt-640-to-work/

Share this post


Link to post
Share on other sites

Hi!

I have install with your instruction but not working my Audio.

I have 78lmt-usb3 mainboard with chip via vt2021.

Do you help me?.

Thanks

Same than I use npci=0x3000 and it doesnt work  lock in google for ACL888 kext with voodoo for my works all 

Share this post


Link to post
Share on other sites

I solved.

I use last voodooHDA 2.8.6 and fully working.

Also i copy the kernel in S/L/K and boot my mac without usb with chimera bootloader.

Now is fully working good.

Thanks

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

 

thank you for the howto. My Problem is after putting kernel -v -x -f npci=0x2000 dart=0 in Clover Options Boot Args, my PC reboots after 5 seconds. I think clover dont starts with the kernel I copied in root of the USB Stick.

 

boot.jpg

 

Any idea?

 

Thank you

Share this post


Link to post
Share on other sites

Hi,

 

thank you for the howto. My Problem is after putting kernel -v -x -f npci=0x2000 dart=0 in Clover Options Boot Args, my PC reboots after 5 seconds. I think clover dont starts with the kernel I copied in root of the USB Stick.

 

boot.jpg

 

Any idea?

 

Thank you

You have to press 2 a lot of times just when you select usb boot device to boot in chamaleon

Share this post


Link to post
Share on other sites

I'm getting a bluetooth controller transport error.

I have an Nvidia GTX 500 series gfx card and an APU (same architecture as fx so usually runs same kernels).

Share this post


Link to post
Share on other sites

Hi,

 

I have a graphic problem with my Asus GTX660 Ti. It´s strange because the card should have native support.

 

graphic.PNG

 

graphic2.PNG

Share this post


Link to post
Share on other sites

I'm getting a bluetooth controller transport error.

I have an Nvidia GTX 500 series gfx card and an APU (same architecture as fx so usually runs same kernels).

Also I but it boots be carefull use the kernel in the link yesterday trinying a new installation with an other kernel gets my stuck just from the start up

Share this post


Link to post
Share on other sites

Hi,

 

I have a graphic problem with my Asus GTX660 Ti. It´s strange because the card should have native support.

 

graphic.PNG

 

graphic2.PNG

Problem comes with Resolution?¿ If you are under Vanilla try this app maybe it helps becouse it is well recognised the graphic card:

http://www.macupdate.com/app/mac/8355/switchresx

 

If it is niresh for my it doesnt work ever the graphic card but sound yes and in vanilla well  one time i go it but now that i make a new install i dont find good config for ALC 888 integrated and Audio jack

Share this post


Link to post
Share on other sites

Its not a resolution Problem. Seems like a problem with 10.10.0. In other boards they have the same problem. Does this kernel work with 10.10.1?

Share this post


Link to post
Share on other sites

konsole.PNG

I get this lock.

Boot with nv_disable=1 and say what happen i havent this error at all with Graphic Card with me it works or just it dont work at all 

Share this post


Link to post
Share on other sites

I am going to test Niresh yosemite  i will post here my configs when i succefully install it

Puff niresh is a disaster things are corrupted i will post later  guide for my not working graphics but boot loader  working perfectly

Share this post


Link to post
Share on other sites

Ohhh same Problem, with nvidia and osx drivers. Here my cfgs:

 

Asus m5a99x evo

Amd phenom ii x6 1100t

Asus Geforce GTX 660 TI

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>EthernetBuiltIn</key>
    <string>Yes</string>
    <key>Graphics Mode</key>
    <string>1024x768x32</string>
    <key>Kernel Flags</key>
    <string>kext-dev-mode=1 npci=0x3000 dart=0 nvda_drv=1 debug=8 ahcidisk=1</string>
</dict>
</plist>
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>SMbiosdate</key>
    <string>10/07/10</string>
    <key>SMbiosvendor</key>
    <string>Apple Inc.</string>
    <key>SMbiosversion</key>
    <string>MP51.88Z.007F.B03.1010071432</string>
    <key>SMboardproduct</key>
    <string>Mac-F221BEC8</string>
    <key>SMfamily</key>
    <string>Mac Pro</string>
    <key>SMmanufacturer</key>
    <string>Apple Inc.</string>
    <key>SMproductname</key>
    <string>MacPro5,1</string>
    <key>SMserial</key>
    <string>CK308504EUH</string>
    <key>SMsystemversion</key>
    <string>1.0</string>
</dict>
</plist

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Turn Off ADBlock Extension If you have.
  • Donation Goals

    Hosting 2019

    This FREE website is made possible by your contribution to the community.



    $8.78 of $2,500.00 goal reached.
    Donate Now
  • Forum Statistics

    • Total Topics
      9,651
    • Total Posts
      29,733
  • Donation Goals

    Hosting 2019

    This FREE website is made possible by your contribution to the community.



    $8.78 of $2,500.00 goal reached.
    Donate Now
  • Topics

×
×
  • Create New...