Jump to content

Recommended Posts

Life is complicated.

I want to install OS X (>=10.8.5) on Dell PowerEdge 1950. This is  a nice machine with PERC 5i SAS controller and it was running 1.x.x. bios with 5.1.4 raid firmware. The controller is not recognized by the standard OS X distributions but there is one nice guy (http://www.insanelymac.com/forum/topic/285197-driver-for-lsi-megaraid-sas-family/) who wrote a driver for it. The dell booted very well right to the installation setup screen with 10.9 (AMD) and 10.10 Niresh usb distributions and I managed to inject the SAS kext. Unfortunatelly it could not initiate the controler and ended with the FW error so the obvious move was to upgrade the RAID FW to the latest version. I did it and dit it also for the bios as this is what was recommended by Dell. After this nothing was the same. The booting ends up for both .9 and .10 with the same k. panic: "can't perform kext scan" but here goes some observations:

- it is not instant, it clearly reads the /System/Library/Extension (at least for .10) so it looks like after a kext gets injected something gets *beep*

- .9 boots well to the installation screen if:

    i) it boots from optical usb drive

    ii) it boots from a thumbdrive but an optical drive with .9 is present (in this case the OD blinks 2 times only during the whole installation process)

I have to say, I am pretty OS X illiterate but it seems to me something interferes with the USB drive during the boot time. Now, I can live with 10.9 but I don't know how to inject the SAS kext. Take a note that this is not (u)efi system. For the 10.10 I intuitively placed the kext into the /System/Library/Extension and it was read. 10.9 has it as mkext and before I spend next few hours trying to put the SAS kext to this mkext I would like to ask you about your opinion on what's actually is going on after the bios/fw was upgraded, whether something can be done to overcome this usb "can't perform kext scan" problem and what is generally the best way to inject this SAS kext for non efi system if this had to be 10.9.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.30 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • I don't think the ten series work yet on Mojave, I have a Ryzen with a GTX 1050 and I'm staying in High Sierra for now.
    • Hardware Information CPU Intel Core i7 6800K @ 3.40GHz Broadwell-E/EP 14nm Technology RAM 32.0GB G.Skill Trident Z @ 1599MHz (15-15-15-35) Motherboard Gigabyte Technology Co. Ltd. X99-Ultra Gaming-CF (SOCKET 0) Graphics 2047MB NVIDIA GeForce GTX 1060 6GB (MSI)
      I have tried High Sierra and Sierra with no good luck. I had it installed once before but the issue was I couldn't boot into it, of course, lol.   Now I can't seem to get the installer to boot, but can get to the bootloader to enter flags. I've tried npci=0x2000  nv_disable=1 -v -f -x which ends up just crashing the thing and it says it's exiting.    I'm really trying to get this to work, I'm sick of Windows always having updates and dumb issues. My timezone won't even work right lol What?    Please let me know what other info you need so I can get this loaded!   PS: Tonymac banned me for discussing "illegal distributions" or using one or some crap like that... was a member for like 5 years. Really crappy of them. Not sure what they're even talking about. No warnings or anything. I think because I mentioned another site they got pissed lol    
    • I now see that my wifi adapter doesn't work as it's Intel.  I purchased USB-AC53 Nano which works, but handoff, even with functioning Bluetooth and wifi doesn't work.  Suggestions?  
    • @Niresh is there any work around for graphics for the gt1030 on dell optiplex 760?
    • @Niresh - my apologies for the delay.  I didn't see this until now.  I've made quite a bit of headway and am up and running except for my wifi from what I can tell.  Is this something you can help with?  As to the specs:   https://www.dell.com/support/home/us/en/04/product-support/servicetag/6bx4y52/configuration   Thanks so much!
  • Download Statistics

    • Files
      855
    • Comments
      2,148
    • Reviews
      2,613

    Latest File
    By Niresh

    193    2

×