Jump to content
Bryan Morfe De Leon

[SOLVED]Fix the cpus=1 Intel core i3 350M Niresh 10.9 -> 10.9.5

Recommended Posts

Hello, hackintoshers. It was just a day ago that I got my hackintosh up and running almost 100% perfect. The only three things missing (that I am aware of) is that I can't change my brightness (I will fix that later), I can't use HDMI (Totally fine with that) and, what made me write this post, I am only able to boot my system using 1 core of my Dual-Core processor, aka; cpus=1...

 

The reason that I installed this hackintosh is to program in Xcode and that, and use some other apps that demand CPU power, which I cannot achieve with only 1 core...

 

My details are;

HP Pavilion DV7 4077cl (Once I fix this I will post a full guide on how I reached 10.9.5 with niresh and make it work almost to perfection, and will give credit to everyone that helped me achieve it)

8gb of Ram perfectly working

Integrated Intel HD Graphics (100% Working thanks to a guide I saw...)

 

Intel Core i3 350M 2.26Ghz... -> Arrandale in early 2010.

Dual-Core with multithread (2 Physical cores and 2 Virtual ones)

 

So, is the anything I could do to fix this? (I posted a picture of the kernel panic I get in verbose if I don't use cpus=1)

If you need extra information let me know.

 

Thanks, all of you. 

 

Pic:

https://www.dropbox.com/s/lxoat99oxua77yb/IMG_7617.JPG?dl=0

IMG_7617.JPG?dl=0

 

EDIT:

 

I tried disabling the Intel Virtualization Technology and boot with dart=0... I also tried the Voodo kext for 4 cores but mine has two, so I guess that's why it didn't work.

 

SOLUTION: 

 

Apply Lapic Kernel Patch.

Share this post


Link to post
Share on other sites

I just installed OS X Yosemite on my old DELL laptop (inspiron N4010) 2010 version. The system works fine on the laptop, but I couldn't figure out the Video card drive part.  This laptop has same cpu that you have Intel core i3 350M, which has GPU Intel in it. Could you share how did you installed the driver for video and make it work? It will be a huge help for me. 

Share this post


Link to post
Share on other sites

@Akbar Muhtar 

I understand. When I first upgraded to 10.9.5, I had to install the kext for the 10.9 and after that the kext for 10.9.5. Maybe you should try using the kext for 10.9 and after that for 10.10, because the frame kexts do not get replaced. Give that a try and let me know how it goes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Turn Off ADBlock Extension If you have.
  • Donation Goals

    Hosting 2019

    This FREE website is made possible by your contribution to the community.



    $8.78 of $2,500.00 goal reached.
    Donate Now
  • Forum Statistics

    • Total Topics
      9,651
    • Total Posts
      29,731
  • Donation Goals

    Hosting 2019

    This FREE website is made possible by your contribution to the community.



    $8.78 of $2,500.00 goal reached.
    Donate Now
  • Topics

×
×
  • Create New...