Jump to content
Sign in to follow this  

Unable to Load Niresh in Virtual Machine

Recommended Posts

I am trying to get Niresh to work in Virtual Box and naturally nothing works for me when all the guides online have no issues setting it up...


I was able to install it, but as soon as it boots after the install it just hangs at the apple logo and spins forever. I am unable to really read the problem in the-v diagnostics:



My Specs are i7-4770k 3.5ghz quad

Nvidia GTX 760

16GB Ram

Solid State Hardrive 200GB at 500 mb/s write speed

Windows 8.1



I tried installing niresh on a dedicated partition and it also got passed the install but once it boots, it just goes to a black screen and my monitor flashes like its in sleep mode.


Share this post

Link to post
Share on other sites

had the same problem:


this fixed it:


NOTE 2: Virtualbox may have problems booting Mac OS X if your computer uses an Intel Haswell processor (i.e. if your computer was built/bought in 2013 or later). If this is this case, you will have to trick Virtualbox into thinking that your processor is actually an older model. To do this, open the Command Prompt in Windows (make sure you are logged into an Administrator account on Windows). You can do this by opening the Start Menu, and typing "command prompt" into the Start Menu search bar. Then, type the following command into the Command Prompt.


cd "C:Program FilesOracleVirtualbox"

This command will change the focus of the Command Prompt to the program folder for Virtualbox (if you installed Virtualbox somewhere different, then change the command to wherever you installed it). Next, type in this command:

VBoxManage modifyvm <Name of virtual machine> --cpuidset 00000001 000306a9 00020800 80000201 178bfbff

This command activates "vboxmanage", a command-line program included with Virtualbox that allows you to edit the properties of your virtual machine, including its built-in resolutions. Replace "Name of virtual machine" with the name of your virtual machine (no quotation marks)-- you can find the name of your virtual machine in the left pane of the Virtualbox main window. This command should do the trick.


source: http://www.macbreaker.com/2014/05/os-x-mavericks-in-virtualbox-with-niresh.html



Share this post

Link to post
Share on other sites

Thanks, that fixed the issue. But after 20 minutes of use the mouse is now stuck on the upper left corner the keyboard also does not work, how would I fix this?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...