Jump to content
maxcarnage

Internal WiFi and Trackpad not working - Lenovo x220

Recommended Posts

Specs

 

Processor:         Intel® Core i7-2620M CPU @2.70GHz

RAM:                 4GB

Graphic Card:   Intel® HD Graphics 3000

Motherboard:    Motherboard Intel i5 04W3290

Wlan:                Intel Centrino Wireless-N 1000

Ethernet:          Intel 82579LM

Audio Card:     Conexant 20672 SmartAudio HD (or Intel® Display Audio)

 

I am able to load Niresh Maverick using the bootable DVD (burned from the ISO)

I have a few issues that I am having a hard time figuring out.

 

  1. It seems that I still need to have the DVD in the drive in order to boot into the hard drive. so the first question is, did I miss a step to where I was supposed to boot to the Niresh screen? I followed the instructions located here twice.
     
  2. whether I start up normally or with the -v or -x option, i still can not detect the internal wifi card.
     
  3. I cant seem to hear any Audio ktext
     
  4. The trackpad on the Lenovo gets detected by the OS and I can move the mouse but the tap to click doesnt work. I checked the system preferences and played around with the mouse settings but nothing works.

Would anyone be able to assist me?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.30 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • @riddlemeright You have not posted any pictures regarding ACPI Error, without pictures I can not debug Also you need to post your full hardware specs
    • @Douglas Dreer use ATH9KFixup.kext with Lilu.kext also you need to add -ath9485 as boot-flag in clover config
    • @tdtech959 Without any pictures of kernel panic it is really hard to debug, but anyhow have you installed whatevergreen.kext with lilu.kext   i had a weird kernel panic when my onboard graphics was turned on, I was able to select external graphics card via BIOS settings as default. are you sure if the USB is the actual problem.
    • Has anyone managed to run the atheros 9485 run on Mojave? I even managed to make it recognize, but it can not find any network.
    • Hello everyone  I have installed High Sierra and updated to 10.13.6 before installing nVidea web drivers. After everything was installed (Kexts and the driver) everything booted fine. Graphics worked perfectly. My onboard USB did not work but I have some generic NEC USB 2.0 card that works fine. After a reboot later in the day, I had a weird kernel panic. It spit out strings no longer than 30 charters and then proceeded to reboot. I have not seen this type of panic . This happened when using the onboard USB 3.0 controller but was fixed by removing the device. But now I'm not sure what caused this. I have reinstalled about 15 times already. Here are my specs: ASUS B150 Plus D3 Intel Pentium G4400 ZOTAC GeForce GTX 1050 2GB WD Blue 500GB HDD 8GB Ram Some generic wireless card (That works) Thanks -T
  • Download Statistics

    • Files
      855
    • Comments
      2,148
    • Reviews
      2,611

    Latest File
    By Niresh

    166    2

×