Jump to content
Sign in to follow this  
justinnickovtime

Internal Display Not Working

Recommended Posts

Hello,

 

I've managed to successfully install Niresh 10.9.0 on my Sony VAIO VPC-CW29FX laptop, but right after the Apple logo (after loading the Nvidia kexts), my internal screen shuts off, and the graphics drivers switch the display output to the HDMI port. When I go into System PreferencesDisplays and click Detect, it doesn't detect the internal screen. 

 

I've done numerous things to get it to work. I've tried the usual boot switches (GraphicsEnabler=off/on, PCIRootUID=1, etc.), but to no avail. One thing I did try and had moderate success at was the guide Niresh posted specifically for this issue. After backing up the kext files, I was able to boot with the internal display working correctly. The only problem is that qe/ci was disabled. I tried reinstalling the defaul kexts, but as soon as I rebooted, my internal display stopped working again. 

 

My System Specs - 

 

CPU - Intel Core i3 350M

GPU - Nvidia Geforce 310M 256MB

Mobo Chipset - Intel HM 55 Chipset

RAM - 6GB DDR3 PC3-10600

WLAN - Atheros AR9285

Ethernet - Marvell Yukon 88E8057
Audio - Realtek something (not sure right now, at work, but I can look it up later if needed)
 
Is it possible to modify the kext, so it's forced to display out via the internal monitor? If not, is there another way to make it work?

Share this post


Link to post
Share on other sites

 

@justinnickovtime

Boot with nv_disable=1 & GraphicsEnabler=Yes or No

Example with verbosemode

nv_disable=1 GraphicsEnabler=Yes -v

Okay, that seems to have done the same thing as backing up the kexts files. I can boot into Mavericks with the internal display, but qe/ci performance is excruciatingly slow. With the Nvidia kexts ENabled, qe/ci performance is fast, but it only displays out through the hdmi port, i.e. no internal display.

 

Edit: This may be a dumb thought, as I'm limited in my OS X knowledge (I've been working on it for a whole 3 days now), but do the kext files require an edid in the dsdt? If so, I think I found my problem. Every method of edid extraction I've tried so far has failed. So it's very possible that OS X is unable to detect my edid as well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...