Jump to content
  • 0
TheNikOne

Public Beta - SATA Controller kext

Question

Hello everybody,

 

I keep getting a "still waiting for root device" error related to "waiting on <dic>ID="0".

George Elliott Morris had the same problem here: 

 

Mark helped him out:

He said: "Then try to find the SATA controller kext from your current install, and then install it to /S/L/E (/System/Library/Extensions). If you can't find it, then try asking on Niresh's forums." to him.

 

Then George could boot with the flags "( ahcidisk=1 debug=8 USBBusFix=Yes)"

 

My only problem is that I just don't know where to find this SATA controller kext from my current install.

 

Maybe you think it's silly, but I'm working on this since weeks.

 

Mavericks works for me without any problems.

 

My specs are:

 

- CPU Intel Core i5 4670 @ 3.40 Ghz

-  nVidia GeForce GTX 770 OC (Gigabyte)

- Z97M-D3H (Gigabyte) - George has a Z87, so I think there shouldn't be a different way to the solution, when I've exact the same problem. / ?

 

I used MacPwn-Developer-Preview-Yosemite-1.4

I use the public beta that you can download without a developer account from Apple's official website.

 

 

Sorry if there are any mistakes, I'm German.

 

Maybe it's to obvious for you, but I just don't get it..

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

>> He said: "Then try to find the SATA controller kext from your current install, and then install it to /S/L/E (/System/Library/Extensions). If you can't find it, then try asking on Niresh's forums." to him.

>> Then George could boot with the flags "( ahcidisk=1 debug=8 USBBusFix=Yes)"

 

Try to check BIOS options where you can change IDE or AHCISATA variant. The flag ahcidisk is a flag for drivecontroller kext and your machine problem may be solved by advanced jMicron drivers + serial ata controller kext(not critical; if you have working jMicron kext it not needed and ahci disk option does not any changes -- only different readwrite speed). Partitioning scheme is a two posible problem; check the way MBRPBR or GUID. Last works better ...

 

-----------------------

update

-----------------------

 

You machine may have a problems with arch flag. If hackintosh runs in 64bit mode the drivers(every kext contains multiple arch's support but you need one of) compiled with only x86(32bit) architecture may have a problems and work speed issues.

 

Primer: arch=x86_64 runs hackintosh in 64bit mode but a driver have only 32 bit support -- a drivers may be not load at a time to use hardware.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.30 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • Has anyone managed to run the atheros 9485 run on Mojave? I even managed to make him recognize, but he can not find any network.
    • Hello everyone  I have installed High Sierra and updated to 10.13.6 before installing nVidea web drivers. After everything was installed (Kexts and the driver) everything booted fine. Graphics worked perfectly. My onboard USB did not work but I have some generic NEC USB 2.0 card that works fine. After a reboot later in the day, I had a weird kernel panic. It spit out strings no longer than 30 charters and then proceeded to reboot. I have not seen this type of panic . This happened when using the onboard USB 3.0 controller but was fixed by removing the device. But now I'm not sure what caused this. I have reinstalled about 15 times already. Here are my specs: ASUS B150 Plus D3 Intel Pentium G4400 ZOTAC GeForce GTX 1050 2GB WD Blue 500GB HDD 8GB Ram Some generic wireless card (That works) Thanks -T
    • did you know the RX580 sapphire works out of the box to get it to work just let the pc go to sleep and thin wake it up make sure all monitors are hooked  up before you boot up the system. let me know how it works for you. here is the specs of my machine    HP Z800 2 x 3.07 GHz 6-Core Intel Xeon 16 GB 1333 MHz DDR3 Radeon RX 580 8192 MB 2 monitors and a 60 inch samsung uhd tv   thank you all for reading my post I have ben working in apple products for years and hackintosh from the beginning .
    • (MAC & PC) macOS Multi Boot USB Project [KEAL-kealOS’es] – Kemal ALKIN – RAW Image   Support – Apple Macintosh | PC (CLOVER Bootloader/Önyükleyicisi UEFI & Legacy BIOS) – Destekler. SSD NVME & SSD TRIM Desteği / Support : CLOVER | Apple Macintosh (SSD Trim Terminal.app Command: “sudo trimforce enable“) (Kernel & Prelinkedkernel) AMD / Ryzen CPU (İşlemci) | Intel CPU (İşlemci) Native/Doğal Destekler – Support macOS versions/sürümleri: (MBR: Master Boot Record – GPT: Guid Partition Table) Mavericks 10.9.5 – MBR & GPT (AMD/Ryzen + Intel Native) Yosemite 10.10.5 – MBR & GPT (AMD/Ryzen + Intel Native) EL Capitan 10.11.6 – MBR & GPT (AMD/Ryzen + Intel Native) Sierra 10.12.6 – MBR & GPT (AMD/Ryzen + Intel Native) High Sierra 10.3.3 – GPT (Stable AMD/Ryzen + Intel Native) High Sierra 10.13.6 – GPT (AMD/Ryzen Test + Intel Native) Mojave 10.14.1 – GPT (Intel Native)   Needs/Gerekenler: 64GB/64GB+ USB | 7-Zip/WinRAR | Win32DiskImager/Transmac   Download / İndir : GoogleDrive  
    • @Niresh - any chance you can help?
  • Download Statistics

    • Files
      855
    • Comments
      2,148
    • Reviews
      2,610

    Latest File
    By Niresh

    166    2

×