Jump to content
hoangthi

High Sierra wrong Scale boot menu, and wrong resolution 1024x768

Recommended Posts

hoangthi

Hello, 

I am totally a newbie to this. I just installed Hackintosh following the tutorial here (used Windows to burn the installer): https://www.hackintosh.computer/1428/hackintosh-high-sierra-zone-aka-niresh-high-sierra-guide/

After finishing setup, PC started booting on SSD, but the boot screen's scale was wrong. 
spacer.png

After that, Although I could select the menu: BOOT FROM SSD, but then, it is stuck here, I tried to use another config file, even tried reinstalling the OS with intel drivers on customization menu, but nothing different:

spacer.png

The only way for me to boot to MACOS is to use the USB stick and select Boot to SSD from there.

spacer.png

The MacOs actually works this way, mouse works, keyboard works, the speaker works, Ethernet works (not Wifi, that's ok). The problem is, Intel Graphics seemed not working, I can't change the screen resolution, only 1024x768 supported.

I tried to inject HD graphics driver but no luck.

spacer.png spacer.png

My Laptop is: HP probook 650 g1 

Core i7-4610M

Memory: 16GB 1600 Mhz

SSD Samsung Evo 860 128GB

Display: 1920x1080

Newest BIOS: 01.49 SEP-2019 (disabled USB 3.0, wake on lan, wake on USB, no VT-d, no Secure Boot Mode, no Fastboot, disabled SerialPort, couldn't find other options)

Please tell me some possible solutions to handle this, I have spent three days on this but still got stuck

Share this post


Link to post
Share on other sites
hoangthi

UPDATE:
It was not actually stuck when I booted from SSD. I waited a little bit more and it loaded the OS. But the screen was totally torn, like this:

spacer.png

Share this post


Link to post
Share on other sites
hoangthi

Update: I fixed the screen problem by this (found on the internet), first mount the EFI, then edit config file by clover configurator:

Quote

HD4600 does not require FakeID.
0xa260006 is for laptops. Desktops use 0x0d220003.
No need for patched AppleGraphicsControl.kext.
Nvidia + Intel graphics: Intel must be primary
-ncpi does nothing and you don't need ncpi either.

Desktop HD4600 requirements:
- config.plist/Graphics/Inject/Intel=true
- config.plist/Graphics/ig-platform-id=0x0d220003
- config.plist/Devices/FakeID/IntelGFX=0
- BIOS DVMT-prealloc 64mb
- digital connection to your monitor (VGA not supported)
- VT-d disabled or use dart=0


The OS works, but the boot menu display still tears.

Plus, the USB mouse and keyboard stopped working :( 

spacer.png

spacer.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...