Jump to content
Sign in to follow this  
Guest Qwertyness

Need help with kernel panics - Asus infinite boot loop

Recommended Posts

Guest Qwertyness

I have been trying to install Niresh Mavericks 10.9 on an Asus VevoBook.  I have been able to successfully create the boot USB drive and boot to it.  The problem arises when I enter the boot flags and press enter. After a few seconds, the OS will crash and the BIOS will reboot back to the screen to enter the boot flags since I have the USB as boot option 1. I can't really provide much in terms of error reports because the reboot occurs so fast.


Here is some info about the computer:

Brand: Asus


Processor: Intel Core i7 Quad core 4500 CPU at 1.8GHz without TurboBoost

Graphics: Intel 4000 HD integrated

BIOS: Version 207 by American Megatrends


Some of the relevant BIOS settings:

Advanced Tab -


DVMT Pre-Allocated: 64MB

Legacy USB Support: Enabled

XHCI Pre-Boot Mode: Smart Auto


Boot Tab -

Launch CSM: Enabled

Launch PXE OpROM policy: Disabled

Boot Option 1: Sandisk USB (Containing Niresh Mavericks)

Boot Option 2: Windows Boot Manager


Security Tab -

Secure Boot Control: Disabled


I have read some info about the OS X BIOS requirements and have seen things saying that you need S3 sleep mode on and HPET set to 64 bit, but have not seen these options in the BIOS the computer has.


It's also worth mentioning that depending on the combination of boot flags, the computer does/does not show the Apple logo screen for a split second before shutting down and rebooting.


If you need any more information, please ask.


Thanks for any help I get! I very much want to be able to dual boot this laptop!

Share this post

Link to post
Share on other sites
Guest Qwertyness

Still crashes back to boot screen. I also tried using these boot tags together: -v xpcm-free ForceHPET=Yes -f

This allowed it to boot once where it displayed a notification about connecting a Bluetooth keyboard.  I had to force reboot to get rid of it, and that combination of tags didn't work again.


EDIT: Just tried it with the xpcm-free tag again and was able to reproduce the Bluetooth keyboard thing. Unsure what to do now though :P


EDIT AGAIN: Was able to get past the keyboard prompt and am now in setup!  Thanks!

Share this post

Link to post
Share on other sites
Guest Qwertyness

I've got another problem now.  I am trying to install the operating system on a partition on the same disk as my Windows install.  In windows I created a 200GB partition formatted with NTFS.  When I booted with Niresh and tried to erase the partition to format with the Mac journaled file system, I was greeted with this error: "MediaKit reports not enough space on device for requested operation."


Since the partition erase didn't work, I also tried to boot Niresh with some unallocated space on the drive and create the partition in OS X.  Disk Utility got stuck on the preparing to create partition bar.


Is there any other way I could successfully install OS X onto a partition on my Windows disk?


Share this post

Link to post
Share on other sites

You need to erase all partitions for this and make new with GUID Partition Table.

For Dual booting , make new partitions from Mac installer .First for Mac in MAC OS Journaled format(HFS+) and second in MS-DOS for windows(BIOS Settings: SATA configuration AHCI)

Now install  niresh on first Mac HDD (Customize: Check AHCI3rdPartyATA and NullPowerManagement ,IGPEnabler=Yes,Still Working FIx) and it will boot (use -x -v bootflags for any error check).

After booting restart and boot the usb for Win 7 and install it on 2nd Partition (64-bit only).Restart with CLOVER bootloader installed on usb with BootDiskUtility.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...