Jump to content
Sign in to follow this  

Help Dell N5010

Recommended Posts

Hi looking for some help with this Dell N5010.  I've tried different ways, but it would be nice to get help from pros.  I still can't get this laptop going.

Specs: Model Inspiron 15 Intel N5010

CPU: Intel i3-350M @ 2.26ghz

Ram: 4GB 1333mhz

HDD: 500gb ST9500325AS ATA Drive

Video: Intel HD 3000 + Nvida GT520mx

Sound Card: Realtek HD

Network: Realtek RTK8102E/ RTL8103e  Family PCI -E Rast Ethernet NIC

Broadcom DW1501 CNB Card half Mini-card


What would be the best to put on this laptop.  I've been able to get a GX520 Dell running Snow leopard no problem.

Share this post

Link to post
Share on other sites

I used to have the same notebook, I hate to break it to you but it's a waste of time. I tried several hackintosh distros (including Niresh) as well as retail installs. I think it has something to do with the BIOS settings, when I tried researching a lot of other people issues with this notebook. If you just don't want windows, linux works great on it, I ran Ubuntu 12.04 on mine. With that being said good luck maybe you'll find something I didn't try. :)

Share this post

Link to post
Share on other sites

Thanks for your info.  I saw most people had it running and there was a tutorial to do it.  But it never worked for me.  Hoping someone out there that has done it would be neat to run it on this laptop.

Share this post

Link to post
Share on other sites

I hope you're still looking at this or are able to see it. And I must apologise for my bad installation guide I am about to give you. I can confirm it does work on this laptop. I installed using Niresh's 10.8.5 ISO. During installation you should deselect AppleIntel powermanagement (It's actually called something else but similar.) Then go ahead an install. When it's done, in theory, it should boot up. If it doesn't, not to worry. You should boot -v -x from here. You should be expecting this line for boot to get stuck on.


-ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPower Management) timed out


In this case, boot up the Niresh installation again. This time you want to click utilities>terminal and type this:


-rm -R /Volumes/Osx/System/Library/Extentions (I think you need a capital letter for each word, maybe OSX has to be all capitals? Try everything if you get a error response)


From here, just hit tab, and keep hitting it slowly and delete any lines with the word "IntelHD" in it. I don't think you need to delete the full line and just the bit with IntelHD, but if it still doesnt boot try both. Boot normally and see if it works. From here it worked for me. Post replys and I'll try get back to you ASAP. The Keyboard and touchpad do not work during first setup, you will need a USB keyboard and mouse (Not bluetooth either, this didn't work for me till after I had got to the desktop) I am still working on the WIFI/Graphics drivers. I haven't found any that work. So you will be stuck with very, very basic programs and capabilities. Sound won't work, but the ones on the Niresh CD, one of the last few drivers allowed sound, but I have no control over how loud output is.


Specs: Model Inspiron 15 Intel N5010

CPU: Intel i5 M480 @ 2.67ghz Ram: 4GB 1333mhz

HDD: 700gb SATA - Using a 320GB for the Hackintosh

Video: Intel HD (I think HD1000. I'm unsure but I think it's that.)

Sound Card: IDT High Definition Audio

Network: Atheros AR9285 (Replaced an Intel Centrino n1000 as it is not supported for Hackintoshing)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.

    $22.66 of $100.00 goal reached.
    Donate Now