Jump to content

Problems with initial install of Maverick

Recommended Posts

This is my first post on this forum so I hope I am doing this right. I want to dual boot windows 8 and Maverick on my laptop (Toshiba Satellite U945) and I've been doing lots of research and I am pretty sure that my laptop is capable of running Mac OSX. I had lots of problems trying to set it up the normal way (mainly not having access to a Mac) and was delighted when I saw Nireshes Maverick distro. Firstly I made the USB as instructed (my laptop doesn't have a DVD drive). That went fine and to make sure I made a second USB just to make sure that the problem wasn't the stick itself. My BIOS is pretty crap and it didn't have an option to change the SATA config, this freaked me out a bit but with a bit of research I am 90% sure that it is AHCI by default due to the SSD/HDD hybrid and the option isnt there because they don't recommend you change it. The next problem was I couldnt boot from USB but I fixed this by changing it to csm or something in BIOS. Now I am on the black screen with Niresh-Mavericks and boot options and I have been trying to get this to work for hours. I will be really disappointed if I cant get it to work as I've spent days trying to set up my Hackintosh. Ive tried all of the options -v etc and still no luck. Most of the time it stays on the screen with the logo and the loading sign then reboots after a while. Occasionally it comes up with the language selection but then it lags loads, freezes and reboots. When I run it with -v, the final line says: WARNING: IOPlatformPluginUtil : getCPUIDInfo : this is an unknown CPU model 0x3a -- power management may be incomplete or unsupported and just above that it says Missing Bluetooth Contoroller Transport!. Any help would be greatly appreciated as I am out of ideas :c Thanks in advance :D


CPU: Intel Core i5-3317U 1.70GHz

Graphics Card: Intel HD Graphics 4000

Motherboard Chipset: Intel HM77 Express

WLan: Intel IEEE 802.11b/g/n


Thanks :D Rob

Share this post

Link to post
Share on other sites

I went through the entire process and still no difference :c I kept on looking for answers and found this :


 Boot with -s. When you see the prompt "root:":

Type: mount -uw /
Type: cd /System/Library/Extensions
Type: mkdir intel_back
Type: mv AppleIntelHD* AppleIntelF* intel_back/
Type: touch ../Extensions

Reboot and use -v flag.


It seems to work for most people with the Bluetooth Controller problem, but this is for people who already have it installed and are then getting problems, I cant use it because I cant even install. Just thought Id post it encase it helps someone to help me :D Thanks again, Rob

Share this post

Link to post
Share on other sites

So after a few hours of trial and error I was able to run the installer using cpus=1 -f -v  as my boot flags. The installer ran successfully and I was able to format my HDD and run the installer fully. When it was installed it restarted my pc and now I am at this screen: 24b42ev.jpg (Erebor is the name of my HDD). After this the apple logo comes up and it loads for several minutes until it reboots again and the process starts over. :c Any help would be greatly appreciated :D Also I've tried using flags and still no success :c

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community.

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.

    $22.66 of $100.00 goal reached.
    Donate Now