Jump to content
dchris

Niresh update to 10.9.4

Recommended Posts

-

Share this post


Link to post
Share on other sites

i did all the steps , even repair permissions also , then when i tried to boot with -v -x -f , after some time automatic restart , tried 15-20times , please help me.
  help me as soon as possible

 

1st i backup all the kexts and kernel via osx86,
then i update with this http://support.apple.com/kb/DL1755

then i restarted use -v -x -f , its took auto restart
then i replaced kext via windows, then did repair permission. and restart , and tried with boot -x -f -v , again same black screen and restart

plz help me :'( :unsure:


processor = amd8350.

gpu = AMD Radeon HD 7700

ram=12Gb

Share this post


Link to post
Share on other sites

Hi,

 

Anybody have the full path to where these ktexts are that I need to back up?

 

As this is a AMD system. This is needed to get back to were the system works again. You knew that, right!

 

As you can tell from my question and statement, I'm a newbi...

 

Motherboard = MSI 785GT-E63

AMD Phenomâ„¢ II X6 Processor CPU.

Graphics Card - N550GTX-Ti-M2D1GD5OC

 

 

Thanks Guys,

 

Share this post


Link to post
Share on other sites

hi i am from Venezuela sorry if the translation is not good but I'll try to tell my problem: install mac 10.9 on my pc but I have problem, after it finishes installing, when in the screen that asks you to select the country the system hangs. 

(if anyone has any configuration to install 10.9 on the PC MAC) 
my pc: 
* Motherboard: M5A97 R2.0 
* Processor: AMD FX 8320 
* Video Card: Nvidia 760 SOTAC 
* G.Skill DDR3 Memorio: 8GB 1886Mhz x2 
* Hard Drive: 320GB seagate 
* Wireless Keyboard: Logitech K260
  • Like 1

Share this post


Link to post
Share on other sites

-

Share this post


Link to post
Share on other sites

-

Share this post


Link to post
Share on other sites

-

Share this post


Link to post
Share on other sites

I can drive a car, however building one is beyond me.

 

I’ve used Macintosh’s since my first. Which was a Macintosh IIfx and Mac OS 6.7

 

Only in the last few weeks did I discover ktext’s even then I didn’t know where…

 

Thanks for the information. It all help’s.

 

Bruce

  • Like 1

Share this post


Link to post
Share on other sites

 

hi i am from Venezuela sorry if the translation is not good but I'll try to tell my problem: install mac 10.9 on my pc but I have problem, after it finishes installing, when in the screen that asks you to select the country the system hangs. 

(if anyone has any configuration to install 10.9 on the PC MAC) 
my pc: 
* Motherboard: M5A97 R2.0 
* Processor: AMD FX 8320 
* Video Card: Nvidia 760 SOTAC 
* G.Skill DDR3 Memorio: 8GB 1886Mhz x2 
* Hard Drive: 320GB seagate 
* Wireless Keyboard: Logitech K260

 

I solved freeze by removing AppleIntelCPU*.kexts

 

-x -s -v

 

then attach and mount as root file system

 

then

 

chown -R root:wheel /System/Library/Extensions/AppleIntelCPU*

 

and remove AppleIntelCPU*

 

mv /System/Library/Extensions/AppleIntelCPU* /

 

then fix permissions using diskutil and reboot

 

diskutil restorepermissions <your drive>

 

reboot

 

also, you can also add some custom Ehernet kexts at previos steps, as of my e2200 Killer Network, at MSI A88X-E45 Gaming

Share this post


Link to post
Share on other sites

What are the complete steps to boot with -v-x-f?

Share this post


Link to post
Share on other sites

or -x-s-v

Share this post


Link to post
Share on other sites

How to

 

My Spec

 

CPU: AMD FX-8320

MB: Asus M5A99X EVO R2.0

GPU: Nvidia GTX 780

 

Share this post


Link to post
Share on other sites

 

hi i am from Venezuela sorry if the translation is not good but I'll try to tell my problem: install mac 10.9 on my pc but I have problem, after it finishes installing, when in the screen that asks you to select the country the system hangs. 

(if anyone has any configuration to install 10.9 on the PC MAC) 
my pc: 
* Motherboard: M5A97 R2.0 
* Processor: AMD FX 8320 
* Video Card: Nvidia 760 SOTAC 
* G.Skill DDR3 Memorio: 8GB 1886Mhz x2 
* Hard Drive: 320GB seagate 
* Wireless Keyboard: Logitech K260

 

 

I've got same mobo and processor with HD7970 on reboot i used the flags -> GraphicsEnabler=No -f -v it will then boot fine, enter your setup details then let the Niresh installer finish it's job.

When you first install i use flags -> amdfx -v

erase HDD, then select HDD for install and customise, select Graphics and untick GraphicsEnabler=Yes...

Mine work great, but No imessage or icloud, trying to figure out how to update to 10.9.5 without problems.. HTH :)

 

Apologies just noticed you have an nvidia card so maybe your GraphicsEnabler is ok, so use flags -f -v GL

Share this post


Link to post
Share on other sites

Niresh 10.9.3 users on AMD (I am running an AMD FX8350)

 

HOW TO UPDATE TO 10.9.4!

 

Backup Audio and other custom kexts

Backup your Kernel (If you dont you wont be able to boot after the update,that was my experience)

Install the update from the app store

Restart

If it doesnt boot with -f then copy the backup of you kernel into the root of you mac drive (maybe using an second mac install or windows with Paragon HFS+ trial) and all your kexts into extensions dir (Most important are sandbox.kext,AppleMatch.kext and System.kext but may be different for your System.)

Now it should boot with -v -x -f,if it still wont boot,boot your install disk and repair permissions using disk utility.

boot with -v -x -f after it boots up use kextbeast to repair your kexts and repair permissions using disk utility in mac os

Reboot with -v (and your usual kernel flags if you used them before the update) and enjoy your hackintosh

 

If you experience a black screen and restart after entering the boot flags and pressing enter then download the latest mach kernel and place it in the root of your mac os drive.

 

I hope that this helps someone and this is only based on my experience with this! If I posted in the wrong section of the forum please move it!

hi Chris

 

This is system config

Processor: AMD FX-8350 Eight-Core

Board: 990FXA-GD65 (MS-7640) 3.0(MSI Mother board)

NVIDIA GeForce GTX 650 Ti [Display adapter]

 

when system getting stuck(Hang) some time after updating  Niresh 10.9.0 to 10.9.4 , i copy the kernel from niresh web site here is the link

https://www.hackintoshzone.com/files/file/508-mach-kernel-for-amd-fx-processors-1094-mavericks/

 

 

it was sucessfully updates but its getting stuck plz help me to resolve this

Share this post


Link to post
Share on other sites

this is a solution I' ve found on internet in order to fix blank screen post istallation:

 

boot with -s parameter

at the prompt type :

 

fsck -fy   
...............press enter  than type
 
mount -uw /
 
..............and press enter  than type
 
grafix backup all
 
...................and press enter.
 
 
this will move your grafix kext to a backup folder
and enable VESA mode.
reboot and install the graphic kext for your video card
 
This worked for me.

Share this post


Link to post
Share on other sites

ok

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.30 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • @riddlemeright You have not posted any pictures regarding ACPI Error, without pictures I can not debug Also you need to post your full hardware specs
    • @Douglas Dreer use ATH9KFixup.kext with Lilu.kext also you need to add -ath9485 as boot-flag in clover config
    • @tdtech959 Without any pictures of kernel panic it is really hard to debug, but anyhow have you installed whatevergreen.kext with lilu.kext   i had a weird kernel panic when my onboard graphics was turned on, I was able to select external graphics card via BIOS settings as default. are you sure if the USB is the actual problem.
    • Has anyone managed to run the atheros 9485 run on Mojave? I even managed to make it recognize, but it can not find any network.
    • Hello everyone  I have installed High Sierra and updated to 10.13.6 before installing nVidea web drivers. After everything was installed (Kexts and the driver) everything booted fine. Graphics worked perfectly. My onboard USB did not work but I have some generic NEC USB 2.0 card that works fine. After a reboot later in the day, I had a weird kernel panic. It spit out strings no longer than 30 charters and then proceeded to reboot. I have not seen this type of panic . This happened when using the onboard USB 3.0 controller but was fixed by removing the device. But now I'm not sure what caused this. I have reinstalled about 15 times already. Here are my specs: ASUS B150 Plus D3 Intel Pentium G4400 ZOTAC GeForce GTX 1050 2GB WD Blue 500GB HDD 8GB Ram Some generic wireless card (That works) Thanks -T
  • Download Statistics

    • Files
      855
    • Comments
      2,148
    • Reviews
      2,610

    Latest File
    By Niresh

    166    2

×