Jump to content
edinfredin

fix intel hd 620 graphics Catalina

Recommended Posts

edinfredin

I installed Mac OS Catalina and my intel hd 620 graphics are registered with only 7mb vram (like shown in this: image).I tried some solutions from online but then I was getting a endless reboot loop.So I am asking here: How to accelerate intel hd 620 graphics in catalina?

 

Thanks so much for helping

  • Like 1

Share this post


Link to post
Share on other sites
Yughost

HI!

Try to add this code to config.plist (to section Properties):

 

<key>Properties</key>
        <dict>
            <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>AAPL,GfxYTile</key>
                <data>
                AQAAAA==
                </data>
                <key>AAPL,ig-platform-id</key>
                <data>
                AAAWWQ==
                </data>
                <key>device-id</key>
                <data>
                FlkAAA==
                </data>
                <key>disable-external-gpu</key>
                <data>
                AQAAAA==
                </data>
                <key>enable-hdmi20</key>
                <data>
                AQAAAA==
                </data>
                <key>framebuffer-con1-alldata</key>
                <data>
                AQUJAAAIAACHAQAAAgQKAAAEAACHAQAA
                </data>
                <key>framebuffer-con1-enable</key>
                <data>
                AQAAAA==
                </data>
                <key>framebuffer-patch-enable</key>
                <data>
                AQAAAA==
                </data>
                <key>framebuffer-stolenmem</key>
                <data>
                AAAwAQ==
                </data>
            </dict>
        </dict>

 

 

Share this post


Link to post
Share on other sites
SteveMoretz

@Yughost 

 

Sorry I have the same problem

 

<key>Properties</key>

 

I couldn't find that would you please share a bigger portion of config.plist so we get where exactly that is??Thank you

Share this post


Link to post
Share on other sites
SteveMoretz

Sorry I have uhd 620 would you please create one of these for me?

Share this post


Link to post
Share on other sites
Yughost

"Properties" is subsection in "Device" section. 

 

P.S. I'm sorry but I'm a newbie also...

 

	<key>Devices</key>
	<dict>
		<key>Properties</key>
		<dict>
			<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
			<dict>
				<key>AAPL,GfxYTile</key>
				<data>AQAAAA==</data>
				<key>AAPL,ig-platform-id</key>
				<data>AAAWWQ==</data>
				<key>device-id</key>
				<data>FlkAAA==</data>
				<key>disable-external-gpu</key>
				<data>AQAAAA==</data>
				<key>enable-hdmi20</key>
				<data>AQAAAA==</data>
				<key>framebuffer-con1-alldata</key>
				<data>AQUJAAAIAACHAQAAAgQKAAAEAACHAQAA</data>
				<key>framebuffer-con1-enable</key>
				<data>AQAAAA==</data>
				<key>framebuffer-patch-enable</key>
				<data>AQAAAA==</data>
				<key>framebuffer-stolenmem</key>
				<data>AAAwAQ==</data>
			</dict>
		</dict>
	</dict>

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Yughost

For disable MX150 (I saw your question in other topic) try to add to "Boot" section string '-wegnoegpu'

 

For example, this part of "Boot" section:

 

	<key>Boot</key>
	<dict>
		<key>Arguments</key>
		<string>-v dart=0 darkwake=0 -wegnoegpu</string>

 

  • Thanks 1

Share this post


Link to post
Share on other sites
SteveMoretz
On 2/17/2020 at 9:36 PM, Yughost said:

"Properties" is subsection in "Device" section. 

 

P.S. I'm sorry but I'm a newbie also...

 


	<key>Devices</key>
	<dict>
		<key>Properties</key>
		<dict>
			<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
			<dict>
				<key>AAPL,GfxYTile</key>
				<data>AQAAAA==</data>
				<key>AAPL,ig-platform-id</key>
				<data>AAAWWQ==</data>
				<key>device-id</key>
				<data>FlkAAA==</data>
				<key>disable-external-gpu</key>
				<data>AQAAAA==</data>
				<key>enable-hdmi20</key>
				<data>AQAAAA==</data>
				<key>framebuffer-con1-alldata</key>
				<data>AQUJAAAIAACHAQAAAgQKAAAEAACHAQAA</data>
				<key>framebuffer-con1-enable</key>
				<data>AQAAAA==</data>
				<key>framebuffer-patch-enable</key>
				<data>AQAAAA==</data>
				<key>framebuffer-stolenmem</key>
				<data>AAAwAQ==</data>
			</dict>
		</dict>
	</dict>

 

You seem like a pro to me.There was no Properties section I created on and added your code even tough I'm using intel uhd 620 not hd 620 it worked perfectly.
 

 

On 2/17/2020 at 9:47 PM, Yughost said:

For disable MX150 (I saw your question in other topic) try to add to "Boot" section string '-wegnoegpu'

 

For example, this part of "Boot" section:

 


	<key>Boot</key>
	<dict>
		<key>Arguments</key>
		<string>-v dart=0 darkwake=0 -wegnoegpu</string>

 

Very nice I've done that already but my battery drains too fast still.How can I make sure MX150 is off and not running?I want to get rid of it in macos.I found a patching tutorial which clamied to do so.But first I'd like to know if it is off or on.Because the patching seems to be too card.

Share this post


Link to post
Share on other sites
edinfredin

So I fixed it the solution is to replace the whole config.plist with the plist from this GitHub repository: https://github.com/RehabMan/OS-X-Clover-Laptop-Config

 

just name the config.plist file something like config2.plist and name the new plist file config.plist

 

Hope it helped

Share this post


Link to post
Share on other sites
himanshu_sharma88

@edinfredin

 

Hello There, 

 

I just wanted to ask if other things are working as well. Like audio and Bluetooth USB tethering and other things. 

 

I have used Catalina in the past and due toh Graphics issue i switched back to windows. 

 

Previously i installed it on a separate SSD. I no longer have that now. I just want to know if everything works (except the wifi I know it won't). Otherwise i would be stuck with Catalina only. 

 

Please let me know. Thanks in advance. 

 

Share this post


Link to post
Share on other sites
edinfredin

for me everithing works except wifi but thats diffrent for every mashine

 

hope it helped

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...