Jump to content
Sign in to follow this  
Dodior

Fix: Stuttering Sound With Amd Cpu (10.9 & 10.8)

Recommended Posts

Hey everybody.This is a quick way to fix stuttering Audio will start to stutter - thats why you have clear sound when you move your mouse around.

 

Now for me, i try'd different kext's and solutions like activating SSE2 on Voodoo PrefPane and almost every other solution that is floating around on the Interwebs.

 

So im using a Quadcore AMD Cpu , and my way to "fix" this bug is to put the CPU usage on 100%.

But since you're using multiple Cpu's your performance won't go down. For example i can still run everything very fast and crisp, even games still run without any problems. Long story short > i noticed no difference in performance.But this might change on a different AMD CPU . So try it on your own risk. But let me assure (this won't brick your OSX Installation its just a terminal command).

 

 

Step1. Open Terminal.app

Step2. "yes > /dev/null" without quotation marks into terminal app.

Step3. Press Enter and enjoy proper Audio.

How to Disable:   "no > /dev/null"  without quotation marks into Terminal app.

 

 

Note: Terminal have to run as long as you want to have this "Fix" applied.

When you close Terminal, it resets itself. So just start the command and minimize Terminal !

 

 

 

 

YouTube Video Proof i did:

Enjoy and have a nice day! And much thanks to Niresh crew for providing great mackintosh distros.

  • Like 2

Share this post


Link to post
Share on other sites

This works for me, but there has to be a better way to fix this issue.  Any ideas?  I am new to the Hackintosh realm but am willing to help where I can.  I have a Phenom2 x4 965.  Everything else works perfect except the crackling Audio.

Share this post


Link to post
Share on other sites

This works for me also. Thanks a lot was losing hope lol. Is there any way to have this automatically applied during startup? This This way it does not have to be done manualy every start up.

Share this post


Link to post
Share on other sites

Niresh 10.9 everything works but can't fix Audio in all 3 different sound cards... 

Maybe a late response but i have the same motherboard and CPU as you and i was also screwing with it for 2 days.

Here is the FIX:

  • Enter the Bios from your motherboard.
  • Go to Jumpfree/CPU config > DISABLE "AMD TURBO CORE"
  • Do this fix and it will work! :)

I think many people with processors that have AMD Turbo Core have the same issue, and i think this needs to be set in the Niresh Install Guide

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...