Jump to content
Sign in to follow this  

ALC889 and HD 6870 issue.

Recommended Posts

Hello guys,


So, I successfully installed Mavericks 10.9.0 with default the costume settings because which they work great apart from 2 things.


First of all I would like to tell you what I have done until now regarding OS X:

1) The only thing I have installed is the AMD install Helper 1.1.1 using the Mavericks kernel inside which fixes some small issues.

2) I have set in org.chameleon.Boot.plist the GraphicsEnabler to no.



- The first and most important issue I would like to fix is the sound. My motherboard uses ALC889 codec and from what I read a lot of people have problems with it.

My current kexts I use are the default in Mavericks installation usb. My sound in shattered, laggy, shitty and I cannot hear anything to be honest, also when I play something I think that the performance of OS X is dropping a bit. I only have sound (or whatever is that I am hearing) in the green rear port.

What I have tried until now: 1) Slytherin and multibeast and some patched AppleHDA on top of the default kexts from the installation. 

                                             2) Slytherin and multibeast some patched AppleHDA on a clean install without any kext for sound. That had as a result to get "No output devices found" in System Preferences > Sound.

                                             3) Have tickled with settings in Audio HDMI setup with 1) and I get a lot of loud unbearable static. 



- My second problem is with my graphics card. After the AMD Install Helper 1.1.1 I have seen a lot of small but nice to see improvements and I also have ran some benchmarks. The graphics are not that bad, but are not that good either. In ultra settings except multisample I get around 30 FPS. For example I tried to play some games and instead of ultra settings graphics I have to use low.

What I have tied until now: 1) I have just tried some kexts from several sites/ forums and the result of those was OS X not booting, OS X loading infinitely. 



My System Specs are:


Motherboard: Gigabyte 990FXA-D3 (with ALC889 Audio codec)

CPU: AMD Phenom II 960T

GPU: XFX Radeon HD 6870 Black Edition (non-flashed, I do NOT know how to flash it and I have read that some people got great results without flashing the 6870, in older OS X versions at least)

The graphics card is connected to the screen via an HDMI cable, I do NOT know if that has something to do with the sound

SSD: Sandisk 128Gb Ultra Plus (AHCI)





Thank you all for the help in advance and I hope we help some other people too. 

Share this post

Link to post
Share on other sites

I found a solution for the sound.

1) Uninstall VoodooHDA kext, remove voodoo from System Preferences and Application. 

2) Shutdown your system, do not restart. (it is safer).

3) Install voodoo 2.7.3 (I did it from Multibeast).

4) Shutdown again and reopen.

5) If you don't have sound go to System Preferences > Sound > Sound Effect and select your port and > Output and select the same port.

(if you have static noise there are solutions in youtube or other sites)

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...