Jump to content
GiandeFreitas

Error with IntelHD 4000 and Nvidia 635M combo

Recommended Posts

Hey guys, 
 
I have an ASUS laptop S550C
Intel-Core i5-3317U
IntelHD4000 and Nvidia 635M
8GB ram
1Tb HDD+ 24GB SSD
 
First off I don't know whether or not this is important but I'm using a program called EasyBCD to get to my BIOS
Since my computer boots on the SSD it's almost impossible to hit whatever F key to get there.
 
This is pretty much my error when I try to start it

1398976099__image.jpeg

 

Basically if I press any button it will get stuck at the mac loading screen forever.

I've been able to actually get in by using the -x feature, So before pressing enter I typed in GraphicsEnabler= No -x 

And I got in but on safe mode, really shitty resolution and extremely annoying mouse sensitivity no mousepad access and keyboard I got access to after Niresh finished installing. Unfortunately if I shutdown or restart I am back at square one, So I can't start it without safe mode and if I do use safe mode I have to create a user account all over again and niresh has to setup up once again.

 

Now my question here is how do I fix it?

Is it possible to fix it in safe mode?

 

I've researched this a lot and it always ended up about people saying to edit the kext files,delete files located *here*, or something along those lines.

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Okay...I tried method 2 but it feels like they've skipped something? 

Step 4 is pretty unclear to me, "Boot with USB this usb and Select Partition where you have installed OSX"

 

I am booting it from a 32Gig sandisc cruzer, that's where I have the OS installed , is it telling me to have both USB's in? when I boot with the other USB stick with clover it just stays at a black screen with a dash ( - ) and that's about it

Share this post


Link to post
Share on other sites

You must  on bios specify graphic  64 mb  shared..  

after start your book  - F2   

Share this post


Link to post
Share on other sites

You must  on bios specify graphic  64 mb  shared..  

after start your book  - F2   

I tried that and it's still a blackscreen

Basically there's 2 choices 

 

1399067528__image.jpeg

 

Lexar is the USB where I installed clover on

Sandisc Cruzer is what I use to boot the Mac

There's two options for Lexar(clover) the EUFI one doesn't do anything but just keep saying ( - )

The one where it doesn't say EUFI reacts does a line break and just types "6" then nothing happens

 

and yes I have changed it to 64Mb

Share this post


Link to post
Share on other sites

with UEFI bios you need a Efi bootloader too to switch to Clover Bootloader ..

  • Like 2

Share this post


Link to post
Share on other sites

with UEFI bios you need a Efi bootloader too to switch to Clover Bootloader ..

 

Yeah.

 

For anyone else who has this problem do the following

  • Disable CSM in your Bios ( I had to enable it in the first place to instal Mac otherwise my bios would not let me boot from any other device)
  • Now it will only detect one of the two USB's you have plugged in (clover)

For example it went from this

1399067528__image.jpeg

 

To this 

1399142456__image_2.jpeg

 

  • Boot with clover
  • Press O 
  • Go to Graphic Injector Menu and Enable InjectEDID and InjectIntel
  • to the main menu 
  • Use arrow keys to go to the right AKA the next page (I thought at first there's only 3 options)
  • and boot from your USB it will be the one with an X on the logo
  • *EDIT* before you boot from the Mac USB you have to click on the very last option" boot UEFI internal from"usb with mac name" otherwise you will get the same error as before, then the resolution changes and you will have all the buttons on one screen, proceed by clicking the 6th one. 
  • and boot from your USB it will be the one with an X on the logo
  • Like 1

Share this post


Link to post
Share on other sites

My new problem is, is that I need to use Clover Configurator to finalize this otherwise I would have to do this whole process to get the right resolution.

And it still stays at 64, just better resolution, but clover configurator requires internet connection which I don't have on mac

Share this post


Link to post
Share on other sites

don't inject edid if worked then may ,,it need to inject intelcapriFB=0 to 9 which works for read this guide 

https://www.hackintoshzone.com/apple/articles/how-to/intel-hd4000-and-haswell-igpu-r12/

and try clover configurator beta v4.1 

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.30 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • Has anyone managed to run the atheros 9485 run on Mojave? I even managed to make him recognize, but he can not find any network.
    • Hello everyone  I have installed High Sierra and updated to 10.13.6 before installing nVidea web drivers. After everything was installed (Kexts and the driver) everything booted fine. Graphics worked perfectly. My onboard USB did not work but I have some generic NEC USB 2.0 card that works fine. After a reboot later in the day, I had a weird kernel panic. It spit out strings no longer than 30 charters and then proceeded to reboot. I have not seen this type of panic . This happened when using the onboard USB 3.0 controller but was fixed by removing the device. But now I'm not sure what caused this. I have reinstalled about 15 times already. Here are my specs: ASUS B150 Plus D3 Intel Pentium G4400 ZOTAC GeForce GTX 1050 2GB WD Blue 500GB HDD 8GB Ram Some generic wireless card (That works) Thanks -T
    • did you know the RX580 sapphire works out of the box to get it to work just let the pc go to sleep and thin wake it up make sure all monitors are hooked  up before you boot up the system. let me know how it works for you. here is the specs of my machine    HP Z800 2 x 3.07 GHz 6-Core Intel Xeon 16 GB 1333 MHz DDR3 Radeon RX 580 8192 MB 2 monitors and a 60 inch samsung uhd tv   thank you all for reading my post I have ben working in apple products for years and hackintosh from the beginning .
    • (MAC & PC) macOS Multi Boot USB Project [KEAL-kealOS’es] – Kemal ALKIN – RAW Image   Support – Apple Macintosh | PC (CLOVER Bootloader/Önyükleyicisi UEFI & Legacy BIOS) – Destekler. SSD NVME & SSD TRIM Desteği / Support : CLOVER | Apple Macintosh (SSD Trim Terminal.app Command: “sudo trimforce enable“) (Kernel & Prelinkedkernel) AMD / Ryzen CPU (İşlemci) | Intel CPU (İşlemci) Native/Doğal Destekler – Support macOS versions/sürümleri: (MBR: Master Boot Record – GPT: Guid Partition Table) Mavericks 10.9.5 – MBR & GPT (AMD/Ryzen + Intel Native) Yosemite 10.10.5 – MBR & GPT (AMD/Ryzen + Intel Native) EL Capitan 10.11.6 – MBR & GPT (AMD/Ryzen + Intel Native) Sierra 10.12.6 – MBR & GPT (AMD/Ryzen + Intel Native) High Sierra 10.3.3 – GPT (Stable AMD/Ryzen + Intel Native) High Sierra 10.13.6 – GPT (AMD/Ryzen Test + Intel Native) Mojave 10.14.1 – GPT (Intel Native)   Needs/Gerekenler: 64GB/64GB+ USB | 7-Zip/WinRAR | Win32DiskImager/Transmac   Download / İndir : GoogleDrive  
    • @Niresh - any chance you can help?
  • Download Statistics

    • Files
      855
    • Comments
      2,148
    • Reviews
      2,610

    Latest File
    By Niresh

    163    2

×