Jump to content
HARAN Gopal

Mavericks boot error after installation of graphic card kexts

Recommended Posts

I have a hp touchsmart 520 pc-

Intel i5 2400s (4 core). Sandy bridge

Graphics card - AMD RADEON HD 6540

I have a pegatron 2AC3 motherboard

AMI BIOS v.7.08

6 GB ram

I am able to run mavericks with boot flag GraphicsEnabler=No immediately after installation. But i get only a 3 mb video card with bad graphics . I found that my graphic kexts were missing so i downloaded them but they downloads section in this site . But , after installation and when i boot up i always get to a set of screen after the apple logo - these set of colours appear -black , red , green , blue , grey ( pictures below ) . I have tried many boot flags like - graphicsenabler=no , -x , -v , -s (mount uw) all that found in previous posts . But ended up with same result . I have reinstalled mavericks more than 9-10 times . But this occurs only after i install the graphics kext (amdcontroller6xxx.kext) . So any help will be appreciated . I am also dual booting with windows and windows works fine. Sometimes immediately after installation when i boot the hard disk it gets stuck at the apple logo but they os runs at the background (the music , keystrokes , etc). So any help will be appreciated. Hoping for a reply . Thanks in advance.

post-50802-0-51419900-1398783054_thumb.j

post-50802-0-90981200-1398783068_thumb.j

post-50802-0-07183700-1398783084_thumb.j

post-50802-0-57238700-1398783095_thumb.j

Share this post


Link to post
Share on other sites

About the last before sentence thats when i am booting mavericks for the first time with boot flag ( GraphicsEnabler=Yes ).

Share this post


Link to post
Share on other sites

UPDATE: i have changed my resolution to 1920x1080x32 and i get a good resolution and the graphics increases to 7 mb ( i did this after reinstall ) . I installed the graphics kext again from this site : http://www.osx86.net/file/1046-ati-radeon-6450-hd-fix-for-mountain-lion-dp4-gm/

And i again get to the coloured screen . Is it a problem with the kext as it is for mountail lion ? Or should i try another kext . I also tried the kext from khatphat but it has only the AMD6000Contoller.kext which doesn't change anything . After some research i found that you also need other kexts like ( AMDSupport , Accelerator/x3000 , etc)

Which i dont have. So could anyone upload the kexts please. Plus this only occurs when i install the kexts from that website. Otherwise everything is working fine except for the graphics . Thanks in advance.

Share this post


Link to post
Share on other sites

UPDATE: i thought it was a prob with 10.9 so i downloaded and installed 10.8.5 distro from niresh . The distro itself boots with good graphics and fullscreen (while installing i select backup graphics kexts ) so after booting as usual i get a 1024x724 resolution n bad graphics and after installation i get the same blinking screen just like mavericks. The os itself works perfectly fine without the graphic kexts (but without proper graphics) . As far as i know my pc is compatible and i hav seen videos on youtube on people running osx with my graphic card . So any help is appreciated . ( i dont mind doing a reinstall hav alrdy done that like 5 times a day)

Share this post


Link to post
Share on other sites

as i said before i am dual booting with windows and i see 2 options under graphics - AMD Radeon HD 6540 , Intel® HD Graphics . even if i could get the intel one working its fine with me . and i dont know whether its 3000/4000 graphics or the version of it. so any help appreaciated .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Contribute

    This is a free website, We'll try to keep it that way, Your donations and disabling Adblock makes this site going on, Thanks for understanding.



    $22.30 of $200.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • Has anyone managed to run the atheros 9485 run on Mojave? I even managed to make him recognize, but he can not find any network.
    • Hello everyone  I have installed High Sierra and updated to 10.13.6 before installing nVidea web drivers. After everything was installed (Kexts and the driver) everything booted fine. Graphics worked perfectly. My onboard USB did not work but I have some generic NEC USB 2.0 card that works fine. After a reboot later in the day, I had a weird kernel panic. It spit out strings no longer than 30 charters and then proceeded to reboot. I have not seen this type of panic . This happened when using the onboard USB 3.0 controller but was fixed by removing the device. But now I'm not sure what caused this. I have reinstalled about 15 times already. Here are my specs: ASUS B150 Plus D3 Intel Pentium G4400 ZOTAC GeForce GTX 1050 2GB WD Blue 500GB HDD 8GB Ram Some generic wireless card (That works) Thanks -T
    • did you know the RX580 sapphire works out of the box to get it to work just let the pc go to sleep and thin wake it up make sure all monitors are hooked  up before you boot up the system. let me know how it works for you. here is the specs of my machine    HP Z800 2 x 3.07 GHz 6-Core Intel Xeon 16 GB 1333 MHz DDR3 Radeon RX 580 8192 MB 2 monitors and a 60 inch samsung uhd tv   thank you all for reading my post I have ben working in apple products for years and hackintosh from the beginning .
    • (MAC & PC) macOS Multi Boot USB Project [KEAL-kealOS’es] – Kemal ALKIN – RAW Image   Support – Apple Macintosh | PC (CLOVER Bootloader/Önyükleyicisi UEFI & Legacy BIOS) – Destekler. SSD NVME & SSD TRIM Desteği / Support : CLOVER | Apple Macintosh (SSD Trim Terminal.app Command: “sudo trimforce enable“) (Kernel & Prelinkedkernel) AMD / Ryzen CPU (İşlemci) | Intel CPU (İşlemci) Native/Doğal Destekler – Support macOS versions/sürümleri: (MBR: Master Boot Record – GPT: Guid Partition Table) Mavericks 10.9.5 – MBR & GPT (AMD/Ryzen + Intel Native) Yosemite 10.10.5 – MBR & GPT (AMD/Ryzen + Intel Native) EL Capitan 10.11.6 – MBR & GPT (AMD/Ryzen + Intel Native) Sierra 10.12.6 – MBR & GPT (AMD/Ryzen + Intel Native) High Sierra 10.3.3 – GPT (Stable AMD/Ryzen + Intel Native) High Sierra 10.13.6 – GPT (AMD/Ryzen Test + Intel Native) Mojave 10.14.1 – GPT (Intel Native)   Needs/Gerekenler: 64GB/64GB+ USB | 7-Zip/WinRAR | Win32DiskImager/Transmac   Download / İndir : GoogleDrive  
    • @Niresh - any chance you can help?
  • Download Statistics

    • Files
      855
    • Comments
      2,148
    • Reviews
      2,610

    Latest File
    By Niresh

    166    2

×